aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-09-08 15:29:00 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-09-19 09:03:22 +0000
commiteeb4b50dde8f23b2513958e5031d40a1057c7782 (patch)
treef3d1ada561427e2808bb386571043c17609e388c /deskutils
parent93924a20b38e7856dc1a0df0c4514eaecdb624be (diff)
downloadports-eeb4b50dde8f23b2513958e5031d40a1057c7782.tar.gz
ports-eeb4b50dde8f23b2513958e5031d40a1057c7782.zip
Uses/cargo: Unbreak ports with CARGO_BUILD_TARGET set
While here fix their WITH_DEBUG builds too.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/solanum/files/patch-build-aux_cargo.sh16
1 files changed, 16 insertions, 0 deletions
diff --git a/deskutils/solanum/files/patch-build-aux_cargo.sh b/deskutils/solanum/files/patch-build-aux_cargo.sh
new file mode 100644
index 000000000000..86989835971b
--- /dev/null
+++ b/deskutils/solanum/files/patch-build-aux_cargo.sh
@@ -0,0 +1,16 @@
+--- build-aux/cargo.sh.orig 2021-09-08 15:16:18 UTC
++++ build-aux/cargo.sh
+@@ -14,11 +14,11 @@ then
+ echo "RELEASE MODE"
+ cargo build --manifest-path \
+ "$MESON_SOURCE_ROOT"/Cargo.toml --release && \
+- cp "$CARGO_TARGET_DIR"/release/"$APP_BIN" "$OUTPUT"
++ cp "$CARGO_TARGET_DIR"/$CARGO_BUILD_TARGET/release/"$APP_BIN" "$OUTPUT"
+ else
+ echo "DEBUG MODE"
+ cargo build --manifest-path \
+ "$MESON_SOURCE_ROOT"/Cargo.toml --verbose && \
+- cp "$CARGO_TARGET_DIR"/debug/"$APP_BIN" "$OUTPUT"
++ cp "$CARGO_TARGET_DIR"/$CARGO_BUILD_TARGET/debug/"$APP_BIN" "$OUTPUT"
+ fi
+