aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-19 14:59:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-19 14:59:04 +0000
commit5250a0223f5f85fb069fd1b0607fca011db56932 (patch)
treedcc1b6033bcd597011f464a4cca1451c5cfe43c1 /deskutils
parent035c76c438571f033d2bbf874d9bbfa031065d5c (diff)
downloadports-5250a0223f5f85fb069fd1b0607fca011db56932.tar.gz
ports-5250a0223f5f85fb069fd1b0607fca011db56932.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/google-gadgets/Makefile5
-rw-r--r--deskutils/google-gadgets/distinfo6
-rw-r--r--deskutils/google-gadgets/files/patch-configure.ac16
-rw-r--r--deskutils/google-gadgets/files/patch-extensions_gst__video__element_gadget__videosink.cc (renamed from deskutils/google-gadgets/files/patch-extensions_gst__mediaplayer__element_gadget__videosink.cc)34
-rw-r--r--deskutils/google-gadgets/files/patch-extensions_gst__video__element_gst__video__element.cc (renamed from deskutils/google-gadgets/files/patch-extensions_gst__mediaplayer__element_gst__mediaplayer__element.cc)90
-rw-r--r--deskutils/google-gadgets/files/patch-extensions_linux__system__framework_file__system.cc66
-rw-r--r--deskutils/google-gadgets/files/patch-gadgets_designer_designer__script__utils.cc14
-rw-r--r--deskutils/google-gadgets/files/patch-ggadget_gtk_utilities.cc14
-rw-r--r--deskutils/google-gadgets/files/patch-ggadget_qt_utilities.cc14
-rw-r--r--deskutils/google-gadgets/pkg-plist39
10 files changed, 136 insertions, 162 deletions
diff --git a/deskutils/google-gadgets/Makefile b/deskutils/google-gadgets/Makefile
index 7312e8cc2f0e..d5420b7d4c41 100644
--- a/deskutils/google-gadgets/Makefile
+++ b/deskutils/google-gadgets/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= google-gadgets
-PORTVERSION= 0.10.0
-PORTREVISION= 1
+PORTVERSION= 0.10.2
CATEGORIES= deskutils
MASTER_SITES= http://google-gadgets-for-linux.googlecode.com/files/
DISTNAME= ${PORTNAME}-for-linux-${PORTVERSION}
@@ -31,6 +30,7 @@ LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/firefox-js.pc:${PORTSDIR}/www/firefox \
${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
+USE_BZIP2= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_GCC= 4.2+
@@ -41,6 +41,7 @@ CONFIGURE_ARGS= --enable-ltdl-install=no
USE_AUTOTOOLS= libtool:15:env autoconf:262:env automake:110:env aclocal:110:env libltdl:15
WANT_GNOME= yes
USE_GNOME= gnomehack
+INSTALLS_ICONS= yes
OPTIONS= DEBUGGING "Enable debug output on runtime" on\
GTK "Build GTK Host" on\
diff --git a/deskutils/google-gadgets/distinfo b/deskutils/google-gadgets/distinfo
index 309256aabd82..871b8b52510c 100644
--- a/deskutils/google-gadgets/distinfo
+++ b/deskutils/google-gadgets/distinfo
@@ -1,3 +1,3 @@
-MD5 (google-gadgets-for-linux-0.10.0.tar.gz) = 315406fe83ab05d31e48200e07344496
-SHA256 (google-gadgets-for-linux-0.10.0.tar.gz) = 5367a44d47d60e31fc17dc43b7b1e1d393147bd901cb8c24f7975781e4abed5a
-SIZE (google-gadgets-for-linux-0.10.0.tar.gz) = 2499027
+MD5 (google-gadgets-for-linux-0.10.2.tar.bz2) = 0822bb6294cff0b8aa9830a13c2dd06d
+SHA256 (google-gadgets-for-linux-0.10.2.tar.bz2) = 0429408cd215dc8cb33c6fda31c65425366597426e3679004633b874f8fed164
+SIZE (google-gadgets-for-linux-0.10.2.tar.bz2) = 2188977
diff --git a/deskutils/google-gadgets/files/patch-configure.ac b/deskutils/google-gadgets/files/patch-configure.ac
index c5a1be701e95..027e4c820532 100644
--- a/deskutils/google-gadgets/files/patch-configure.ac
+++ b/deskutils/google-gadgets/files/patch-configure.ac
@@ -3,7 +3,7 @@ $FreeBSD$
--- configure.ac.orig
+++ configure.ac
-@@ -334,6 +334,13 @@
+@@ -371,6 +371,13 @@
GGL_PLATFORM_SHORT=\"linux\"
GGL_PLATFORM=\"linux\"
;;
@@ -17,7 +17,7 @@ $FreeBSD$
*solaris* )
ggl_host_type=solaris
PREDEFINED_MACROS="$PREDEFINED_MACROS -DGGL_HOST_SOLARIS=1"
-@@ -352,6 +359,7 @@
+@@ -389,6 +396,7 @@
AM_CONDITIONAL([GGL_HOST_MACOSX], [test x$ggl_host_type = xmacosx])
AM_CONDITIONAL([GGL_HOST_LINUX], [test x$ggl_host_type = xlinux])
AM_CONDITIONAL([GGL_HOST_SOLARIS], [test x$ggl_host_type = xsolaris])
@@ -25,12 +25,12 @@ $FreeBSD$
AC_SUBST(PREDEFINED_MACROS)
AC_SUBST(DEFAULT_COMPILE_FLAGS)
-@@ -445,7 +453,7 @@
- fi
-
- # Check qt4
+@@ -489,7 +497,7 @@
+ has_qtnetwork=no
+ has_qtwebkit=no
+ has_qtscript=no
-if test x$ggl_host_type = xlinux; then
+if test x$ggl_host_type = xlinux -o x$ggl_host_type = xfreebsd; then
- PKG_CHECK_MODULES(QT4, [QtGui >= 4.3, QtCore >= 4.3, QtOpenGL >= 4.3,
- QtNetwork >= 4.3],
+ PKG_CHECK_MODULES(QT4, [QtGui >= 4.3 QtCore >= 4.3 QtNetwork >= 4.3],
[has_qt4=yes
+ MOC=`$PKG_CONFIG --variable=moc_location QtCore`],
diff --git a/deskutils/google-gadgets/files/patch-extensions_gst__mediaplayer__element_gadget__videosink.cc b/deskutils/google-gadgets/files/patch-extensions_gst__video__element_gadget__videosink.cc
index 2b1a7798c7ad..058667ecd2d8 100644
--- a/deskutils/google-gadgets/files/patch-extensions_gst__mediaplayer__element_gadget__videosink.cc
+++ b/deskutils/google-gadgets/files/patch-extensions_gst__video__element_gadget__videosink.cc
@@ -1,22 +1,9 @@
$FreeBSD$
---- extensions/gst_mediaplayer_element/gadget_videosink.cc.orig
-+++ extensions/gst_mediaplayer_element/gadget_videosink.cc
-@@ -17,6 +17,12 @@
- #include "gadget_videosink.h"
- #include <pthread.h>
-
-+#if __GNUC__ < 4
-+#define CAST_HACK(x) (x)
-+#else
-+#define CAST_HACK(x) reinterpret_cast<x>
-+#endif
-+
- namespace ggadget {
- namespace gst {
-
-@@ -454,10 +460,10 @@
+--- extensions/gst_video_element/gadget_videosink.cc.orig
++++ extensions/gst_video_element/gadget_videosink.cc
+@@ -459,10 +459,10 @@
nom = gst_value_get_fraction_numerator(videosink->par_);
den = gst_value_get_fraction_denominator(videosink->par_);
gst_structure_set(structure, "pixel-aspect-ratio",
@@ -29,7 +16,7 @@ $FreeBSD$
}
}
-@@ -669,18 +675,18 @@
+@@ -672,18 +672,18 @@
desired_caps = gst_caps_copy(caps);
desired_struct = gst_caps_get_structure(desired_caps, 0);
@@ -44,7 +31,7 @@ $FreeBSD$
den = gst_value_get_fraction_denominator(videosink->par_);
gst_structure_set(desired_struct, "pixel-aspect-ratio",
- GST_TYPE_FRACTION, nom, den, NULL);
-+ GST_TYPE_FRACTION, nom, den, (gchar*)0);
++ GST_TYPE_FRACTION, nom, den, (gchar*)0);
} else {
gst_structure_set(desired_struct, "pixel-aspect-ratio",
- GST_TYPE_FRACTION, 1, 1, NULL);
@@ -52,16 +39,7 @@ $FreeBSD$
}
// see if peer accepts our new suggestion, if there is no peer, this
-@@ -859,7 +865,7 @@
- g_value_transform(videosink->par_, value);
- break;
- case PROP_RECEIVE_IMAGE_HANDLER:
-- g_value_set_pointer(value, reinterpret_cast<void*>(&ReceiveImageHandler));
-+ g_value_set_pointer(value, CAST_HACK(void*)(&ReceiveImageHandler));
- break;
- default:
- G_OBJECT_WARN_INVALID_PROPERTY_ID(object, prop_id, pspec);
-@@ -892,7 +898,7 @@
+@@ -895,7 +895,7 @@
nom = gst_value_get_fraction_numerator(par_);
den = gst_value_get_fraction_denominator(par_);
gst_caps_set_simple(caps_, const_cast<gchar*>("pixel-aspect-ratio"),
diff --git a/deskutils/google-gadgets/files/patch-extensions_gst__mediaplayer__element_gst__mediaplayer__element.cc b/deskutils/google-gadgets/files/patch-extensions_gst__video__element_gst__video__element.cc
index d2d9fd5cdbf4..1ead87bc2162 100644
--- a/deskutils/google-gadgets/files/patch-extensions_gst__mediaplayer__element_gst__mediaplayer__element.cc
+++ b/deskutils/google-gadgets/files/patch-extensions_gst__video__element_gst__video__element.cc
@@ -1,9 +1,9 @@
$FreeBSD$
---- extensions/gst_mediaplayer_element/gst_mediaplayer_element.cc.orig
-+++ extensions/gst_mediaplayer_element/gst_mediaplayer_element.cc
-@@ -133,7 +133,7 @@
+--- extensions/gst_video_element/gst_video_element.cc.orig
++++ extensions/gst_video_element/gst_video_element.cc
+@@ -127,7 +127,7 @@
return;
} else {
g_object_get(G_OBJECT(videosink_),
@@ -12,7 +12,7 @@ $FreeBSD$
if (!receive_image_handler_) {
gst_object_unref(GST_OBJECT(playbin_));
gst_object_unref(GST_OBJECT(videosink_));
-@@ -143,7 +143,7 @@
+@@ -137,7 +137,7 @@
}
// Set videosink to receive video output.
@@ -21,27 +21,27 @@ $FreeBSD$
// Create new audio sink with panorama support if possible.
GstElement *audiosink = NULL;
-@@ -169,15 +169,15 @@
+@@ -163,15 +163,15 @@
GstElement *audiobin = gst_bin_new("audiobin");
GstPad *sinkpad;
if (volume_ && panorama_) {
- gst_bin_add_many(GST_BIN(audiobin), volume_, panorama_, audiosink, NULL);
- gst_element_link_many(volume_, panorama_, audiosink, NULL);
-+ gst_bin_add_many(GST_BIN(audiobin), volume_, panorama_, audiosink, (GstElement*)0);
-+ gst_element_link_many(volume_, panorama_, audiosink, (GstElement*)0);
++ gst_bin_add_many(GST_BIN(audiobin), volume_, panorama_, audiosink, (gchar*)0);
++ gst_element_link_many(volume_, panorama_, audiosink, (gchar*)0);
sinkpad = gst_element_get_pad(volume_, "sink");
} else if (volume_) {
- gst_bin_add_many(GST_BIN(audiobin), volume_, audiosink, NULL);
-+ gst_bin_add_many(GST_BIN(audiobin), volume_, audiosink, (GstElement*)0);
++ gst_bin_add_many(GST_BIN(audiobin), volume_, audiosink, (gchar*)0);
gst_element_link(volume_, audiosink);
sinkpad = gst_element_get_pad(volume_, "sink");
} else {
- gst_bin_add_many(GST_BIN(audiobin), panorama_, audiosink, NULL);
-+ gst_bin_add_many(GST_BIN(audiobin), panorama_, audiosink, (GstElement*)0);
++ gst_bin_add_many(GST_BIN(audiobin), panorama_, audiosink, (gchar*)0);
gst_element_link(panorama_, audiosink);
sinkpad = gst_element_get_pad(panorama_, "sink");
}
-@@ -187,7 +187,7 @@
+@@ -181,7 +181,7 @@
}
// Set audio-sink to our new audiosink.
@@ -50,44 +50,35 @@ $FreeBSD$
// Watch the message bus.
// The host using this class must use a g_main_loop to capture the
-@@ -262,7 +262,7 @@
- if (src_.compare(new_src_) != 0) {
- src_ = new_src_;
+@@ -361,7 +361,7 @@
+
+ src_ = src;
media_changed_ = true;
- g_object_set(G_OBJECT(playbin_), "uri", src_.c_str(), NULL);
+ g_object_set(G_OBJECT(playbin_), "uri", src_.c_str(), (gchar*)0);
-
- // Empty the tag cache when loading a new media.
- if (tag_list_) {
+ if (GetAutoPlay())
+ Play();
+ }
@@ -370,7 +370,7 @@
- void GstMediaPlayerElement::SetGeometry(int width, int height) {
- if (playbin_ && videosink_) {
- g_object_set(G_OBJECT(videosink_),
-- "geometry-width", width, "geometry-height", height, NULL);
-+ "geometry-width", width, "geometry-height", height, (gchar*)0);
- } else {
- if (!playbin_)
- DLOG("Playbin was not initialized correctly.");
-@@ -382,7 +382,7 @@
- int GstMediaPlayerElement::GetVolume() {
+ int GstVideoElement::GetVolume() {
if (playbin_) {
double volume;
- g_object_get(G_OBJECT(playbin_), "volume", &volume, NULL);
+ g_object_get(G_OBJECT(playbin_), "volume", &volume, (gchar*)0);
int gg_volume = static_cast<int>((volume / kMaxGstVolume) *
- (kMaxVolume - kMinVolume) +
- kMinVolume);
-@@ -404,7 +404,7 @@
- (gdouble(volume - kMinVolume) / (kMaxVolume - kMinVolume)) *
- kMaxGstVolume;
-
-- g_object_set(G_OBJECT(playbin_), "volume", gst_volume, NULL);
-+ g_object_set(G_OBJECT(playbin_), "volume", gst_volume, (gchar*)0);
+ (kMaxVolume - kMinVolume) + kMinVolume);
+ return Clamp(gg_volume, kMinVolume, kMaxVolume);
+@@ -387,7 +387,7 @@
+ }
+ gdouble gg_volume = ((gdouble(volume - kMinVolume) /
+ (kMaxVolume - kMinVolume)) * kMaxGstVolume);
+- g_object_set(G_OBJECT(playbin_), "volume", gg_volume, NULL);
++ g_object_set(G_OBJECT(playbin_), "volume", gg_volume, (gchar*)0);
} else {
DLOG("Playbin was not initialized correctly.");
}
-@@ -413,7 +413,7 @@
- int GstMediaPlayerElement::GetBalance() {
+@@ -409,7 +409,7 @@
+ int GstVideoElement::GetBalance() {
if (playbin_ && panorama_) {
gfloat balance;
- g_object_get(G_OBJECT(panorama_), "panorama", &balance, NULL);
@@ -95,17 +86,17 @@ $FreeBSD$
int gg_balance = static_cast<int>(((balance + 1) / 2) *
(kMaxBalance - kMinBalance) +
kMinBalance);
-@@ -437,7 +437,7 @@
+@@ -432,7 +432,7 @@
}
- gfloat gst_balance =
- (gfloat(balance - kMinBalance) / (kMaxBalance - kMinBalance)) * 2 - 1;
-- g_object_set(G_OBJECT(panorama_), "panorama", gst_balance, NULL);
-+ g_object_set(G_OBJECT(panorama_), "panorama", gst_balance, (gchar*)0);
+ gfloat gg_balance = (gfloat(balance - kMinBalance) /
+ (kMaxBalance - kMinBalance)) * 2 - 1;
+- g_object_set(G_OBJECT(panorama_), "panorama", gg_balance, NULL);
++ g_object_set(G_OBJECT(panorama_), "panorama", gg_balance, (gchar*)0);
} else {
if (!playbin_)
DLOG("Playbin was not initialized correctly.");
-@@ -449,7 +449,7 @@
- bool GstMediaPlayerElement::GetMute() {
+@@ -444,7 +444,7 @@
+ bool GstVideoElement::GetMute() {
if (playbin_ && volume_) {
gboolean mute;
- g_object_get(G_OBJECT(volume_), "mute", &mute, NULL);
@@ -113,12 +104,21 @@ $FreeBSD$
return static_cast<bool>(mute);
} else {
if (!playbin_)
-@@ -462,7 +462,7 @@
+@@ -457,7 +457,7 @@
- void GstMediaPlayerElement::SetMute(bool mute) {
+ void GstVideoElement::SetMute(bool mute) {
if (playbin_ && volume_) {
- g_object_set(G_OBJECT(volume_), "mute", static_cast<gboolean>(mute), NULL);
+ g_object_set(G_OBJECT(volume_), "mute", static_cast<gboolean>(mute), (gchar*)0);
} else {
if (!playbin_)
DLOG("Playbin was not initialized correctly.");
+@@ -470,7 +470,7 @@
+ if (playbin_ && videosink_) {
+ g_object_set(G_OBJECT(videosink_),
+ "geometry-width", static_cast<int>(width),
+- "geometry-height", static_cast<int>(height), NULL);
++ "geometry-height", static_cast<int>(height), (gchar*)0);
+ } else {
+ if (!playbin_)
+ DLOG("Playbin was not initialized correctly.");
diff --git a/deskutils/google-gadgets/files/patch-extensions_linux__system__framework_file__system.cc b/deskutils/google-gadgets/files/patch-extensions_linux__system__framework_file__system.cc
index ae291423afba..4c09753c7554 100644
--- a/deskutils/google-gadgets/files/patch-extensions_linux__system__framework_file__system.cc
+++ b/deskutils/google-gadgets/files/patch-extensions_linux__system__framework_file__system.cc
@@ -3,47 +3,25 @@ $FreeBSD$
--- extensions/linux_system_framework/file_system.cc.orig
+++ extensions/linux_system_framework/file_system.cc
-@@ -356,8 +356,8 @@
- if (stat(path_.c_str(), &statbuf))
- return Date(0);
-
-- return Date(statbuf.st_mtim.tv_sec * 1000
-- + statbuf.st_mtim.tv_nsec / 1000000);
-+ return Date(statbuf.st_mtimespec.tv_sec * 1000
-+ + statbuf.st_mtimespec.tv_nsec / 1000000);
- }
-
- virtual Date GetDateLastAccessed() {
-@@ -368,8 +368,8 @@
- if (stat(path_.c_str(), &statbuf))
- return Date(0);
-
-- return Date(statbuf.st_atim.tv_sec * 1000
-- + statbuf.st_atim.tv_nsec / 1000000);
-+ return Date(statbuf.st_atimespec.tv_sec * 1000
-+ + statbuf.st_atimespec.tv_nsec / 1000000);
- }
-
- virtual int64_t GetSize() {
-@@ -646,8 +646,8 @@
- if (stat(path_.c_str(), &statbuf))
- return Date(0);
-
-- return Date(statbuf.st_mtim.tv_sec * 1000
-- + statbuf.st_mtim.tv_nsec / 1000000);
-+ return Date(statbuf.st_mtimespec.tv_sec * 1000
-+ + statbuf.st_mtimespec.tv_nsec / 1000000);
- }
-
- virtual Date GetDateLastAccessed() {
-@@ -658,8 +658,8 @@
- if (stat(path_.c_str(), &statbuf))
- return Date(0);
-
-- return Date(statbuf.st_atim.tv_sec * 1000
-- + statbuf.st_atim.tv_nsec / 1000000);
-+ return Date(statbuf.st_atimespec.tv_sec * 1000
-+ + statbuf.st_atimespec.tv_nsec / 1000000);
- }
-
- virtual std::string GetType() {
+@@ -463,8 +463,8 @@
+ if (stat(path, &stat_value))
+ return Date(0);
+
+- return Date(stat_value.st_mtim.tv_sec * 1000
+- + stat_value.st_mtim.tv_nsec / 1000000);
++ return Date(statbuf.st_mtimespec.tv_sec * 1000
++ + statbuf.st_mtimespec.tv_nsec / 1000000);
+ }
+
+ static Date GetDateLastAccessed(const char *path) {
+@@ -476,8 +476,8 @@
+ if (stat(path, &stat_value))
+ return Date(0);
+
+- return Date(stat_value.st_atim.tv_sec * 1000
+- + stat_value.st_atim.tv_nsec / 1000000);
++ return Date(statbuf.st_atimespec.tv_sec * 1000
++ + statbuf.st_atimespec.tv_nsec / 1000000);
+ }
+
+ class Drive : public DriveInterface {
diff --git a/deskutils/google-gadgets/files/patch-gadgets_designer_designer__script__utils.cc b/deskutils/google-gadgets/files/patch-gadgets_designer_designer__script__utils.cc
new file mode 100644
index 000000000000..67e79e563175
--- /dev/null
+++ b/deskutils/google-gadgets/files/patch-gadgets_designer_designer__script__utils.cc
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- gadgets/designer/designer_script_utils.cc.orig
++++ gadgets/designer/designer_script_utils.cc
+@@ -231,7 +231,7 @@
+ if ((pid = fork()) == 0) {
+ if (fork() != 0)
+ _exit(0);
+- execlp(command, command, file, NULL);
++ execlp(command, command, file, (char*)0);
+ DLOG("Failed to exec command: %s", command);
+ _exit(-1);
+ }
diff --git a/deskutils/google-gadgets/files/patch-ggadget_gtk_utilities.cc b/deskutils/google-gadgets/files/patch-ggadget_gtk_utilities.cc
deleted file mode 100644
index 70ee8f17ba1e..000000000000
--- a/deskutils/google-gadgets/files/patch-ggadget_gtk_utilities.cc
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- ggadget/gtk/utilities.cc.orig
-+++ ggadget/gtk/utilities.cc
-@@ -262,7 +262,7 @@
- if (fork() != 0)
- _exit(0);
-
-- execl(xdg_open.c_str(), xdg_open.c_str(), url, NULL);
-+ execl(xdg_open.c_str(), xdg_open.c_str(), url, (char*)0);
-
- DLOG("Failed to exec command: %s", xdg_open.c_str());
- _exit(-1);
diff --git a/deskutils/google-gadgets/files/patch-ggadget_qt_utilities.cc b/deskutils/google-gadgets/files/patch-ggadget_qt_utilities.cc
deleted file mode 100644
index 11ed580a083c..000000000000
--- a/deskutils/google-gadgets/files/patch-ggadget_qt_utilities.cc
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- ggadget/qt/utilities.cc.orig
-+++ ggadget/qt/utilities.cc
-@@ -111,7 +111,7 @@
- if (fork() != 0)
- _exit(0);
-
-- execl(xdg_open.c_str(), xdg_open.c_str(), url, NULL);
-+ execl(xdg_open.c_str(), xdg_open.c_str(), url, (const char*)0);
-
- DLOG("Failed to exec command: %s", xdg_open.c_str());
- _exit(-1);
diff --git a/deskutils/google-gadgets/pkg-plist b/deskutils/google-gadgets/pkg-plist
index 5222fe6ac74f..dec41f450529 100644
--- a/deskutils/google-gadgets/pkg-plist
+++ b/deskutils/google-gadgets/pkg-plist
@@ -19,10 +19,12 @@ include/google-gadgets/ggadget/dbus/dbus_proxy.h
include/google-gadgets/ggadget/dbus/dbus_result_receiver.h
include/google-gadgets/ggadget/decorated_view_host.h
include/google-gadgets/ggadget/details_view_data.h
+include/google-gadgets/ggadget/details_view_decorator.h
include/google-gadgets/ggadget/digest_utils.h
include/google-gadgets/ggadget/dir_file_manager.h
include/google-gadgets/ggadget/display_window.h
include/google-gadgets/ggadget/div_element.h
+include/google-gadgets/ggadget/docked_main_view_decorator.h
include/google-gadgets/ggadget/edit_element_base.h
include/google-gadgets/ggadget/element_factory.h
include/google-gadgets/ggadget/elements.h
@@ -33,7 +35,9 @@ include/google-gadgets/ggadget/file_manager_factory.h
include/google-gadgets/ggadget/file_manager_interface.h
include/google-gadgets/ggadget/file_manager_wrapper.h
include/google-gadgets/ggadget/file_system_interface.h
+include/google-gadgets/ggadget/floating_main_view_decorator.h
include/google-gadgets/ggadget/font_interface.h
+include/google-gadgets/ggadget/framed_view_decorator_base.h
include/google-gadgets/ggadget/framework_interface.h
include/google-gadgets/ggadget/gadget.h
include/google-gadgets/ggadget/gadget_consts.h
@@ -49,6 +53,7 @@ include/google-gadgets/ggadget/graphics_interface.h
%%GTK%%include/google-gadgets/ggadget/gtk/utilities.h
%%GTK%%include/google-gadgets/ggadget/gtk/view_widget_binder.h
include/google-gadgets/ggadget/host_interface.h
+include/google-gadgets/ggadget/host_utils.h
include/google-gadgets/ggadget/image_cache.h
include/google-gadgets/ggadget/image_interface.h
include/google-gadgets/ggadget/img_element.h
@@ -61,14 +66,17 @@ include/google-gadgets/ggadget/locales.h
include/google-gadgets/ggadget/localized_file_manager.h
include/google-gadgets/ggadget/logger.h
include/google-gadgets/ggadget/main_loop_interface.h
+include/google-gadgets/ggadget/main_view_decorator_base.h
include/google-gadgets/ggadget/math_utils.h
-include/google-gadgets/ggadget/mediaplayer_element_base.h
include/google-gadgets/ggadget/memory_options.h
include/google-gadgets/ggadget/menu_interface.h
include/google-gadgets/ggadget/messages.h
include/google-gadgets/ggadget/module.h
include/google-gadgets/ggadget/object_element.h
+include/google-gadgets/ggadget/object_videoplayer.h
include/google-gadgets/ggadget/options_interface.h
+include/google-gadgets/ggadget/permissions.h
+include/google-gadgets/ggadget/popout_main_view_decorator.h
include/google-gadgets/ggadget/progressbar_element.h
%%QT%%include/google-gadgets/ggadget/qt/qt_graphics.h
%%QT%%include/google-gadgets/ggadget/qt/qt_main_loop.h
@@ -84,6 +92,7 @@ include/google-gadgets/ggadget/script_runtime_interface.h
include/google-gadgets/ggadget/script_runtime_manager.h
include/google-gadgets/ggadget/scriptable_array.h
include/google-gadgets/ggadget/scriptable_binary_data.h
+include/google-gadgets/ggadget/scriptable_enumerator.h
include/google-gadgets/ggadget/scriptable_event.h
include/google-gadgets/ggadget/scriptable_file_system.h
include/google-gadgets/ggadget/scriptable_framework.h
@@ -107,10 +116,14 @@ include/google-gadgets/ggadget/text_frame.h
include/google-gadgets/ggadget/texture.h
include/google-gadgets/ggadget/unicode_utils.h
include/google-gadgets/ggadget/variant.h
+include/google-gadgets/ggadget/video_element_base.h
include/google-gadgets/ggadget/view.h
+include/google-gadgets/ggadget/view_decorator_base.h
include/google-gadgets/ggadget/view_element.h
include/google-gadgets/ggadget/view_host_interface.h
include/google-gadgets/ggadget/view_interface.h
+include/google-gadgets/ggadget/xdg/desktop_entry.h
+include/google-gadgets/ggadget/xdg/utilities.h
include/google-gadgets/ggadget/xml_dom.h
include/google-gadgets/ggadget/xml_dom_interface.h
include/google-gadgets/ggadget/xml_http_request_interface.h
@@ -137,9 +150,9 @@ lib/google-gadgets/modules/google-gadget-manager.so
lib/google-gadgets/modules/gst-audio-framework.a
lib/google-gadgets/modules/gst-audio-framework.la
lib/google-gadgets/modules/gst-audio-framework.so
-lib/google-gadgets/modules/gst-mediaplayer-element.a
-lib/google-gadgets/modules/gst-mediaplayer-element.la
-lib/google-gadgets/modules/gst-mediaplayer-element.so
+lib/google-gadgets/modules/gst-video-element.a
+lib/google-gadgets/modules/gst-video-element.la
+lib/google-gadgets/modules/gst-video-element.so
%%GTK%%lib/google-gadgets/modules/gtk-edit-element.a
%%GTK%%lib/google-gadgets/modules/gtk-edit-element.la
%%GTK%%lib/google-gadgets/modules/gtk-edit-element.so
@@ -190,19 +203,36 @@ lib/libggadget-js-1.0.so.0
%%QT%%lib/libggadget-qt-1.0.la
%%QT%%lib/libggadget-qt-1.0.so
%%QT%%lib/libggadget-qt-1.0.so.0
+lib/libggadget-xdg-1.0.a
+lib/libggadget-xdg-1.0.la
+lib/libggadget-xdg-1.0.so
+lib/libggadget-xdg-1.0.so.0
libdata/pkgconfig/libggadget-1.0.pc
libdata/pkgconfig/libggadget-dbus-1.0.pc
%%GTK%%libdata/pkgconfig/libggadget-gtk-1.0.pc
libdata/pkgconfig/libggadget-js-1.0.pc
%%QT%%libdata/pkgconfig/libggadget-qt-1.0.pc
+libdata/pkgconfig/libggadget-xdg-1.0.pc
%%GTK%%share/applications/ggl-gtk.desktop
%%QT%%share/applications/ggl-qt.desktop
%%DATADIR%%/analog_clock.gg
+%%DATADIR%%/designer.gg
%%DATADIR%%/digital_alarm_clock.gg
%%DATADIR%%/google-gadget-browser.gg
%%DATADIR%%/igoogle.gg
+%%DATADIR%%/photos.gg
%%DATADIR%%/resources.gg
%%DATADIR%%/rss.gg
+share/icons/hicolor/128x128/apps/google-gadgets.png
+share/icons/hicolor/128x128/mimetypes/application-x-google-gadgets.png
+share/icons/hicolor/192x192/apps/google-gadgets.png
+share/icons/hicolor/192x192/mimetypes/application-x-google-gadgets.png
+share/icons/hicolor/32x32/apps/google-gadgets.png
+share/icons/hicolor/32x32/mimetypes/application-x-google-gadgets.png
+share/icons/hicolor/48x48/apps/google-gadgets.png
+share/icons/hicolor/48x48/mimetypes/application-x-google-gadgets.png
+share/icons/hicolor/64x64/apps/google-gadgets.png
+share/icons/hicolor/64x64/mimetypes/application-x-google-gadgets.png
share/mime/packages/00-google-gadgets.xml
share/pixmaps/google-gadgets.png
@dirrm %%DATADIR%%
@@ -212,6 +242,7 @@ share/pixmaps/google-gadgets.png
@dirrm lib/google-gadgets
%%QT%%@dirrm include/google-gadgets/ggadget/qt
@dirrm include/google-gadgets/ggadget/js
+@dirrm include/google-gadgets/ggadget/xdg
%%GTK%%@dirrm include/google-gadgets/ggadget/gtk
@dirrm include/google-gadgets/ggadget/dbus
@dirrm include/google-gadgets/ggadget