aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMartin Filla <freebsd@sysctl.cz>2021-12-26 12:38:37 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-12-26 12:44:25 +0000
commit58d8a7cb9b81e2b69698cc7357b4a61fc716a53d (patch)
tree19bc0ce3808a59202cf2d0e6e3ad28de63ee0445 /deskutils
parente3dde9b37b787b10d81175d36467714719c10695 (diff)
downloadports-58d8a7cb9b81e2b69698cc7357b4a61fc716a53d.tar.gz
ports-58d8a7cb9b81e2b69698cc7357b4a61fc716a53d.zip
deskutils/ausweisapp2: Update to 1.22.2
PR: 258542
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/ausweisapp2/Makefile6
-rw-r--r--deskutils/ausweisapp2/distinfo6
-rw-r--r--deskutils/ausweisapp2/files/patch-cmake_Install.cmake28
-rw-r--r--deskutils/ausweisapp2/files/patch-cmake_Libraries.cmake17
-rw-r--r--deskutils/ausweisapp2/pkg-plist10
5 files changed, 29 insertions, 38 deletions
diff --git a/deskutils/ausweisapp2/Makefile b/deskutils/ausweisapp2/Makefile
index a5403770f504..c79e388d95a8 100644
--- a/deskutils/ausweisapp2/Makefile
+++ b/deskutils/ausweisapp2/Makefile
@@ -1,6 +1,5 @@
PORTNAME= ausweisapp2
-DISTVERSION= 1.20.0
-PORTREVISION= 2
+DISTVERSION= 1.22.2
CATEGORIES= deskutils security
MAINTAINER= freebsd@sysctl.cz
@@ -13,7 +12,8 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= pcsc-lite>0:devel/pcsc-lite
LIB_DEPENDS= libhttp_parser.so:www/http-parser \
- libpcsclite.so:devel/pcsc-lite
+ libpcsclite.so:devel/pcsc-lite \
+ libudev.so:devel/libudev-devd
USES= cmake compiler:c++17-lang pkgconfig qmake qt:5 ssl
USE_GITHUB= yes
diff --git a/deskutils/ausweisapp2/distinfo b/deskutils/ausweisapp2/distinfo
index 02104bc65a8f..f09465ab203e 100644
--- a/deskutils/ausweisapp2/distinfo
+++ b/deskutils/ausweisapp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1580634267
-SHA256 (Governikus-AusweisApp2-1.20.0_GH0.tar.gz) = 8590b8370fd7a27f639f7678171aeef0898e891fefafc54bd1d58dfc020e373b
-SIZE (Governikus-AusweisApp2-1.20.0_GH0.tar.gz) = 9727544
+TIMESTAMP = 1640361535
+SHA256 (Governikus-AusweisApp2-1.22.2_GH0.tar.gz) = 79d637a976dc1dc5445757a43324f4fe609d844bf90f11c0f62a46c39dc4fea6
+SIZE (Governikus-AusweisApp2-1.22.2_GH0.tar.gz) = 10886670
diff --git a/deskutils/ausweisapp2/files/patch-cmake_Install.cmake b/deskutils/ausweisapp2/files/patch-cmake_Install.cmake
deleted file mode 100644
index c394634b86b8..000000000000
--- a/deskutils/ausweisapp2/files/patch-cmake_Install.cmake
+++ /dev/null
@@ -1,28 +0,0 @@
---- cmake/Install.cmake.orig 2020-03-12 12:06:51 UTC
-+++ cmake/Install.cmake
-@@ -273,12 +273,12 @@ ELSEIF(UNIX)
-
- SET(DEFAULT_FILE_DESTINATION ${CMAKE_INSTALL_DATADIR}/${VENDOR}/AusweisApp2)
- SET(TRANSLATION_DESTINATION ${DEFAULT_FILE_DESTINATION}/${TRANSLATION_DESTINATION})
-- INSTALL(TARGETS AusweisApp DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT Application)
-+ INSTALL(TARGETS AusweisApp DESTINATION ${DESTDIR}${CMAKE_INSTALL_BINDIR} COMPONENT Application)
- CONFIGURE_FILE(${PACKAGING_DIR}/linux/${BUNDLE_IDENTIFIER}.metainfo.xml.in ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.metainfo.xml @ONLY)
- CONFIGURE_FILE(${PACKAGING_DIR}/linux/${BUNDLE_IDENTIFIER}.desktop.in ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.desktop @ONLY)
-- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.metainfo.xml DESTINATION ${CMAKE_INSTALL_DATADIR}/metainfo COMPONENT Application)
-- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.desktop DESTINATION ${CMAKE_INSTALL_DATADIR}/applications COMPONENT Application)
-- INSTALL(FILES ${RESOURCES_DIR}/images/npa.svg DESTINATION ${DEFAULT_FILE_DESTINATION} COMPONENT Application)
-+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.metainfo.xml DESTINATION ${DESTDIR}${CMAKE_INSTALL_DATADIR}/metainfo COMPONENT Application)
-+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${BUNDLE_IDENTIFIER}.desktop DESTINATION ${DESTDIR}${CMAKE_INSTALL_DATADIR}/applications COMPONENT Application)
-+ INSTALL(FILES ${RESOURCES_DIR}/images/npa.svg DESTINATION ${DESTDIR}${DEFAULT_FILE_DESTINATION} COMPONENT Application)
- ENDIF()
-
-
-@@ -303,7 +303,7 @@ IF(LINUX OR WIN32 OR MAC)
- ENDIF()
-
-
--IF(LINUX)
-+IF(LINUX OR BSD)
- INSTALL(FILES ${QM_FILES} DESTINATION ${TRANSLATION_DESTINATION} COMPONENT Translations)
- ELSEIF(NOT INTEGRATED_SDK)
- INSTALL(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/translations/ DESTINATION ${TRANSLATION_DESTINATION} COMPONENT Translations)
diff --git a/deskutils/ausweisapp2/files/patch-cmake_Libraries.cmake b/deskutils/ausweisapp2/files/patch-cmake_Libraries.cmake
new file mode 100644
index 000000000000..46bd9ab45578
--- /dev/null
+++ b/deskutils/ausweisapp2/files/patch-cmake_Libraries.cmake
@@ -0,0 +1,17 @@
+--- cmake/Libraries.cmake.orig 2021-12-24 17:02:28 UTC
++++ cmake/Libraries.cmake
+@@ -122,11 +122,9 @@ elseif(MAC)
+ find_library(OSX_FOUNDATION Foundation)
+ find_library(OSX_SERVICEMANAGEMENT ServiceManagement)
+ elseif(UNIX)
+- if(LINUX)
+- find_library(LIBUDEV NAMES udev ludev libudev)
+- if(NOT LIBUDEV)
+- message(STATUS "Hardware detection disabled - Missing libudev")
+- endif()
++ find_library(LIBUDEV NAMES udev ludev libudev)
++ if(NOT LIBUDEV)
++ message(STATUS "Hardware detection disabled - Missing libudev")
+ endif()
+
+ find_package(PkgConfig REQUIRED)
diff --git a/deskutils/ausweisapp2/pkg-plist b/deskutils/ausweisapp2/pkg-plist
index 1950ec67e270..b6755a880671 100644
--- a/deskutils/ausweisapp2/pkg-plist
+++ b/deskutils/ausweisapp2/pkg-plist
@@ -1,7 +1,9 @@
bin/AusweisApp2
-share/ausweisapp2/AusweisApp2/AusweisApp2.rcc
-share/ausweisapp2/AusweisApp2/config.json
-share/ausweisapp2/AusweisApp2/npa.svg
-share/ausweisapp2/AusweisApp2/translations/ausweisapp2_de.qm
+man/man1/AusweisApp2.1.gz
share/applications/com.governikus.ausweisapp2.desktop
+%%DATADIR%%/AusweisApp2/AusweisApp2.rcc
+%%DATADIR%%/AusweisApp2/config.json
+%%DATADIR%%/AusweisApp2/translations/ausweisapp2_de.qm
+share/icons/hicolor/96x96/apps/AusweisApp2.png
+share/icons/hicolor/scalable/apps/AusweisApp2.svg
share/metainfo/com.governikus.ausweisapp2.metainfo.xml