aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-03-12 08:32:54 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-03-12 08:32:54 +0000
commit8c016d3336bc45bf3557be963f6dd84ecbe2f5fc (patch)
tree1c1ac93e504171babbbaacdf11165d7725b67047 /deskutils
parent92c2f2bd6d83e5fcc3f795fe35bfaa7e9f5075b6 (diff)
downloadports-8c016d3336bc45bf3557be963f6dd84ecbe2f5fc.tar.gz
ports-8c016d3336bc45bf3557be963f6dd84ecbe2f5fc.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/py-pycarddav/Makefile26
-rw-r--r--deskutils/py-pycarddav/distinfo2
-rw-r--r--deskutils/py-pycarddav/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 2d2d35d616e3..29266c74412a 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -201,6 +201,7 @@
SUBDIR += preferencepanes
SUBDIR += preferences
SUBDIR += py-khal
+ SUBDIR += py-pycarddav
SUBDIR += py-pystash
SUBDIR += py-send2trash
SUBDIR += py-spice-gtk
diff --git a/deskutils/py-pycarddav/Makefile b/deskutils/py-pycarddav/Makefile
new file mode 100644
index 000000000000..8c31f6ebbe28
--- /dev/null
+++ b/deskutils/py-pycarddav/Makefile
@@ -0,0 +1,26 @@
+# Created by: che@bein.link
+# $FreeBSD$
+
+PORTNAME= pyCardDAV
+PORTVERSION= 0.7.0
+CATEGORIES= deskutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= che@bein.link
+COMMENT= CardDAV based address book tool
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=3.2:${PORTSDIR}/devel/py-click \
+ ${PYTHON_PKGNAMEPREFIX}urwid>=1.2.1:${PORTSDIR}/devel/py-urwid \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=3.4.1:${PORTSDIR}/devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}vobject>=0.8.0:${PORTSDIR}/deskutils/py-vobject \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.4.3:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}xdg>=0.25:${PORTSDIR}/devel/py-xdg
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/deskutils/py-pycarddav/distinfo b/deskutils/py-pycarddav/distinfo
new file mode 100644
index 000000000000..f7e4a1e89bd4
--- /dev/null
+++ b/deskutils/py-pycarddav/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyCardDAV-0.7.0.tar.gz) = a86bca36e361ce194d5fb49295f1ad1b0ed4a4c0759f3d40f8703b1d2fcb732b
+SIZE (pyCardDAV-0.7.0.tar.gz) = 36677
diff --git a/deskutils/py-pycarddav/pkg-descr b/deskutils/py-pycarddav/pkg-descr
new file mode 100644
index 000000000000..dbff3f4e2d07
--- /dev/null
+++ b/deskutils/py-pycarddav/pkg-descr
@@ -0,0 +1,4 @@
+pyCardDAV is a simple to use CardDAV CLI client. It has built in support for
+mutt's query_command but also works very well solo (and with other MUAs).
+
+WWW: http://lostpackets.de/pycarddav