aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-08-14 00:19:30 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-08-14 00:19:30 +0000
commit08363af9ca9e3ca0a53cb3be0b06cb0850dbeb98 (patch)
treedecad445cba5f19bf7905cbc090f4cf0236dc187 /deskutils
parent39b9a98c25b660a81df03d9d3b27d6f7c7673b5a (diff)
downloadports-08363af9ca9e3ca0a53cb3be0b06cb0850dbeb98.tar.gz
ports-08363af9ca9e3ca0a53cb3be0b06cb0850dbeb98.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/krefty/Makefile2
-rw-r--r--deskutils/krefty/files/patch-krefty_part.cpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/deskutils/krefty/Makefile b/deskutils/krefty/Makefile
index a6567db4cd66..439268c4a311 100644
--- a/deskutils/krefty/Makefile
+++ b/deskutils/krefty/Makefile
@@ -22,7 +22,7 @@ post-extract:
@${TOUCH} ${WRKSRC}/config.h.in
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|-O2|-fPIC|g; s|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
diff --git a/deskutils/krefty/files/patch-krefty_part.cpp b/deskutils/krefty/files/patch-krefty_part.cpp
new file mode 100644
index 000000000000..cfbfb7d1031a
--- /dev/null
+++ b/deskutils/krefty/files/patch-krefty_part.cpp
@@ -0,0 +1,10 @@
+--- src/krefty_part.cpp.orig Sat Aug 14 02:13:08 2004
++++ src/krefty_part.cpp Sat Aug 14 02:13:22 2004
+@@ -197,6 +197,6 @@
+ {
+ return new KreftyPartFactory;
+ }
+-};
++}
+
+ #include "krefty_part.moc"