aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-04-10 09:16:40 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-04-10 09:16:40 +0000
commit762b1d6beada11eab62a3bd6b39b46f9d4b21a6f (patch)
tree8471ec4b5f1cde375b21ed99e5ac6441c01c905f /deskutils
parent8360ab3d50019495b3fe2496f28c058452bed599 (diff)
downloadports-762b1d6beada11eab62a3bd6b39b46f9d4b21a6f.tar.gz
ports-762b1d6beada11eab62a3bd6b39b46f9d4b21a6f.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/bmp-docklet/Makefile28
-rw-r--r--deskutils/bmp-docklet/distinfo2
-rw-r--r--deskutils/bmp-docklet/pkg-descr6
-rw-r--r--deskutils/bmp-docklet/pkg-plist4
5 files changed, 41 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index fb08327832be..2a916765146e 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -11,6 +11,7 @@
SUBDIR += basket
SUBDIR += bigyear
SUBDIR += blogtk
+ SUBDIR += bmp-docklet
SUBDIR += cal
SUBDIR += checkrdf
SUBDIR += dailystrips
diff --git a/deskutils/bmp-docklet/Makefile b/deskutils/bmp-docklet/Makefile
new file mode 100644
index 000000000000..625db22ae083
--- /dev/null
+++ b/deskutils/bmp-docklet/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: bmp-docklet
+# Date created: 10 April, 2005
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bmp-docklet
+PORTVERSION= 1.1
+CATEGORIES= deskutils audio
+MASTER_SITES= http://mark.xnull.de/bmp-docklet/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= System tray controller for beep-media-player
+
+BUILD_DEPENDS= beep-media-player:${PORTSDIR}/multimedia/beep-media-player
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/deskutils/bmp-docklet/distinfo b/deskutils/bmp-docklet/distinfo
new file mode 100644
index 000000000000..1346d7f774b3
--- /dev/null
+++ b/deskutils/bmp-docklet/distinfo
@@ -0,0 +1,2 @@
+MD5 (bmp-docklet-1.1.tar.bz2) = 12a62d3c7d3055c08a0aae97ab68847e
+SIZE (bmp-docklet-1.1.tar.bz2) = 275967
diff --git a/deskutils/bmp-docklet/pkg-descr b/deskutils/bmp-docklet/pkg-descr
new file mode 100644
index 000000000000..96e13dec86c2
--- /dev/null
+++ b/deskutils/bmp-docklet/pkg-descr
@@ -0,0 +1,6 @@
+Provides a small beep-media-player icon in the system tray
+(should work with GNOME, KDE, fluxbox, etc.) that provides
+basic play control for beep-media-player. Also displays the
+current song title in a tooltip.
+
+WWW: http://mark.xnull.de/bmp-docklet.php
diff --git a/deskutils/bmp-docklet/pkg-plist b/deskutils/bmp-docklet/pkg-plist
new file mode 100644
index 000000000000..0727f230da4d
--- /dev/null
+++ b/deskutils/bmp-docklet/pkg-plist
@@ -0,0 +1,4 @@
+lib/bmp/General/libdocklet.so
+share/locale/de/LC_MESSAGES/bmp-docklet.mo
+share/locale/fr/LC_MESSAGES/bmp-docklet.mo
+@dirrm lib/bmp/General