aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-09-01 16:24:58 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-09-01 16:24:58 +0000
commit722eeda87641c16f0a5bb67e199525bdc617f856 (patch)
tree58e8643d44cf681e5339ea102f589837b3fc08f0 /deskutils
parent3bd77fee3404a0c9d4dc9175dc0583ab167963f4 (diff)
downloadports-722eeda87641c16f0a5bb67e199525bdc617f856.tar.gz
ports-722eeda87641c16f0a5bb67e199525bdc617f856.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/xfce4-notifyd/Makefile2
-rw-r--r--deskutils/xfce4-notifyd/distinfo6
-rw-r--r--deskutils/xfce4-notifyd/files/patch-common_xfce-notify-log.c41
-rw-r--r--deskutils/xfce4-notifyd/pkg-plist31
4 files changed, 60 insertions, 20 deletions
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index 9d8cf7b47210..b779b822cbd3 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -6,7 +6,7 @@
# Support of GTK+ is checked at compile time and themes directories too.
PORTNAME= xfce4-notifyd
-PORTVERSION= 0.6.1
+PORTVERSION= 0.6.2
CATEGORIES= deskutils xfce
MASTER_SITES= XFCE/apps
DIST_SUBDIR= xfce4
diff --git a/deskutils/xfce4-notifyd/distinfo b/deskutils/xfce4-notifyd/distinfo
index 921d2d29503f..8422bf434061 100644
--- a/deskutils/xfce4-notifyd/distinfo
+++ b/deskutils/xfce4-notifyd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588843924
-SHA256 (xfce4/xfce4-notifyd-0.6.1.tar.bz2) = 9b5274999c89bf296a7de03b375e8233eef37940b7444502130b92dfb6a089b4
-SIZE (xfce4/xfce4-notifyd-0.6.1.tar.bz2) = 539209
+TIMESTAMP = 1598958913
+SHA256 (xfce4/xfce4-notifyd-0.6.2.tar.bz2) = 19ab84c6665c7819998f2269322d53f462c30963ce26042df23ae525e7d16545
+SIZE (xfce4/xfce4-notifyd-0.6.2.tar.bz2) = 548415
diff --git a/deskutils/xfce4-notifyd/files/patch-common_xfce-notify-log.c b/deskutils/xfce4-notifyd/files/patch-common_xfce-notify-log.c
new file mode 100644
index 000000000000..30cb840c8560
--- /dev/null
+++ b/deskutils/xfce4-notifyd/files/patch-common_xfce-notify-log.c
@@ -0,0 +1,41 @@
+--- common/xfce-notify-log.c.orig 2020-08-17 22:20:52 UTC
++++ common/xfce-notify-log.c
+@@ -37,6 +37,38 @@
+
+ #include "xfce-notify-log.h"
+
++// import g_date_time_format_iso8601
++// from: https://git.sailfishos.org/mirror/glib/commit/dbabd2b8a745bfed4890f2d6cbd7d7848bc4f034
++gchar *
++g_date_time_format_iso8601 (GDateTime *datetime)
++{
++ GString *outstr = NULL;
++ gchar *main_date = NULL;
++ gint64 offset;
++
++ /* Main date and time. */
++ main_date = g_date_time_format (datetime, "%Y-%m-%dT%H:%M:%S");
++ outstr = g_string_new (main_date);
++ g_free (main_date);
++
++ /* Timezone. Format it as `%:::z` unless the offset is zero, in which case
++ * we can simply use `Z`. */
++ offset = g_date_time_get_utc_offset (datetime);
++
++ if (offset == 0)
++ {
++ g_string_append_c (outstr, 'Z');
++ }
++ else
++ {
++ gchar *time_zone = g_date_time_format (datetime, "%:::z");
++ g_string_append (outstr, time_zone);
++ g_free (time_zone);
++ }
++
++ return g_string_free (outstr, FALSE);
++}
++
+ GdkPixbuf *
+ notify_pixbuf_from_image_data (GVariant *image_data)
+ {
diff --git a/deskutils/xfce4-notifyd/pkg-plist b/deskutils/xfce4-notifyd/pkg-plist
index 87c700cb224f..bd4908e27698 100644
--- a/deskutils/xfce4-notifyd/pkg-plist
+++ b/deskutils/xfce4-notifyd/pkg-plist
@@ -1,19 +1,3 @@
-bin/xfce4-notifyd-config
-lib/systemd/user/xfce4-notifyd.service
-lib/xfce4/notifyd/xfce4-notifyd
-lib/xfce4/panel/plugins/libnotification-plugin.so
-man/man1/xfce4-notifyd-config.1.gz
-share/applications/xfce4-notifyd-config.desktop
-share/dbus-1/services/org.xfce.xfce4-notifyd.Notifications.service
-share/icons/hicolor/16x16/apps/xfce4-notifyd.png
-share/icons/hicolor/24x24/apps/xfce4-notifyd.png
-share/icons/hicolor/32x32/apps/xfce4-notifyd.png
-share/icons/hicolor/48x48/apps/xfce4-notifyd.png
-share/icons/hicolor/scalable/apps/xfce4-notifyd.svg
-share/icons/hicolor/scalable/status/notification-disabled-new-symbolic.svg
-share/icons/hicolor/scalable/status/notification-disabled-symbolic.svg
-share/icons/hicolor/scalable/status/notification-new-symbolic.svg
-share/icons/hicolor/scalable/status/notification-symbolic.svg
%%NLS%%share/locale/ar/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/ast/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/be/LC_MESSAGES/xfce4-notifyd.mo
@@ -26,6 +10,7 @@ share/icons/hicolor/scalable/status/notification-symbolic.svg
%%NLS%%share/locale/en_AU/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/es/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/et/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/eu/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-notifyd.mo
@@ -34,6 +19,7 @@ share/icons/hicolor/scalable/status/notification-symbolic.svg
%%NLS%%share/locale/hr/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/hy_AM/LC_MESSAGES/xfce4-notifyd.mo
+%%NLS%%share/locale/hye/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/id/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/ie/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/is/LC_MESSAGES/xfce4-notifyd.mo
@@ -67,6 +53,19 @@ share/icons/hicolor/scalable/status/notification-symbolic.svg
%%NLS%%share/locale/vi/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-notifyd.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-notifyd.mo
+bin/xfce4-notifyd-config
+etc/xdg/autostart/xfce4-notifyd.desktop
+lib/xfce4/notifyd/xfce4-notifyd
+lib/xfce4/panel/plugins/libnotification-plugin.so
+man/man1/xfce4-notifyd-config.1.gz
+share/applications/xfce4-notifyd-config.desktop
+share/icons/hicolor/16x16/apps/org.xfce.notification.png
+share/icons/hicolor/48x48/apps/org.xfce.notification.png
+share/icons/hicolor/scalable/apps/org.xfce.notification.svg
+share/icons/hicolor/scalable/status/notification-disabled-new-symbolic.svg
+share/icons/hicolor/scalable/status/notification-disabled-symbolic.svg
+share/icons/hicolor/scalable/status/notification-new-symbolic.svg
+share/icons/hicolor/scalable/status/notification-symbolic.svg
share/themes/Bright/xfce-notify-4.0/gtk.css
share/themes/Default/xfce-notify-4.0/gtk.css
share/themes/Retro/xfce-notify-4.0/gtk.css