aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
commit789d75c728ef23566a07bf5b9bc2190bf34ff4f1 (patch)
treedc7540d42fa2d5d7c1c74515e3bdbf6ab842cd17 /deskutils
parentd1a9e827c98542eb35619dffa314cba50fb08b58 (diff)
downloadports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.tar.gz
ports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/basket/Makefile2
-rw-r--r--deskutils/bmp-docklet/Makefile2
-rw-r--r--deskutils/bookreader/Makefile2
-rw-r--r--deskutils/contacts/Makefile2
-rw-r--r--deskutils/dragstack/Makefile2
-rw-r--r--deskutils/drivel/Makefile2
-rw-r--r--deskutils/genius/Makefile2
-rw-r--r--deskutils/glabels/Makefile2
-rw-r--r--deskutils/global-menu/Makefile2
-rw-r--r--deskutils/gnome-utils/Makefile2
-rw-r--r--deskutils/gnotime/Makefile4
-rw-r--r--deskutils/google-gadgets/Makefile4
-rw-r--r--deskutils/gruler/Makefile2
-rw-r--r--deskutils/gtkjournal/Makefile2
-rw-r--r--deskutils/karamba/Makefile2
-rw-r--r--deskutils/katapult/Makefile2
-rw-r--r--deskutils/kbirthday/Makefile2
-rw-r--r--deskutils/kblticker/Makefile2
-rw-r--r--deskutils/kchm/Makefile2
-rw-r--r--deskutils/kchmviewer/Makefile2
-rw-r--r--deskutils/kdepim3/Makefile2
-rw-r--r--deskutils/kickpim/Makefile2
-rw-r--r--deskutils/klipoquery/Makefile2
-rw-r--r--deskutils/kluje/Makefile2
-rw-r--r--deskutils/kmatrix3d/Makefile2
-rw-r--r--deskutils/knowit/Makefile2
-rw-r--r--deskutils/kompose/Makefile2
-rw-r--r--deskutils/kooldock/Makefile2
-rw-r--r--deskutils/krefty/Makefile2
-rw-r--r--deskutils/krss/Makefile2
-rw-r--r--deskutils/ksmoothdock/Makefile2
-rw-r--r--deskutils/ktagebuch/Makefile2
-rw-r--r--deskutils/kuake/Makefile2
-rw-r--r--deskutils/lightning-thunderbird/Makefile2
-rw-r--r--deskutils/lightning/Makefile2
-rw-r--r--deskutils/metabar/Makefile2
-rw-r--r--deskutils/multisync/Makefile2
-rw-r--r--deskutils/nautilus-locked-folder/Makefile2
-rw-r--r--deskutils/sunbird/Makefile2
-rw-r--r--deskutils/taskjuggler/Makefile2
40 files changed, 42 insertions, 42 deletions
diff --git a/deskutils/basket/Makefile b/deskutils/basket/Makefile
index c46b649c8f47..c1898a7e9474 100644
--- a/deskutils/basket/Makefile
+++ b/deskutils/basket/Makefile
@@ -15,7 +15,7 @@ COMMENT= Desktop organization tool
USE_KDELIBS_VER=3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
OPTIONS= KONTACT "Kontact plugin" on \
diff --git a/deskutils/bmp-docklet/Makefile b/deskutils/bmp-docklet/Makefile
index a1dd71f2c5e3..32ba821aa424 100644
--- a/deskutils/bmp-docklet/Makefile
+++ b/deskutils/bmp-docklet/Makefile
@@ -19,7 +19,7 @@ COMMENT= System tray controller for beep-media-player
BUILD_DEPENDS= beep-media-player:${PORTSDIR}/multimedia/beep-media-player
RUN_DEPENDS= beep-media-player:${PORTSDIR}/multimedia/beep-media-player
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/deskutils/bookreader/Makefile b/deskutils/bookreader/Makefile
index 35c47361bbae..7d7a9c153781 100644
--- a/deskutils/bookreader/Makefile
+++ b/deskutils/bookreader/Makefile
@@ -18,6 +18,6 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
.include <bsd.port.mk>
diff --git a/deskutils/contacts/Makefile b/deskutils/contacts/Makefile
index c821734c6cf8..95ee1d756354 100644
--- a/deskutils/contacts/Makefile
+++ b/deskutils/contacts/Makefile
@@ -19,7 +19,7 @@ CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
USE_GMAKE= yes
USE_GNOME= gtk20 gnomehier evolutiondataserver
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GCONF_SCHEMAS= contacts.schemas
MAN1= ${PORTNAME}.1
# CFLAGS+= -g
diff --git a/deskutils/dragstack/Makefile b/deskutils/dragstack/Makefile
index a325a2f35a56..54204ee3bb57 100644
--- a/deskutils/dragstack/Makefile
+++ b/deskutils/dragstack/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= markus@FreeBSD.org
COMMENT= Drop stack applet for KDE
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_KDEBASE_VER= 3
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/deskutils/drivel/Makefile b/deskutils/drivel/Makefile
index 88f3a81dcf15..69154a08d9c7 100644
--- a/deskutils/drivel/Makefile
+++ b/deskutils/drivel/Makefile
@@ -23,7 +23,7 @@ USE_GNOME= gnomeprefix gnomehack libgnomeui intlhack gtksourceview
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index 633593ba1c98..d1925657172d 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_GNOME= gnomehack gnomeprefix gnomevfs2 gtksourceview2 intlhack vte
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-extra-gcc-optimization
diff --git a/deskutils/glabels/Makefile b/deskutils/glabels/Makefile
index b803407947b3..e5eea41702b7 100644
--- a/deskutils/glabels/Makefile
+++ b/deskutils/glabels/Makefile
@@ -22,7 +22,7 @@ WANT_GNOME= yes
USE_GETTEXT= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/deskutils/global-menu/Makefile b/deskutils/global-menu/Makefile
index 8f4f9baef51d..f9942a32e2c4 100644
--- a/deskutils/global-menu/Makefile
+++ b/deskutils/global-menu/Makefile
@@ -20,7 +20,7 @@ USE_BZIP2= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15 automake:19:env autoheader:262:env
+USE_AUTOTOOLS= libtool:22 automake:19:env autoheader:262:env
INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/deskutils/gnome-utils/Makefile b/deskutils/gnome-utils/Makefile
index 9a5f2c02622c..c270dd8b41c2 100644
--- a/deskutils/gnome-utils/Makefile
+++ b/deskutils/gnome-utils/Makefile
@@ -28,7 +28,7 @@ USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomepanel \
libgnomeprintui gnomedesktop ltverhack
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/deskutils/gnotime/Makefile b/deskutils/gnotime/Makefile
index c102a8d3eae4..b55064c60041 100644
--- a/deskutils/gnotime/Makefile
+++ b/deskutils/gnotime/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnotime
PORTVERSION= 2.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils gnome
MASTER_SITES= SF/gttr:gttr SF/qof:qof
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:gttr \
@@ -23,7 +23,7 @@ USE_XORG= xscrnsaver
USE_GNOME= gnomehack gnomeprefix gtkhtml3 intlhack libgnomeui
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15 libltdl:15
+USE_AUTOTOOLS= libtool:22 libltdl:22
LIBTOOLFILES= configure ../${QOF_DISTNAME}/configure
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
LIBQOF_CFLAGS="${LIBQOF_CFLAGS}" LIBQOF_LIBS="${LIBQOF_LIBS}"
diff --git a/deskutils/google-gadgets/Makefile b/deskutils/google-gadgets/Makefile
index e4bb19f04920..99349f43d921 100644
--- a/deskutils/google-gadgets/Makefile
+++ b/deskutils/google-gadgets/Makefile
@@ -7,7 +7,7 @@
PORTNAME= google-gadgets
PORTVERSION= 0.10.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= http://google-gadgets-for-linux.googlecode.com/files/
DISTNAME= ${PORTNAME}-for-linux-${PORTVERSION}
@@ -39,7 +39,7 @@ USE_GSTREAMER= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" CPPFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-ltdl-install=no
-USE_AUTOTOOLS= libtool:15:env autoconf:262:env automake:110:env aclocal:110:env libltdl:15
+USE_AUTOTOOLS= libtool:22:env autoconf:262:env automake:110:env aclocal:110:env libltdl:22
WANT_GNOME= yes
USE_GNOME= gnomehack
INSTALLS_ICONS= yes
diff --git a/deskutils/gruler/Makefile b/deskutils/gruler/Makefile
index 004f540126c4..7d568ddb8288 100644
--- a/deskutils/gruler/Makefile
+++ b/deskutils/gruler/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= smyru@heron.pl
COMMENT= A simple customizable GTK screen ruler
USE_GNOME= gnomeprefix gnomehack libgnomeui libglade2
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -export-dynamic"
diff --git a/deskutils/gtkjournal/Makefile b/deskutils/gtkjournal/Makefile
index 0f951a8fbfa7..62e4172cb683 100644
--- a/deskutils/gtkjournal/Makefile
+++ b/deskutils/gtkjournal/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtkmm20 \
PLIST_FILES= bin/gtkjournal lib/libsqlitemm.a lib/libsqlitemm.la \
lib/libsqlitemm.so lib/libsqlitemm.so.0
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/deskutils/karamba/Makefile b/deskutils/karamba/Makefile
index afbba0740df3..84c1a4bb10c2 100644
--- a/deskutils/karamba/Makefile
+++ b/deskutils/karamba/Makefile
@@ -16,7 +16,7 @@ COMMENT= Display various information right on your desktop
EXTRA_PATCHES= ${.CURDIR}/../../comms/kallers/files/patch-configure
USE_KDELIBS_VER=3
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/deskutils/katapult/Makefile b/deskutils/katapult/Makefile
index 34ca76fcc21d..1b1abbfda930 100644
--- a/deskutils/katapult/Makefile
+++ b/deskutils/katapult/Makefile
@@ -17,7 +17,7 @@ COMMENT= Fast, extensible launcher for KDE similar to Quicksilver on OSX
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= ${PREFIX}/lib/ ${PREFIX}/lib/kde3/
INSTALLS_ICONS= yes
USE_GETTEXT= yes
diff --git a/deskutils/kbirthday/Makefile b/deskutils/kbirthday/Makefile
index b184f98dd2da..76f06661ec6b 100644
--- a/deskutils/kbirthday/Makefile
+++ b/deskutils/kbirthday/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.gfai.de/~jaham/download/ \
MAINTAINER= h.eichmann@gmx.de
COMMENT= KDE kicker-applet that reminds you of birthdays and anniversaries
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_KDELIBS_VER=3
USE_LDCONFIG= yes
diff --git a/deskutils/kblticker/Makefile b/deskutils/kblticker/Makefile
index 8090913945fb..d117defebdcd 100644
--- a/deskutils/kblticker/Makefile
+++ b/deskutils/kblticker/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mich@FreeBSD.org
COMMENT= KDE bloglines notifier
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_KDELIBS_VER= 3
diff --git a/deskutils/kchm/Makefile b/deskutils/kchm/Makefile
index 68b31d8772bb..1d47b82a6dc7 100644
--- a/deskutils/kchm/Makefile
+++ b/deskutils/kchm/Makefile
@@ -21,6 +21,6 @@ LIB_DEPENDS= chm.0:${PORTSDIR}/misc/chmlib
USE_BZIP2= yes
USE_KDEBASE_VER=3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
.include <bsd.port.mk>
diff --git a/deskutils/kchmviewer/Makefile b/deskutils/kchmviewer/Makefile
index cd2d343ec08f..bcb5e0a2d9c2 100644
--- a/deskutils/kchmviewer/Makefile
+++ b/deskutils/kchmviewer/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS+= chm:${PORTSDIR}/misc/chmlib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
DO_NOT_COMPILE+=chmlib
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/deskutils/kdepim3/Makefile b/deskutils/kdepim3/Makefile
index 409c85e1c93b..be99b566e881 100644
--- a/deskutils/kdepim3/Makefile
+++ b/deskutils/kdepim3/Makefile
@@ -29,7 +29,7 @@ _NO_KDE_FINAL= yes
USE_BZIP2= yes
USE_BISON= build
USE_OPENSSL= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/deskutils/kickpim/Makefile b/deskutils/kickpim/Makefile
index 125cdf3ead87..67112010512a 100644
--- a/deskutils/kickpim/Makefile
+++ b/deskutils/kickpim/Makefile
@@ -17,7 +17,7 @@ COMMENT= Panel applet for editing and accessing the KDE addressbook
USE_KDEBASE_VER= 3
USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
diff --git a/deskutils/klipoquery/Makefile b/deskutils/klipoquery/Makefile
index 1157b8bb4fbf..3943e8746292 100644
--- a/deskutils/klipoquery/Makefile
+++ b/deskutils/klipoquery/Makefile
@@ -17,7 +17,7 @@ EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
USE_KDELIBS_VER=3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/deskutils/kluje/Makefile b/deskutils/kluje/Makefile
index c142d5abbb1a..7a3a7c953fe2 100644
--- a/deskutils/kluje/Makefile
+++ b/deskutils/kluje/Makefile
@@ -17,7 +17,7 @@ COMMENT= A KDE client for the popular online journal site LiveJournal
USE_KDELIBS_VER= 3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g ; \
diff --git a/deskutils/kmatrix3d/Makefile b/deskutils/kmatrix3d/Makefile
index a565d168f5f5..fe6b48116f40 100644
--- a/deskutils/kmatrix3d/Makefile
+++ b/deskutils/kmatrix3d/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GL= glut
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15 automake:19:env autoheader:262:env
+USE_AUTOTOOLS= libtool:22 automake:19:env autoheader:262:env
USE_KDELIBS_VER= 3
USE_BZIP2= yes
USE_PERL5_BUILD= yes
diff --git a/deskutils/knowit/Makefile b/deskutils/knowit/Makefile
index 0462607d25c3..5ac154dcf020 100644
--- a/deskutils/knowit/Makefile
+++ b/deskutils/knowit/Makefile
@@ -18,7 +18,7 @@ USE_BZIP2= yes
USE_GETTEXT= yes
USE_KDELIBS_VER= 3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
INSTALLS_ICONS= yes
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
AUTOMAKE="${TRUE}"
diff --git a/deskutils/kompose/Makefile b/deskutils/kompose/Makefile
index 2d81e2bd479f..583bb9863015 100644
--- a/deskutils/kompose/Makefile
+++ b/deskutils/kompose/Makefile
@@ -19,7 +19,7 @@ EXTRA_PATCHES= ${PORTSDIR}/x11/kde3/files/extrapatch-old_configure
USE_BZIP2= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_EFL= imlib2
INSTALLS_ICONS= yes
diff --git a/deskutils/kooldock/Makefile b/deskutils/kooldock/Makefile
index 6f3d6a127843..ca17aacabe6e 100644
--- a/deskutils/kooldock/Makefile
+++ b/deskutils/kooldock/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/kooldock
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
INSTALLS_ICONS= yes
USE_GETTEXT= yes
USE_KDELIBS_VER= 3
diff --git a/deskutils/krefty/Makefile b/deskutils/krefty/Makefile
index abd5e8f7fdfe..e173e67605b2 100644
--- a/deskutils/krefty/Makefile
+++ b/deskutils/krefty/Makefile
@@ -16,7 +16,7 @@ COMMENT= Quick Reference sheets for KDE
USE_KDELIBS_VER=3
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
DOCSDIR= share/doc/HTML
diff --git a/deskutils/krss/Makefile b/deskutils/krss/Makefile
index 4822c5a3eecf..a5daaf697865 100644
--- a/deskutils/krss/Makefile
+++ b/deskutils/krss/Makefile
@@ -18,7 +18,7 @@ COMMENT= KDE Rich Site Summary viewer
USE_KDEBASE_VER=3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= LIBQT="-lqt-mt ${PTHREAD_LIBS}" KDB2HTML=${TRUE}
MAKE_ENV= LIBQT="-lqt-mt ${PTHREAD_LIBS}" KDB2HTML=${TRUE}
diff --git a/deskutils/ksmoothdock/Makefile b/deskutils/ksmoothdock/Makefile
index 149dc061a678..1582edf78622 100644
--- a/deskutils/ksmoothdock/Makefile
+++ b/deskutils/ksmoothdock/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_KDELIBS_VER=3
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:262:env automake:19:env libtool:15:env
+USE_AUTOTOOLS= autoconf:262:env automake:19:env libtool:22
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_PERL5_BUILD=yes
diff --git a/deskutils/ktagebuch/Makefile b/deskutils/ktagebuch/Makefile
index e910d946f25e..cdce3de04727 100644
--- a/deskutils/ktagebuch/Makefile
+++ b/deskutils/ktagebuch/Makefile
@@ -20,7 +20,7 @@ EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
USE_KDELIBS_VER= 3
USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_GETTEXT= yes
diff --git a/deskutils/kuake/Makefile b/deskutils/kuake/Makefile
index 4f5594ad941e..981790300e85 100644
--- a/deskutils/kuake/Makefile
+++ b/deskutils/kuake/Makefile
@@ -15,7 +15,7 @@ COMMENT= KDE konsole application acting like the Quake-console
USE_KDEBASE_VER=3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
diff --git a/deskutils/lightning-thunderbird/Makefile b/deskutils/lightning-thunderbird/Makefile
index 5089bf0ad2d4..167a6c79daf7 100644
--- a/deskutils/lightning-thunderbird/Makefile
+++ b/deskutils/lightning-thunderbird/Makefile
@@ -18,7 +18,7 @@ DISTNAME= lightning-${PORTNAME}-${DISTVERSION}-source
MAINTAINER= gecko@FreeBSD.org
COMMENT= Redesign of the Mozilla Calendar with XUL interface
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
ALL_TARGET= default
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
HAS_CONFIGURE= yes
diff --git a/deskutils/lightning/Makefile b/deskutils/lightning/Makefile
index 5089bf0ad2d4..167a6c79daf7 100644
--- a/deskutils/lightning/Makefile
+++ b/deskutils/lightning/Makefile
@@ -18,7 +18,7 @@ DISTNAME= lightning-${PORTNAME}-${DISTVERSION}-source
MAINTAINER= gecko@FreeBSD.org
COMMENT= Redesign of the Mozilla Calendar with XUL interface
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
ALL_TARGET= default
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
HAS_CONFIGURE= yes
diff --git a/deskutils/metabar/Makefile b/deskutils/metabar/Makefile
index 5e4b927558e5..0967f38c4d3e 100644
--- a/deskutils/metabar/Makefile
+++ b/deskutils/metabar/Makefile
@@ -17,7 +17,7 @@ COMMENT= Sidebar plugin for Konqueror
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_KDEBASE_VER=3
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/deskutils/multisync/Makefile b/deskutils/multisync/Makefile
index a40ea405ac26..6337ce02f804 100644
--- a/deskutils/multisync/Makefile
+++ b/deskutils/multisync/Makefile
@@ -20,7 +20,7 @@ WRKSRCMASTER= ${WRKDIR}/multisync-${PORTVERSION}
USE_BZIP2= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui
USE_GMAKE= yes
-USE_AUTOTOOLS= automake:19:env libtool:15
+USE_AUTOTOOLS= automake:19:env libtool:22
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
pre-configure:
diff --git a/deskutils/nautilus-locked-folder/Makefile b/deskutils/nautilus-locked-folder/Makefile
index 297c9012e846..b0261d2d36a1 100644
--- a/deskutils/nautilus-locked-folder/Makefile
+++ b/deskutils/nautilus-locked-folder/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= pav
MAINTAINER= gnome@FreeBSD.org
COMMENT= Nautilus plugin that allows you to encrypt the contents of a folder
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_GNOME= nautilus2 eel2
PKGCONFIGS= gtk+-2.0 libglade-2.0 libnautilus-extension libgnomeui-2.0
diff --git a/deskutils/sunbird/Makefile b/deskutils/sunbird/Makefile
index 5089bf0ad2d4..167a6c79daf7 100644
--- a/deskutils/sunbird/Makefile
+++ b/deskutils/sunbird/Makefile
@@ -18,7 +18,7 @@ DISTNAME= lightning-${PORTNAME}-${DISTVERSION}-source
MAINTAINER= gecko@FreeBSD.org
COMMENT= Redesign of the Mozilla Calendar with XUL interface
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
ALL_TARGET= default
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
HAS_CONFIGURE= yes
diff --git a/deskutils/taskjuggler/Makefile b/deskutils/taskjuggler/Makefile
index 7c1a201bf838..130fdcdd2d63 100644
--- a/deskutils/taskjuggler/Makefile
+++ b/deskutils/taskjuggler/Makefile
@@ -28,7 +28,7 @@ USE_BZIP2= yes
USE_QT_VER= 3
USE_PERL5_RUN= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:262:env automake:19:env libtool:15:env
+USE_AUTOTOOLS= autoconf:262:env automake:19:env libtool:22:env
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_CFLAGS}"