aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-12-20 13:36:07 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-12-20 13:36:07 +0000
commitabc1625d9637eb064cc9deba823258572168397d (patch)
tree7a891647aa0e1cba3199bc42d7e0ef2ee01062d0 /deskutils
parent91571f28bbf0669a34236012bee885c2fa72b48a (diff)
downloadports-abc1625d9637eb064cc9deba823258572168397d.tar.gz
ports-abc1625d9637eb064cc9deba823258572168397d.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/lxshortcut/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/deskutils/lxshortcut/Makefile b/deskutils/lxshortcut/Makefile
index 15f167da2267..39a556c45f12 100644
--- a/deskutils/lxshortcut/Makefile
+++ b/deskutils/lxshortcut/Makefile
@@ -3,9 +3,10 @@
PORTNAME= lxshortcut
PORTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= SF/lxde/LXShortcut%20%28edit%20app%20shortcut%29/LXShortcut%20${PORTVERSION}/ \
- SF/nemysisfreebsdp/lxde/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
@@ -15,6 +16,8 @@ COMMENT= Small utility used to edit easily application shortcuts
LICENSE= GPLv3
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+
USES= gmake pkgconfig
USE_GNOME= gtk20 intlhack
GNU_CONFIGURE= yes
@@ -32,7 +35,7 @@ NLS_USES= gettext
SUB_FILES= ${PORTNAME}-start
-DESKTOP_ENTRIES="LXShortcut" "${COMMENT}" "${PORTNAME}" \
+DESKTOP_ENTRIES="LXShortcut" "" "${PORTNAME}" \
"${PORTNAME}-start" "Settings;GTK;DesktopSettings;" true
.include <bsd.port.options.mk>
@@ -48,7 +51,8 @@ post-patch:
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-start ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}