aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-12-07 17:31:52 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-12-07 17:31:52 +0000
commit1bb7a7389147c88f4b0b06816c148b065e63c58b (patch)
tree5acbd950a4fe5ea6a4b5144c3fd5c45d61b7aeb0 /deskutils
parentdeac843de9f69fe386de12fdf68b45b8090e83c6 (diff)
downloadports-1bb7a7389147c88f4b0b06816c148b065e63c58b.tar.gz
ports-1bb7a7389147c88f4b0b06816c148b065e63c58b.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/recoll/Makefile25
-rw-r--r--deskutils/recoll/distinfo3
-rw-r--r--deskutils/recoll/pkg-descr24
-rw-r--r--deskutils/recoll/pkg-plist30
5 files changed, 83 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 91b3ff16d7b0..584b9a1811e7 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -125,6 +125,7 @@
SUBDIR += preferences.app
SUBDIR += py-dosage
SUBDIR += pypanel
+ SUBDIR += recoll
SUBDIR += remember.el
SUBDIR += remind
SUBDIR += rolo
diff --git a/deskutils/recoll/Makefile b/deskutils/recoll/Makefile
new file mode 100644
index 000000000000..8723288d331a
--- /dev/null
+++ b/deskutils/recoll/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: recoll
+# Date created: 5 December 2005
+# Whom: J.F. Dockes <jean-francois.dockes@wanadoo.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= recoll
+PORTVERSION= 1.0.14
+CATEGORIES= deskutils
+MASTER_SITES= http://www.lesbonscomptes.com/recoll/
+
+MAINTAINER= jean-francois.dockes@wanadoo.fr
+COMMENT= A personal full text search package, based on QT and Xapian
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+LIB_DEPENDS= xapian.8:${PORTSDIR}/databases/xapian-core \
+ qt-mt.3:${PORTSDIR}/x11-toolkits/qt33
+
+USE_QT_VER= 3
+MAKE_ENV= QTDIR="${QT_PREFIX}" QMAKESPEC="freebsd-g++"
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/deskutils/recoll/distinfo b/deskutils/recoll/distinfo
new file mode 100644
index 000000000000..33897885076f
--- /dev/null
+++ b/deskutils/recoll/distinfo
@@ -0,0 +1,3 @@
+MD5 (recoll-1.0.14.tar.gz) = 223037883f26294405491e0e2c8ab33b
+SHA256 (recoll-1.0.14.tar.gz) = 0552c467c2c1c8eedc98a1fcc457304e29f080c2afe11fad5c55b88b4cf3548f
+SIZE (recoll-1.0.14.tar.gz) = 328158
diff --git a/deskutils/recoll/pkg-descr b/deskutils/recoll/pkg-descr
new file mode 100644
index 000000000000..8fd0397df041
--- /dev/null
+++ b/deskutils/recoll/pkg-descr
@@ -0,0 +1,24 @@
+Recoll is a personal full text search package with a QT graphical
+interface. It is based on a very strong backend (Xapian), for which it
+provides an easy to use and feature-rich interface.
+
+Features:
+ * Free, GPL license.
+ * QT-based GUI.
+ * Supports the following document types (and their compressed versions):
+ - Natively: text, html, OpenOffice files, maildir and mailbox
+ (Mozilla and Thunderbird mail ok), gaim log files.
+ - With external helpers: pdf (pdftotext), postscript (ghostscript),
+ msword (antiword), rtf (unrtf).
+ * Powerful query facilities, with boolean searches, phrases, filter on
+ file types and directory tree.
+ * Support for multiple charsets. Internal processing and storage uses
+ Unicode UTF-8.
+ * Stemming performed at query time (can switch stemming language after
+ indexing)
+ * Easy installation. No database daemon, web server or exotic language
+ necessary.
+ * An indexer which runs either as a thread inside the GUI or as an
+ external, cron'able program.
+
+WWW: http://www.lesbonscomptes.com/recoll/
diff --git a/deskutils/recoll/pkg-plist b/deskutils/recoll/pkg-plist
new file mode 100644
index 000000000000..1ba3297061d3
--- /dev/null
+++ b/deskutils/recoll/pkg-plist
@@ -0,0 +1,30 @@
+bin/recoll
+bin/recollindex
+%%DATADIR%%/examples/mimeconf
+%%DATADIR%%/examples/mimemap
+%%DATADIR%%/examples/recoll.conf
+%%DATADIR%%/filters/rcldoc
+%%DATADIR%%/filters/rclgaim
+%%DATADIR%%/filters/rclpdf
+%%DATADIR%%/filters/rclps
+%%DATADIR%%/filters/rclrtf
+%%DATADIR%%/filters/rclsoff
+%%DATADIR%%/filters/rcluncomp
+%%DATADIR%%/images/document.png
+%%DATADIR%%/images/drawing.png
+%%DATADIR%%/images/html.png
+%%DATADIR%%/images/message.png
+%%DATADIR%%/images/mozilla_doc.png
+%%DATADIR%%/images/pdf.png
+%%DATADIR%%/images/postscript.png
+%%DATADIR%%/images/presentation.png
+%%DATADIR%%/images/soffice.png
+%%DATADIR%%/images/spreadsheet.png
+%%DATADIR%%/images/txt.png
+%%DATADIR%%/images/wordprocessing.png
+%%DATADIR%%/translations/recoll_fr.qm
+@dirrm %%DATADIR%%/examples
+@dirrm %%DATADIR%%/filters
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/translations
+@dirrm %%DATADIR%%