aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2010-11-21 22:28:03 +0000
committerNicola Vitale <nivit@FreeBSD.org>2010-11-21 22:28:03 +0000
commit2a53dfb520911909b575935ac77e7e23a7d1c7ae (patch)
tree99f69d9a66eeadb6a90d03f536989af994e3b340 /deskutils
parentb7532f8f8454e22aeacf12800e8c42ef91fc21d9 (diff)
downloadports-2a53dfb520911909b575935ac77e7e23a7d1c7ae.tar.gz
ports-2a53dfb520911909b575935ac77e7e23a7d1c7ae.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/teapot/Makefile41
-rw-r--r--deskutils/teapot/distinfo7
-rw-r--r--deskutils/teapot/files/patch-CMakeLists.txt46
-rw-r--r--deskutils/teapot/files/patch-ab21
-rw-r--r--deskutils/teapot/pkg-descr6
-rw-r--r--deskutils/teapot/pkg-plist69
6 files changed, 124 insertions, 66 deletions
diff --git a/deskutils/teapot/Makefile b/deskutils/teapot/Makefile
index da851d9c13f7..61c765f131a8 100644
--- a/deskutils/teapot/Makefile
+++ b/deskutils/teapot/Makefile
@@ -6,40 +6,31 @@
#
PORTNAME= teapot
-PORTVERSION= 1.09
+PORTVERSION= 2.2.0
CATEGORIES= deskutils
-MASTER_SITES= http://www.moria.de/~michael/teapot/ \
- http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
+MASTER_SITES= http://www.syntax-k.de/projekte/${PORTNAME}/ \
+ http://www.syntax-k.de/projekte/${PORTNAME}/:docs
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:DEFAULT \
+ ${DISTNAME:C/^./T/}-Linux-x86${EXTRACT_SUFX}:docs
MAINTAINER= corky1951@comcast.net
COMMENT= Full-screen curses based spread sheet program
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="" LIBS="-lcurses -lm" \
- MAKEDEPEND=""
-ALL_TARGET= teapot
-MAN1= teapot.1
+USE_CMAKE= yes
-EXAMPLES= examples/asqrt examples/asqrt.README examples/blink \
- examples/counter examples/counter.README examples/life \
- examples/life.README examples/graphtest.sh examples/sqrt \
- examples/sqrt.README
-MYPORTDOCS= doc/teapot.doc doc/teapot.html doc/teapot.ps
+# We download the prebuilt binary tarball for Linux in order to avoid
+# having to generate the pdf and html docs from the LyX sourcecode.
+WRKSRC_DOCS= ${WRKDIR}/${DISTNAME:C/^./T/}-Linux/share/doc/${PORTNAME}
-post-build:
- @cd ${WRKSRC}/doc && ${MAKE} teapot.doc teapot.html teapot.ps
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/teapot ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/teapot.1.en ${MANPREFIX}/man/man1/teapot.1
+post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
-.for file in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${EXAMPLESDIR}
-.endfor
@${MKDIR} ${DOCSDIR}
-.for file in ${MYPORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ @(cd ${WRKSRC_DOCS} && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>
diff --git a/deskutils/teapot/distinfo b/deskutils/teapot/distinfo
index 7d621ae83a9c..35500d1a9fd7 100644
--- a/deskutils/teapot/distinfo
+++ b/deskutils/teapot/distinfo
@@ -1,3 +1,4 @@
-MD5 (teapot-1.09.tar.gz) = 21e1d1c1d04ba59af1fac6f49a4e2b1b
-SHA256 (teapot-1.09.tar.gz) = 868312231182881ebc5b67c9680e43b027a86bdd53fc2641bf99a188597e5ca2
-SIZE (teapot-1.09.tar.gz) = 161409
+SHA256 (teapot-2.2.0.tar.gz) = 883c6298002e0f4f27abeeb08f1c0282ae69de8f5b70619437b46ad92bb70916
+SIZE (teapot-2.2.0.tar.gz) = 113903
+SHA256 (Teapot-2.2.0-Linux-x86.tar.gz) = ba841701f50e3c6a84603db3cf2135025037a8809b58a0786ecfa68b844ce517
+SIZE (Teapot-2.2.0-Linux-x86.tar.gz) = 686141
diff --git a/deskutils/teapot/files/patch-CMakeLists.txt b/deskutils/teapot/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..75005c6e6925
--- /dev/null
+++ b/deskutils/teapot/files/patch-CMakeLists.txt
@@ -0,0 +1,46 @@
+--- CMakeLists.txt 2010-10-04 22:41:32.000000000 +0200
++++ CMakeLists.txt.port 2010-11-21 23:05:26.000000000 +0100
+@@ -5,7 +5,7 @@
+ set(Teapot_VERSION_MINOR 2)
+ set(Teapot_VERSION_PATCH 0)
+
+-option(ENABLE_HELP "Enable built-in documentation" ON)
++option(ENABLE_HELP "Enable built-in documentation" OFF)
+ option(ENABLE_UTF8 "Enable UTF-8 support" ON)
+
+ add_library(teapotlib context.c csv.c eval.c func.c html.c latex.c main.c misc.c parser.c sc.c scanner.c sheet.c utf8.c wk1.c xdr.c)
+@@ -36,25 +36,6 @@
+ install(TARGETS teapot DESTINATION bin)
+ endif ()
+
+-find_package(FLTK NO_MODULE)
+-if (FLTK_FOUND)
+- include(${FLTK_USE_FILE})
+-
+- fltk_wrap_ui(fteapot fteapot.fl)
+- add_executable(fteapot WIN32 ${fteapot_FLTK_UI_SRCS})
+- set(fteapot_DEB_DEPENDS ", libstdc++6 (>= 4.1.1), libx11-6, libxinerama1")
+- if (FLTK_XFT_FOUND)
+- set(fteapot_DEB_DEPENDS "${fteapot_DEB_DEPENDS}, libfontconfig1 (>= 2.4.0), libxft2 (>> 2.1.1)")
+- endif ()
+- if (ENABLE_HELP)
+- set(fteapot_DEB_DEPENDS "${fteapot_DEB_DEPENDS}, libjpeg62, libpng12-0 (>= 1.2.13-4)")
+- target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
+- else ()
+- target_link_libraries(fteapot teapotlib fltk ${LIB_PORTABLEXDR})
+- endif ()
+- install(TARGETS fteapot DESTINATION bin)
+-endif ()
+-
+ if (ENABLE_HELP)
+ add_custom_command(
+ OUTPUT teapot.tex teapot.lyx
+@@ -88,7 +69,7 @@
+ set(HELPFILE "${CMAKE_INSTALL_PREFIX}/share/doc/teapot/html/index.html")
+ endif ()
+
+-install(FILES COPYING README DESTINATION share/doc/teapot)
++#install(FILES COPYING README DESTINATION share/doc/teapot)
+
+ add_custom_target(dist
+ COMMAND ${CMAKE_COMMAND} -E remove_directory teapot-${Teapot_VERSION_MAJOR}.${Teapot_VERSION_MINOR}.${Teapot_VERSION_PATCH}
diff --git a/deskutils/teapot/files/patch-ab b/deskutils/teapot/files/patch-ab
deleted file mode 100644
index d41188644d3d..000000000000
--- a/deskutils/teapot/files/patch-ab
+++ /dev/null
@@ -1,21 +0,0 @@
---- doc/Makefile.orig Thu Mar 19 03:12:57 1998
-+++ doc/Makefile Sat Oct 28 06:36:44 2000
-@@ -5,15 +5,15 @@
- soelim teapot.MM | grep -v '^\.lf' >teapot.mm
-
- command.html.0 command.tbl.0: command command.bat insTH.ed
-- teapot -b command <command.bat
-+ ../teapot -b command <command.bat
- ed command.tbl.0 <insTH.ed
-
- editline.html.0 editline.tbl.0: editline editline.bat insTH.ed
-- teapot -b editline <editline.bat
-+ ../teapot -b editline <editline.bat
- ed editline.tbl.0 <insTH.ed
-
- unsorted.html.0 unsorted.tbl.0: unsorted unsorted.bat unsorted.ed
-- teapot -b unsorted <unsorted.bat
-+ ../teapot -b unsorted <unsorted.bat
- ed unsorted.tbl.0 <unsorted.ed
-
- teapot.ps: teapot.mm
diff --git a/deskutils/teapot/pkg-descr b/deskutils/teapot/pkg-descr
index a47ff533d08a..42e6aca3b282 100644
--- a/deskutils/teapot/pkg-descr
+++ b/deskutils/teapot/pkg-descr
@@ -14,9 +14,9 @@ o powerful cell addressing
o three-dimensional sheets
o new expression evaluator functions can be added very easy
o English, Dutch or German builtin messages or X/OPEN message catalogues
-o a user guide, available as troff -mm, PostScript and ASCII
+o a user guide, available as pdf and html
o It is still a small and simple program!
-The following URLs tell you a little more about it:
+NOTE: the GUI interface is not yet supported on FreeBSD
-WWW: http://www.moria.de/~michael/teapot/
+WWW: http://www.syntax-k.de/projekte/teapot
diff --git a/deskutils/teapot/pkg-plist b/deskutils/teapot/pkg-plist
index 94be9429e713..41d31dfc2370 100644
--- a/deskutils/teapot/pkg-plist
+++ b/deskutils/teapot/pkg-plist
@@ -1,16 +1,57 @@
+@comment $FreeBSD$
bin/teapot
-%%PORTDOCS%%%%DOCSDIR%%/teapot.doc
-%%PORTDOCS%%%%DOCSDIR%%/teapot.html
-%%PORTDOCS%%%%DOCSDIR%%/teapot.ps
-%%PORTDOCS%%%%EXAMPLESDIR%%/asqrt
-%%PORTDOCS%%%%EXAMPLESDIR%%/asqrt.README
-%%PORTDOCS%%%%EXAMPLESDIR%%/blink
-%%PORTDOCS%%%%EXAMPLESDIR%%/counter
-%%PORTDOCS%%%%EXAMPLESDIR%%/counter.README
-%%PORTDOCS%%%%EXAMPLESDIR%%/life
-%%PORTDOCS%%%%EXAMPLESDIR%%/life.README
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphtest.sh
-%%PORTDOCS%%%%EXAMPLESDIR%%/sqrt
-%%PORTDOCS%%%%EXAMPLESDIR%%/sqrt.README
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/html/About_this_document.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Batch_functions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Block_Functions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Cell_Attributes.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Command_Mode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Contents.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Copyright_Contributors_Lice.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Data_Types.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Differences_Between_User_In.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Expression_Grammar.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Expressions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/First_Steps.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Frequently_Asked_Questions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Functions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/General_Introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/How_do_I_hide_intermediate_.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Interactive_Functions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Introduction_Spread_Sheets.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Line_Editor.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Operators.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Other_Functions.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Saving_Loading.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Why_is_1_0_unequal_1_0.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Why_is_there_no_conditional.html
+%%PORTDOCS%%%%DOCSDIR%%/html/contents.png
+%%PORTDOCS%%%%DOCSDIR%%/html/footnode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/img1.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img2.png
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/next.png
+%%PORTDOCS%%%%DOCSDIR%%/html/next_g.png
+%%PORTDOCS%%%%DOCSDIR%%/html/prev.png
+%%PORTDOCS%%%%DOCSDIR%%/html/prev_g.png
+%%PORTDOCS%%%%DOCSDIR%%/html/teapot.html
+%%PORTDOCS%%%%DOCSDIR%%/html/up.png
+%%PORTDOCS%%%%DOCSDIR%%/html/up_g.png
+%%PORTDOCS%%%%DOCSDIR%%/teapot.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asqrt.README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asqrt.tp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/blink.tp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/counter.README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/counter.tp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphtest.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/life.README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/life.tp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/load_save_time.README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/load_save_time.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/load_save_time.tp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sqrt.README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sqrt.tp
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%