aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-05-05 09:02:46 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-05-05 09:02:46 +0000
commit499a363dd9c6e23797edbcdb462601657790b546 (patch)
tree7cb6184978bcd972897cfcbd203ba83907c3ad98 /deskutils
parent8b213808e54700a195092cad3344bba8ceb2ddd3 (diff)
downloadports-499a363dd9c6e23797edbcdb462601657790b546.tar.gz
ports-499a363dd9c6e23797edbcdb462601657790b546.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/xfce4-notification-daemon/Makefile2
-rw-r--r--deskutils/xfce4-notification-daemon/files/patch-src__daemon__daemon.c13
-rw-r--r--deskutils/xfce4-notification-daemon/files/patch-src__daemon__stack.c62
3 files changed, 76 insertions, 1 deletions
diff --git a/deskutils/xfce4-notification-daemon/Makefile b/deskutils/xfce4-notification-daemon/Makefile
index f9f5da9fde34..d19b7c0fd285 100644
--- a/deskutils/xfce4-notification-daemon/Makefile
+++ b/deskutils/xfce4-notification-daemon/Makefile
@@ -7,7 +7,7 @@
PORTNAME= notification-daemon
PORTVERSION= 0.3.7
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= deskutils xfce
MASTER_SITES= http://goodies.xfce.org/releases/notification-daemon-xfce/ \
CRITICAL
diff --git a/deskutils/xfce4-notification-daemon/files/patch-src__daemon__daemon.c b/deskutils/xfce4-notification-daemon/files/patch-src__daemon__daemon.c
new file mode 100644
index 000000000000..623e55c8b8f4
--- /dev/null
+++ b/deskutils/xfce4-notification-daemon/files/patch-src__daemon__daemon.c
@@ -0,0 +1,13 @@
+--- ./src/daemon/daemon.c.orig 2010-05-05 10:54:14.000000000 +0200
++++ ./src/daemon/daemon.c 2010-05-05 10:54:50.000000000 +0200
+@@ -1091,10 +1091,6 @@
+
+ g_set_application_name ("notification-daemon-xfce");
+
+-#ifdef G_ENABLE_DEBUG
+- g_log_set_always_fatal(G_LOG_LEVEL_ERROR | G_LOG_LEVEL_CRITICAL);
+-#endif
+-
+ gtk_init(&argc, &argv);
+
+ error = NULL;
diff --git a/deskutils/xfce4-notification-daemon/files/patch-src__daemon__stack.c b/deskutils/xfce4-notification-daemon/files/patch-src__daemon__stack.c
new file mode 100644
index 000000000000..9f597739d1f5
--- /dev/null
+++ b/deskutils/xfce4-notification-daemon/files/patch-src__daemon__stack.c
@@ -0,0 +1,62 @@
+--- ./src/daemon/stack.c.orig 2007-05-26 11:52:28.000000000 +0200
++++ ./src/daemon/stack.c 2010-05-05 10:54:02.000000000 +0200
+@@ -40,51 +40,18 @@
+ static gboolean
+ get_work_area(GtkWidget *nw, GdkRectangle *rect)
+ {
+- Atom workarea = XInternAtom(GDK_DISPLAY(), "_NET_WORKAREA", True);
+- Atom type;
+- Window win;
+- int format;
+- gulong num, leftovers;
+- gulong max_len = 4 * 32;
+- guchar *ret_workarea;
+- long *workareas;
+- int result;
+ GdkScreen *screen;
+- int disp_screen;
+
++ /* It would be best to allow the user to configure this, but the first
++ * monitor is a good default for now (the first monitor is likely the
++ * primary monitor). */
++
++ guint monitor = 0;
++
+ gtk_widget_realize(nw);
+ screen = gdk_drawable_get_screen(GDK_DRAWABLE(nw->window));
+- disp_screen = GDK_SCREEN_XNUMBER(screen);
+-
+- /* Defaults in case of error */
+- rect->x = 0;
+- rect->y = 0;
+- rect->width = gdk_screen_get_width(screen);
+- rect->height = gdk_screen_get_height(screen);
+-
+- if (workarea == None)
+- return FALSE;
+-
+- win = XRootWindow(GDK_DISPLAY(), disp_screen);
+- result = XGetWindowProperty(GDK_DISPLAY(), win, workarea, 0,
+- max_len, False, AnyPropertyType,
+- &type, &format, &num, &leftovers,
+- &ret_workarea);
+-
+- if (result != Success || type == None || format == 0 || leftovers ||
+- num % 4)
+- {
+- return FALSE;
+- }
+-
+- workareas = (long *)ret_workarea;
+- rect->x = workareas[disp_screen * 4];
+- rect->y = workareas[disp_screen * 4 + 1];
+- rect->width = workareas[disp_screen * 4 + 2];
+- rect->height = workareas[disp_screen * 4 + 3];
+-
+- XFree(ret_workarea);
+-
++
++ gdk_screen_get_monitor_geometry(screen, monitor, rect);
+ return TRUE;
+ }
+