aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-17 20:58:15 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-17 20:58:15 +0000
commite6f4d600f076adbf39bae4300e86c4b9d385eb81 (patch)
tree1decbcf90110d6b2b17dd464549f64c70ba1773d /deskutils
parent0a370a25f55ad36b8e7ed55544db0971a8c90bad (diff)
downloadports-e6f4d600f076adbf39bae4300e86c4b9d385eb81.tar.gz
ports-e6f4d600f076adbf39bae4300e86c4b9d385eb81.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/gdesklets-sensor-psi_memoover/Makefile47
-rw-r--r--deskutils/gdesklets-sensor-psi_memoover/distinfo1
-rw-r--r--deskutils/gdesklets-sensor-psi_memoover/files/patch-Install_MemoOver_Sensor.bin19
-rw-r--r--deskutils/gdesklets-sensor-psi_memoover/pkg-descr3
-rw-r--r--deskutils/gdesklets-sensor-psi_memoover/pkg-message20
-rw-r--r--deskutils/gdesklets-sensor-psi_memoover/pkg-plist9
7 files changed, 100 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index bd405c68c3c9..8383adbe061a 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -22,6 +22,7 @@
SUBDIR += gdesklets-recentlyused
SUBDIR += gdesklets-sensor-psi_iconbutton
SUBDIR += gdesklets-sensor-psi_memo
+ SUBDIR += gdesklets-sensor-psi_memoover
SUBDIR += gdesklets-sensor-psi_theme
SUBDIR += gdesklets-sensor-psi_variableborder
SUBDIR += gdesklets-starterbar
diff --git a/deskutils/gdesklets-sensor-psi_memoover/Makefile b/deskutils/gdesklets-sensor-psi_memoover/Makefile
new file mode 100644
index 000000000000..3df3b9297677
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memoover/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: gdesklets-sensor-psi_memoover
+# Date created: 20 September 2003
+# Whom: Franz Klammer <klammer@webonaut.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= memoover
+PORTVERSION= 0.1.0
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://gdesklets.gnomedesktop.org/files/
+PKGNAMEPREFIX= gdesklets-sensor-psi_
+DISTNAME= PsiSensorPackage-${DISTVERSION}
+
+MAINTAINER= klammer@webonaut.com
+COMMENT= MemoOver Sensor from the Psi Sensor Package
+
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gdesklets-core.pc:${PORTSDIR}/deskutils/gdesklets
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+
+DISTVERSION= 20031028
+NAME= MemoOver
+DATADIR= ${PREFIX}/share/gnome
+WRKSRC= ${WRKDIR}/${NAME}-${PORTVERSION}
+EXAMPLESDIR= ${PREFIX}/share/examples/${NAME}
+
+do-build:
+ @${WRKSRC}/Install_${NAME}_Sensor.bin --nomsg ${WRKSRC}
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
+
+do-install:
+ @${MKDIR} ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/*.py ${DATADIR}/gdesklets/Sensors/${NAME}/
+ @${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}/gdesklets/Sensors/${NAME}/
+ @${INSTALL_DATA} ${WRKSRC}/*.py ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/INSTALLATION ${EXAMPLESDIR}
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/deskutils/gdesklets-sensor-psi_memoover/distinfo b/deskutils/gdesklets-sensor-psi_memoover/distinfo
new file mode 100644
index 000000000000..bf4d02f7d5c7
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memoover/distinfo
@@ -0,0 +1 @@
+MD5 (PsiSensorPackage-20031028.tar.bz2) = 24c891e1d0f66426040b4e4fb618f9f5
diff --git a/deskutils/gdesklets-sensor-psi_memoover/files/patch-Install_MemoOver_Sensor.bin b/deskutils/gdesklets-sensor-psi_memoover/files/patch-Install_MemoOver_Sensor.bin
new file mode 100644
index 000000000000..008730e45596
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memoover/files/patch-Install_MemoOver_Sensor.bin
@@ -0,0 +1,19 @@
+--- Install_MemoOver_Sensor.bin.orig Wed Nov 19 18:34:09 2003
++++ Install_MemoOver_Sensor.bin Wed Nov 19 18:34:26 2003
+@@ -75,15 +75,9 @@
+ else:
+ cmd = "mkdir -p %(destination)s; cd %(destination)s; " \
+ "LANG=C tar -xzvf %(tmp)s 2>&1"
+- fail, out = commands.getstatusoutput(cmd % vars())
++ commands.getstatusoutput(cmd % vars())
+ os.unlink(tmp)
+
+- if (fail):
+- if (no_message): print ERROR_TAR + out
+- else: message(ERROR_TAR + out, "error")
+- sys.exit(1)
+-
+- print out
+ if (not list_only):
+ if (no_message): print SUCCESS
+ else: message(SUCCESS, "info")
diff --git a/deskutils/gdesklets-sensor-psi_memoover/pkg-descr b/deskutils/gdesklets-sensor-psi_memoover/pkg-descr
new file mode 100644
index 000000000000..0fcee866f1f5
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memoover/pkg-descr
@@ -0,0 +1,3 @@
+MemoOver Sensor from the Psi Sensor Package.
+
+WWW: http://gdesklets.gnomedesktop.org/
diff --git a/deskutils/gdesklets-sensor-psi_memoover/pkg-message b/deskutils/gdesklets-sensor-psi_memoover/pkg-message
new file mode 100644
index 000000000000..2dabf85ccab4
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memoover/pkg-message
@@ -0,0 +1,20 @@
+##
+To view the README, do the command following:
+
+ cat ${PREFIX}/share/gnome/gdesklets/Sensors/MemoOver/README
+
+## !! IMPORTANT !!
+
+To use this Sensor you must copy memo2.py _and_ memo2-gtodo.py from
+
+${PREFIX}/share/examples/MemoOver/ in to your ~/.gdesklets directory.
+
+##
+
+For further Information please do the follwing command:
+
+ cat ${PREFIX}/share/examples/MemoOver/INSTALLATION
+
+This is just a sensor, to actually see the data it collects, you have to install
+an appropriate display plugin.
+##
diff --git a/deskutils/gdesklets-sensor-psi_memoover/pkg-plist b/deskutils/gdesklets-sensor-psi_memoover/pkg-plist
new file mode 100644
index 000000000000..9876019568ee
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memoover/pkg-plist
@@ -0,0 +1,9 @@
+%%EXAMPLESDIR%%/INSTALLATION
+%%EXAMPLESDIR%%/memo2.py
+%%EXAMPLESDIR%%/memo2-gtodo.py
+share/gnome/gdesklets/Sensors/MemoOver/__init__.py
+share/gnome/gdesklets/Sensors/MemoOver/__init__.pyc
+share/gnome/gdesklets/Sensors/MemoOver/__init__.pyo
+share/gnome/gdesklets/Sensors/MemoOver/README
+@dirrm share/gnome/gdesklets/Sensors/MemoOver
+@dirrm %%EXAMPLESDIR%%