aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-05-12 13:08:04 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-05-12 13:08:04 +0000
commit9c8a1e00453be5252fe456ce6d1ef02fb4c1929d (patch)
tree3675e22831b75acc0cc6ed6a91c9108b7ededfe6 /deskutils
parent726b4f9323e7779e48c74221a0793968a25deea6 (diff)
downloadports-9c8a1e00453be5252fe456ce6d1ef02fb4c1929d.tar.gz
ports-9c8a1e00453be5252fe456ce6d1ef02fb4c1929d.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/drivel/Makefile6
-rw-r--r--deskutils/drivel/files/patch-show-options64
-rw-r--r--deskutils/drivel/files/patch-src-blog_lj47
-rw-r--r--deskutils/drivel/files/patch-src-main11
-rw-r--r--deskutils/drivel/pkg-descr16
5 files changed, 137 insertions, 7 deletions
diff --git a/deskutils/drivel/Makefile b/deskutils/drivel/Makefile
index e304d6d05278..cc7f75fc8ba3 100644
--- a/deskutils/drivel/Makefile
+++ b/deskutils/drivel/Makefile
@@ -12,8 +12,8 @@ CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= The Gnome livejournal client
+MAINTAINER= jbq@caraldi.com
+COMMENT= Blog editor for GNOME
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
@@ -23,7 +23,7 @@ USE_GNOME= gnomeprefix gnomehack libgnomeui intlhack gtksourceview
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/deskutils/drivel/files/patch-show-options b/deskutils/drivel/files/patch-show-options
new file mode 100644
index 000000000000..9b69c1a81855
--- /dev/null
+++ b/deskutils/drivel/files/patch-show-options
@@ -0,0 +1,64 @@
+--- src/journal.c.orig 25 Jun 2005 16:19:28 -0000 1.127
++++ src/journal.c 8 Mar 2006 13:18:06 -0000
+@@ -1401,6 +1401,16 @@
+ return;
+ }
+
++static void
++journal_set_expander(DrivelClient *dc, gboolean state)
++{
++ gtk_expander_set_expanded (GTK_EXPANDER (dc->journal_expander), state);
++ if (state)
++ gtk_label_set_text_with_mnemonic(GTK_LABEL(dc->journal_more_options), _("Hide _options"));
++ else
++ gtk_label_set_text_with_mnemonic(GTK_LABEL(dc->journal_more_options), _("Show more _options"));
++}
++
+ /* display the default items for a blank journal entry and set the sensitivity
+ of the widgets appropriately */
+
+@@ -1482,7 +1492,7 @@
+
+ /* set the expander state */
+ state = gconf_client_get_bool (dc->client, dc->gconf->expander_open, NULL);
+- gtk_expander_set_expanded (GTK_EXPANDER (dc->journal_expander), state);
++ journal_set_expander (dc,state);
+ gtk_toggle_action_set_active (GTK_TOGGLE_ACTION (dc->menu_view_options), state);
+
+ /* enable/disable highlighting */
+@@ -1753,7 +1763,7 @@
+ value = gconf_entry_get_value (entry);
+ state = gconf_value_get_bool (value);
+
+- gtk_expander_set_expanded (GTK_EXPANDER (dc->journal_expander), state);
++ journal_set_expander (dc,state);
+ gtk_toggle_action_set_active (GTK_TOGGLE_ACTION (dc->menu_view_options), state);
+
+ return;
+@@ -3399,7 +3409,7 @@
+ { "Strike", GTK_STOCK_STRIKETHROUGH, NULL, NULL, NULL, G_CALLBACK (strikethrough_cb) },
+ { "Super", NULL, N_("Supe_rscript"), NULL, NULL, G_CALLBACK (superscript_cb) },
+ { "Sub", NULL, N_("Subs_cript"), NULL, NULL, G_CALLBACK (subscript_cb) },
+- { "List", NULL, N_("L_ist"), NULL, NULL, G_CALLBACK (list_cb) },
++ { "List", NULL, N_("Lis_t"), NULL, NULL, G_CALLBACK (list_cb) },
+ { "ListItem", NULL, N_("List Ite_m"), NULL, NULL, G_CALLBACK (listitem_cb) },
+ { "Indent", NULL, N_("I_ndent"), NULL, NULL, G_CALLBACK (blockquote_cb) },
+ { "InsertLink", "drivel-insert-link", N_("Insert _Link..."), NULL, N_("Create a link to a web page, livejournal user, or a long journal entry"), G_CALLBACK (insert_link_cb) },
+@@ -3675,6 +3685,7 @@
+
+ /* options expander */
+ dc->journal_expander = glade_xml_get_widget (xml, "more_options");
++ dc->journal_more_options = glade_xml_get_widget (xml, "more_options_label");
+
+ /* buttons */
+ help_button = glade_xml_get_widget (xml, "help_button");
+--- src/drivel.h.orig 30 Aug 2005 17:46:18 -0000 1.56
++++ src/drivel.h 8 Mar 2006 13:18:06 -0000
+@@ -215,6 +215,7 @@
+ GtkWidget *journal_text;
+ GtkWidget *journal_security;
+ GtkWidget *journal_expander;
++ GtkWidget *journal_more_options;
+ GtkWidget *journal_picture;
+ GtkWidget *journal_comment;
+ GtkWidget *journal_autoformat;
diff --git a/deskutils/drivel/files/patch-src-blog_lj b/deskutils/drivel/files/patch-src-blog_lj
new file mode 100644
index 000000000000..9c4382e1f1f9
--- /dev/null
+++ b/deskutils/drivel/files/patch-src-blog_lj
@@ -0,0 +1,47 @@
+--- src/blog_lj.c.orig 25 Jun 2005 16:19:28 -0000 1.27
++++ src/blog_lj.c 28 Feb 2006 16:41:41 -0000
+@@ -826,6 +826,11 @@
+
+ for (j = 0; j < prop_count; j++)
+ {
++ g_snprintf (key, 32, "prop_%d_itemid", j + 1);
++ mesg = drivel_request_value_lookup (dr, key);
++ if (strcmp(mesg,itemid[i])!=0)
++ continue;
++
+ g_snprintf (key, 32, "prop_%d_name", j + 1);
+ mesg = drivel_request_value_lookup (dr, key);
+
+@@ -869,28 +874,28 @@
+ {
+ prop = journal_prop_new ();
+ prop->name = g_strdup ("music");
+- prop->value = g_strdup (picture[i]);
++ prop->value = g_strdup (music[i]);
+ g_array_append_val (entry->properties, prop);
+ }
+ if (mood[i])
+ {
+ prop = journal_prop_new ();
+ prop->name = g_strdup ("mood");
+- prop->value = g_strdup (picture[i]);
++ prop->value = g_strdup (mood[i]);
+ g_array_append_val (entry->properties, prop);
+ }
+ if (comments[i])
+ {
+ prop = journal_prop_new ();
+ prop->name = g_strdup ("comments");
+- prop->value = g_strdup (picture[i]);
++ prop->value = g_strdup (comments[i]);
+ g_array_append_val (entry->properties, prop);
+ }
+ if (autoformat[i])
+ {
+ prop = journal_prop_new ();
+ prop->name = g_strdup ("autoformat");
+- prop->value = g_strdup (picture[i]);
++ prop->value = g_strdup (autoformat[i]);
+ g_array_append_val (entry->properties, prop);
+ }
+ prop = journal_prop_new ();
diff --git a/deskutils/drivel/files/patch-src-main b/deskutils/drivel/files/patch-src-main
new file mode 100644
index 000000000000..b35c7251e61d
--- /dev/null
+++ b/deskutils/drivel/files/patch-src-main
@@ -0,0 +1,11 @@
+--- src/main.c.orig 30 Aug 2005 17:46:19 -0000 1.60
++++ src/main.c 6 Mar 2006 17:05:44 -0000
+@@ -253,7 +253,7 @@
+ {
+ c = g_utf8_get_char_validated (p, -1);
+
+- if (!g_unichar_isalnum (c) && c != '_' && c!= '-')
++ if (!g_unichar_isalnum (c) && c != '_' && c!= '-' && c!='@' && c!='.')
+ {
+ retval = FALSE;
+ break;
diff --git a/deskutils/drivel/pkg-descr b/deskutils/drivel/pkg-descr
index 20c87364be66..b2d3713f5d9c 100644
--- a/deskutils/drivel/pkg-descr
+++ b/deskutils/drivel/pkg-descr
@@ -1,7 +1,15 @@
-Drivel the livejournal client for Gnome.
+Drivel is a GNOME client for working with online journals, also known as
+weblogs or simply blogs. It retains a simple and elegant design while providing
+many powerful features, including:
-Its purpose is to retain a simple and elegant design while providing the
-same level of functionality as the offical LiveJournal clients. Drivel also
-integrates tightly with the GNOME Desktop technologies.
+ * Support for LiveJournal, Blogger, MovableType, Advogato, and Atom
+ journals (systems based off these are also supported, including WordPress
+ and Drupal)
+ * The ability to post, edit, delete, and view recent entries
+ * Integrated spellchecking and HTML syntax highlighting
+ * Offline composition and editing
+ * Automatic recovery in the event of a crash
+ * Journal system extensions, including LiveJournal security groups and
+ MovableType categories
WWW: http://www.dropline.net/drivel/