aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-02-22 04:29:46 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-02-22 04:29:46 +0000
commitfa2961ca4cf9b3b0cbece0862a7a7e8265fb6949 (patch)
tree951842aa4a33a5bff367907ed30c96820bd3608a /deskutils
parent6b661fda222711e65af722703789640b811c2bef (diff)
downloadports-fa2961ca4cf9b3b0cbece0862a7a7e8265fb6949.tar.gz
ports-fa2961ca4cf9b3b0cbece0862a7a7e8265fb6949.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/dailystrips/Makefile39
-rw-r--r--deskutils/dailystrips/distinfo4
-rw-r--r--deskutils/dailystrips/pkg-plist11
3 files changed, 24 insertions, 30 deletions
diff --git a/deskutils/dailystrips/Makefile b/deskutils/dailystrips/Makefile
index 9548be3d35ce..f784480903a5 100644
--- a/deskutils/dailystrips/Makefile
+++ b/deskutils/dailystrips/Makefile
@@ -1,41 +1,46 @@
-# New ports collection makefile for: dailystrips
-# Date created: 13 July 2001
-# Whom: Pete Fritchman <petef@databits.net>
-#
+# Created by: Pete Fritchman <petef@databits.net>
# $FreeBSD$
-#
PORTNAME= dailystrips
-PORTVERSION= 1.0.28
-PORTREVISION= 2
+PORTVERSION= 1.1.0
CATEGORIES= deskutils www
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Utility to download or view your favorite online comic strips daily
+LICENSE= GPLv2
+
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
NO_BUILD= yes
USE_PERL5= yes
-post-patch:
+PORTDOCS= *
+PLIST_FILES= bin/getstrips.pl \
+ bin/makepage.pl \
+ bin/shared_functions.pl \
+ share/dailystrips/strips.def
+PLIST_DIRS= share/dailystrips
+
+post-patch-script:
@${REINPLACE_CMD} 's|^#!/usr/bin/perl|#!${PERL}|; \
- s!/usr/share/dailystrips/strips.def!${DATADIR}/strips.def!' \
- ${WRKSRC}/dailystrips ${WRKSRC}/dailystrips-clean \
- ${WRKSRC}/dailystrips-update
+ s!strips.def!${DATADIR}/strips.def!; \
+ s!robotman!!; \
+ s!shared_functions.pl!${PREFIX}/bin/shared_functions.pl!' \
+ ${WRKSRC}/getstrips.pl ${WRKSRC}/makepage.pl \
+ ${WRKSRC}/strips.def
+
+.include <bsd.port.options.mk>
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/dailystrips ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/dailystrips-clean ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/dailystrips-update ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${PREFIX}/bin
@${MKDIR} ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/strips.def ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for file in README README.DEFS README.LOCAL README.dailystrips-clean \
- README.dailystrips-update
+.for file in README README.DEFS README.LOCAL archive.html
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/deskutils/dailystrips/distinfo b/deskutils/dailystrips/distinfo
index 145041d754e7..92b8441f7582 100644
--- a/deskutils/dailystrips/distinfo
+++ b/deskutils/dailystrips/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dailystrips-1.0.28.tar.gz) = dc54d8559d378fb4115a5605cff5d0e45a69f6ed1539f4aa31d6e13231c362ca
-SIZE (dailystrips-1.0.28.tar.gz) = 58713
+SHA256 (dailystrips-1.1.0.tar.gz) = 4de31c6e7e9fecd634f35a5a407dbc266f0f29cf79e391459697bea8e4751631
+SIZE (dailystrips-1.1.0.tar.gz) = 29740
diff --git a/deskutils/dailystrips/pkg-plist b/deskutils/dailystrips/pkg-plist
deleted file mode 100644
index 81594adf4c53..000000000000
--- a/deskutils/dailystrips/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-bin/dailystrips
-bin/dailystrips-clean
-bin/dailystrips-update
-share/dailystrips/strips.def
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.DEFS
-%%PORTDOCS%%%%DOCSDIR%%/README.LOCAL
-%%PORTDOCS%%%%DOCSDIR%%/README.dailystrips-clean
-%%PORTDOCS%%%%DOCSDIR%%/README.dailystrips-update
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm share/dailystrips