aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-05-11 10:54:54 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-05-11 10:54:54 +0000
commitfb24cdaff819ef744b6c6491366f6a22e7713093 (patch)
treeb8a206316910d57d6e9f68301b11d3ed25970282 /deskutils
parentf70c1dffb8a245cd41b61cc0a6c3b00da60c79b9 (diff)
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/dosage/Makefile32
-rw-r--r--deskutils/dosage/distinfo5
-rw-r--r--deskutils/dosage/files/patch-PKG-INFO151
-rw-r--r--deskutils/dosage/pkg-descr2
4 files changed, 178 insertions, 12 deletions
diff --git a/deskutils/dosage/Makefile b/deskutils/dosage/Makefile
index b9cbee7da453..cfd6d982a9c7 100644
--- a/deskutils/dosage/Makefile
+++ b/deskutils/dosage/Makefile
@@ -1,23 +1,37 @@
-# Created by: Antoine Brodin <antoine@FreeBSD.org>
# $FreeBSD$
PORTNAME= dosage
-PORTVERSION= 2.15
-PORTREVISION= 1
+DISTVERSION= 2.15-532
+DISTVERSIONSUFFIX= -gffbf49476
CATEGORIES= deskutils python
-MASTER_SITES= CHEESESHOP
MAINTAINER= antoine@FreeBSD.org
COMMENT= Application to keep a local mirror of web comics
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.9:devel/py-pbr@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>0:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cssselect>0:www/py-cssselect@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pbr>=1.9:devel/py-pbr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USE_GITHUB= yes
+GH_ACCOUNT= webcomics
USES= python
-USE_PYTHON= distutils autoplist concurrent optsuffix
+USE_PYTHON= distutils autoplist noflavors
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
-post-patch:
- @${REINPLACE_CMD} 's|share/man/man1|man/man1|' ${WRKSRC}/setup.py
+.if ${PYTHON_REL} < 3000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.shutil_get_terminal_size>0:devel/py-backports.shutil_get_terminal_size@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>0:devel/py-backports.functools_lru_cache@${PY_FLAVOR}
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/dosage/distinfo b/deskutils/dosage/distinfo
index 9aeae94e32d3..4dce7c000edb 100644
--- a/deskutils/dosage/distinfo
+++ b/deskutils/dosage/distinfo
@@ -1,2 +1,3 @@
-SHA256 (dosage-2.15.tar.gz) = db08edf2851b7afa8cc06c369b83a846c3609c21cfb0a79cc1b359eb1f2a660c
-SIZE (dosage-2.15.tar.gz) = 342943
+TIMESTAMP = 1556192436
+SHA256 (webcomics-dosage-2.15-532-gffbf49476_GH0.tar.gz) = 6f781a7d9a8ed70dad28ab692db112fa2df8829359c35feb3d09dce47d90a535
+SIZE (webcomics-dosage-2.15-532-gffbf49476_GH0.tar.gz) = 918287
diff --git a/deskutils/dosage/files/patch-PKG-INFO b/deskutils/dosage/files/patch-PKG-INFO
new file mode 100644
index 000000000000..bcb8f3ba2276
--- /dev/null
+++ b/deskutils/dosage/files/patch-PKG-INFO
@@ -0,0 +1,151 @@
+--- PKG-INFO.orig 2019-04-25 12:27:45 UTC
++++ PKG-INFO
+@@ -0,0 +1,148 @@
++Metadata-Version: 2.1
++Name: dosage
++Version: 2.15.1.dev523
++Summary: a comic strip downloader and archiver
++Home-page: http://dosage.rocks/
++Maintainer: Tobias Gruetzmacher
++Maintainer-email: tobias-dosage@23.gs
++License: MIT
++Description: # Dosage
++
++ [![Build Status](https://travis-ci.org/webcomics/dosage.svg?branch=master)](https://travis-ci.org/webcomics/dosage)
++ [![Code Climate](https://codeclimate.com/github/webcomics/dosage/badges/gpa.svg)](https://codeclimate.com/github/webcomics/dosage)
++ [![codecov](https://codecov.io/gh/webcomics/dosage/branch/master/graph/badge.svg)](https://codecov.io/gh/webcomics/dosage)
++ [![Maintenance](https://img.shields.io/maintenance/yes/2018.svg)]()
++
++ Dosage is designed to keep a local copy of specific webcomics and other
++ picture-based content such as Picture of the Day sites. With the dosage
++ commandline script you can get the latest strip of a webcomic, or catch-up to
++ the last strip downloaded, or download a strip for a particular date/index (if
++ the webcomic's site layout allows this).
++
++ Multiple webcomics can be downloaded in parallel, making the update of comic
++ strips faster.
++
++ ## Notice
++
++ This software is in no way intended to publically "broadcast" comic strips, it
++ is purely for personal use. Please be aware that by making downloaded strips
++ publically available (without the explicit permission of the author) you may be
++ infringing upon various copyrights.
++
++ Additionally, Dosage respects the robots.txt exclusion protocol. This makes
++ sure no content is accessed in an automatic way without consent by the
++ publishers.
++
++ In any case, you should support the authors of the comics you are downloading,
++ either by buying some of their products or even donating them some money since
++ they provide the comics you like and read.
++
++ If you are a publisher of comics and want Dosage to access your files,
++ add the following entry to your robots.txt file:
++
++ User-agent: Dosage
++ Allow: *
++
++ ## Adult content
++
++ Some comics contain adult content and require age confirmation. These comics
++ can only be downloaded by using the `--adult` option, which confirms that you
++ are old enough to view them.
++
++ ## Usage
++
++ List available comics (ca. 3000 at the moment):
++
++ $ dosage --list
++
++ Get the latest comic of for example CalvinAndHobbes and save it in the "Comics"
++ directory:
++
++ $ dosage CalvinAndHobbes
++
++ If you already have downloaded several comics and want to get the latest strip
++ of all of them:
++
++ $ dosage @
++
++
++ To help others find good comics, you can vote for your favourite ones:
++
++ $ dosage --vote @
++
++ For advanced options and features execute `dosage --help`.
++
++ ## Dependencies
++
++ [Python](http://www.python.org/): for Python 2.x at least 2.7.0, for Python 3.x
++ at least Python 3.3. Dosage requires the following Python modules:
++
++ - colorama
++ - lxml
++ - pbr
++ - requests
++ - six
++
++ For certain modules, you need the `cssselect` module, for bash argument
++ completion you need the `argcomplete` module.
++
++ ## Installation
++
++ The easy way with pip:
++
++ pip install --user dosage
++
++ You can invoke Dosage directly from the source code as `./dosage`.
++ Alternatively, you can install Dosage using setuptools by invoking `setup.py`
++ in the root of the distribution. For example:
++
++ python setup.py install
++
++ or if you do not have root permissions:
++
++ python setup.py install --home=$HOME
++
++ ## Reporting Bugs
++
++ You can report bugs, patches or requests at the [GitHub issue
++ tracker](https://github.com/webcomics/dosage/issues) - Dosage currently
++ supports a large number of comics and that number grows on a regular basis. If
++ you feel that there are comics that Dosage does not currently support, but
++ should support, please feel free to request them.
++
++ ## Extending Dosage
++
++ In order to add a new webcomic, a new module class has to be created in one of
++ the *.py files in the `dosagelib/plugins` subdirectory. Look at the
++ [documentation for adding modules](doc/adding_new_comics.md) and at
++ existing module classes for examples.
++
++ ### Test suite status
++
++ Dosage has extensive unit tests to ensure the code quality.
++ [Travis-CI](https://travis-ci.org/) is used for continuous build and test
++ integration. See the badges at the top of this page for the current status.
++
++
++Keywords: comic,webcomic,downloader,archiver,crawler
++Platform: Any
++Classifier: Environment :: Console
++Classifier: Intended Audience :: End Users/Desktop
++Classifier: Topic :: Multimedia :: Graphics
++Classifier: Topic :: Internet :: WWW/HTTP
++Classifier: Development Status :: 4 - Beta
++Classifier: License :: OSI Approved :: MIT License
++Classifier: Programming Language :: Python
++Classifier: Programming Language :: Python :: 2
++Classifier: Programming Language :: Python :: 2.7
++Classifier: Programming Language :: Python :: 3
++Classifier: Programming Language :: Python :: 3.4
++Classifier: Programming Language :: Python :: 3.5
++Classifier: Programming Language :: Python :: 3.6
++Classifier: Programming Language :: Python :: 3.7
++Classifier: Operating System :: OS Independent
++Requires-Python: >=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*
++Provides-Extra: css
++Provides-Extra: dimensions
++Provides-Extra: bash
++Provides-Extra: test
diff --git a/deskutils/dosage/pkg-descr b/deskutils/dosage/pkg-descr
index d3d08cb4af5e..e589fe093c1c 100644
--- a/deskutils/dosage/pkg-descr
+++ b/deskutils/dosage/pkg-descr
@@ -4,4 +4,4 @@ dosage commandline script you can get the latest strip of a webcomic, or
catch-up to the last strip downloaded, or download a strip for a particular
date/index (if the webcomic's site layout allows this).
-WWW: http://wummel.github.io/dosage/
+WWW: https://dosage.rocks/