aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-06 21:17:14 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-06 21:17:14 +0000
commit4564feab5f3be88380164e5ff883653a646e7447 (patch)
tree7e8d564ca114c3f4618ec7e8a662615acde71af8 /deskutils
parentdd2ba8a26778d2a56a70eeb5588dcf92dc84fe2a (diff)
downloadports-4564feab5f3be88380164e5ff883653a646e7447.tar.gz
ports-4564feab5f3be88380164e5ff883653a646e7447.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/intclock/Makefile33
-rw-r--r--deskutils/intclock/distinfo3
-rw-r--r--deskutils/intclock/pkg-descr5
-rw-r--r--deskutils/intclock/pkg-plist25
5 files changed, 67 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index f5568e6c0688..3337b7b8586f 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -99,6 +99,7 @@
SUBDIR += hot-babe
SUBDIR += howm
SUBDIR += ical
+ SUBDIR += intclock
SUBDIR += ithought
SUBDIR += jlj
SUBDIR += karamba
diff --git a/deskutils/intclock/Makefile b/deskutils/intclock/Makefile
new file mode 100644
index 000000000000..1ce2692214c5
--- /dev/null
+++ b/deskutils/intclock/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: intclock
+# Date created: 6 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= intclock
+PORTVERSION= 2.10
+CATEGORIES= deskutils perl5
+MASTER_SITES= http://www.peterverthez.net/projects/${PORTNAME}/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Multi-timezone clock
+
+BUILD_DEPENDS= p5-Gtk2>=1.144:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ iso-codes>=1.3:${PORTSDIR}/misc/iso-codes
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$$zonedir/$$countryfile|${LOCALBASE}/share/iso-codes/iso_3166.tab|' \
+ ${WRKSRC}/lib/Intclock/TZ.pm
+ @${REINPLACE_CMD} -e 's|$$prefix/share/intclock|${DATADIR}|;\
+ s|/usr/share|${PREFIX}/share|' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -e 's|/usr/bin|${PREFIX}/bin|;\
+ s|/usr/share/intclock|${DATADIR}|' ${WRKSRC}/data/intclock.desktop
+ @${FIND} ${WRKSRC} -name \*.bak -delete
+
+.include <bsd.port.mk>
diff --git a/deskutils/intclock/distinfo b/deskutils/intclock/distinfo
new file mode 100644
index 000000000000..27a2b40cceef
--- /dev/null
+++ b/deskutils/intclock/distinfo
@@ -0,0 +1,3 @@
+MD5 (intclock-2.10.tar.gz) = f15772dd7b9e86629f5df79f29d3371d
+SHA256 (intclock-2.10.tar.gz) = 5a50b0d258c9e619ec88dbd4dc04ca5c5ce2afa2a37b5f8dd3e5ed28202b82de
+SIZE (intclock-2.10.tar.gz) = 320000
diff --git a/deskutils/intclock/pkg-descr b/deskutils/intclock/pkg-descr
new file mode 100644
index 000000000000..3d842ff4c69a
--- /dev/null
+++ b/deskutils/intclock/pkg-descr
@@ -0,0 +1,5 @@
+Intclock provides a graphical multi-timezone clock that is customizable
+via a configuration window. It is based on hsclock.
+
+WWW: http://www.peterverthez.net/projects/intclock/
+Author: Peter Verthez <peter.verthez@advalvas.be>
diff --git a/deskutils/intclock/pkg-plist b/deskutils/intclock/pkg-plist
new file mode 100644
index 000000000000..a6fba9c2e7c6
--- /dev/null
+++ b/deskutils/intclock/pkg-plist
@@ -0,0 +1,25 @@
+bin/intclock
+%%SITE_PERL%%/Intclock/Config.pm
+%%SITE_PERL%%/Intclock/L10N/de.pm
+%%SITE_PERL%%/Intclock/L10N/en.pm
+%%SITE_PERL%%/Intclock/L10N/fr.pm
+%%SITE_PERL%%/Intclock/L10N/nl.pm
+%%SITE_PERL%%/Intclock/L10N/pl.pm
+%%SITE_PERL%%/Intclock/L10N/ru.pm
+%%SITE_PERL%%/Intclock/L10N.pm
+%%SITE_PERL%%/Intclock/TZ.pm
+%%SITE_PERL%%/Intclock/UI.pm
+%%SITE_PERL%%/Intclock/UI_gtk.pm
+%%SITE_PERL%%/Intclock/UI_gtk2.pm
+%%SITE_PERL%%/Intclock/UI_tty.pm
+%%SITE_PERL%%/Intclock.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Intclock/.packlist
+share/applications/intclock.desktop
+%%DATADIR%%/intclock.png
+%%DATADIR%%/territories.dat
+%%DATADIR%%/zones.dat
+@dirrm %%SITE_PERL%%/Intclock/L10N
+@dirrm %%SITE_PERL%%/Intclock
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Intclock
+@dirrm %%DATADIR%%
+@dirrmtry share/applications