aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-09-17 03:23:39 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-09-17 03:23:39 +0000
commit798509269d40f4b59c2e50ad160fe0259f04fef6 (patch)
tree0bb5227a94655bc93388fb0644f03b5ddfefa83a /deskutils
parentfbe19321341308dbb80868f167e8b3ac591c6c46 (diff)
downloadports-798509269d40f4b59c2e50ad160fe0259f04fef6.tar.gz
ports-798509269d40f4b59c2e50ad160fe0259f04fef6.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/kmymoney2/Makefile21
-rw-r--r--deskutils/kmymoney2/distinfo1
-rw-r--r--deskutils/kmymoney2/files/patch-aa71
-rw-r--r--deskutils/kmymoney2/files/patch-ab25
-rw-r--r--deskutils/kmymoney2/pkg-comment1
-rw-r--r--deskutils/kmymoney2/pkg-descr15
-rw-r--r--deskutils/kmymoney2/pkg-plist48
8 files changed, 183 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index fcf9fec902bb..7b82bdb5f276 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -21,6 +21,7 @@
SUBDIR += ithought
SUBDIR += jlj
SUBDIR += kdepim
+ SUBDIR += kmymoney2
SUBDIR += korganizer
SUBDIR += kproject
SUBDIR += logjam
diff --git a/deskutils/kmymoney2/Makefile b/deskutils/kmymoney2/Makefile
new file mode 100644
index 000000000000..125e17bf408f
--- /dev/null
+++ b/deskutils/kmymoney2/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: kmymoney
+# Date created: 16 September 2001
+# Whom: dwcjr
+#
+# $FreeBSD$
+#
+
+PORTNAME= kmymoney2
+PORTVERSION= 0.3.6
+CATEGORIES= deskutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}"
+MASTER_SITE_SUBDIR= kmymoney2
+
+MAINTAINER= dmitry_makovey@mail.com
+
+USE_KDELIBS_VER=2
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOCONF= yes
+
+.include <bsd.port.mk>
diff --git a/deskutils/kmymoney2/distinfo b/deskutils/kmymoney2/distinfo
new file mode 100644
index 000000000000..cdd44ac838b6
--- /dev/null
+++ b/deskutils/kmymoney2/distinfo
@@ -0,0 +1 @@
+MD5 (kmymoney2-0.3.6.tar.bz2) = 9cc43770c3c1ae2851fbb844386f1d14
diff --git a/deskutils/kmymoney2/files/patch-aa b/deskutils/kmymoney2/files/patch-aa
new file mode 100644
index 000000000000..b0807fe599ee
--- /dev/null
+++ b/deskutils/kmymoney2/files/patch-aa
@@ -0,0 +1,71 @@
+*** acinclude.m4.orig Fri Jul 27 21:38:25 2001
+--- acinclude.m4 Thu Aug 2 16:22:56 2001
+***************
+*** 143,149 ****
+ qt_bindirs="$ac_qt_bindir $qt_bindirs"
+ fi
+
+! KDE_FIND_PATH(moc, MOC, [$qt_bindirs], [KDE_MOC_ERROR_MESSAGE])
+ KDE_FIND_PATH(uic, UIC, [$qt_bindirs], [UIC="" ; KDE_UIC_ERROR_MESSAGE])
+ if test -z "$UIC" ; then
+ if test -z "$UIC_NOT_NEEDED" ; then
+--- 143,149 ----
+ qt_bindirs="$ac_qt_bindir $qt_bindirs"
+ fi
+
+! KDE_FIND_PATH(moc2, MOC, [$qt_bindirs], [KDE_MOC_ERROR_MESSAGE])
+ KDE_FIND_PATH(uic, UIC, [$qt_bindirs], [UIC="" ; KDE_UIC_ERROR_MESSAGE])
+ if test -z "$UIC" ; then
+ if test -z "$UIC_NOT_NEEDED" ; then
+***************
+*** 878,891 ****
+
+ if test -z "$LIBQT_GLOB"; then
+
+! LIBQT_GLOB="libqt.*"
+
+ fi
+
+ if test -z "$LIBQT"; then
+
+! LIBQT="-lqt"
+! kde_int_qt="-lqt"
+
+ dnl ------------------------------------------------------------------------
+ dnl If we got --enable-qt-mt then adjust the Qt library name for the host.
+--- 878,891 ----
+
+ if test -z "$LIBQT_GLOB"; then
+
+! LIBQT_GLOB="libqt2.*"
+
+ fi
+
+ if test -z "$LIBQT"; then
+
+! LIBQT="-lqt2"
+! kde_int_qt="-lqt2"
+
+ dnl ------------------------------------------------------------------------
+ dnl If we got --enable-qt-mt then adjust the Qt library name for the host.
+***************
+*** 896,904 ****
+ case $host in
+ *-*-linux-*)
+ if test "x$GCC" = "xyes"; then
+! LIBQT="-lqt-mt"
+! kde_int_qt="-lqt-mt"
+! LIBQT_GLOB="libqt-mt.*"
+ USING_QT_MT="using -mt"
+ fi
+ ;;
+--- 896,904 ----
+ case $host in
+ *-*-linux-*)
+ if test "x$GCC" = "xyes"; then
+! LIBQT="-lqt2-mt"
+! kde_int_qt="-lqt2-mt"
+! LIBQT_GLOB="libqt2-mt.*"
+ USING_QT_MT="using -mt"
+ fi
+ ;;
diff --git a/deskutils/kmymoney2/files/patch-ab b/deskutils/kmymoney2/files/patch-ab
new file mode 100644
index 000000000000..c6980a17b23a
--- /dev/null
+++ b/deskutils/kmymoney2/files/patch-ab
@@ -0,0 +1,25 @@
+*** kmymoney2/kmymoneyview.orig Fri Jul 27 20:51:32 2001
+--- kmymoney2/kmymoneyview.cpp Wed Aug 1 18:14:47 2001
+***************
+*** 1639,1648 ****
+ + ","
+ + ((transaction->type()==MyMoneyTransaction::Credit) ?
+ QString::number(transaction->amount().amount()) :
+! "")
+ + ","
+ + ((transaction->type()==MyMoneyTransaction::Credit) ?
+! "" :
+ QString::number(transaction->amount().amount()))
+ + ","
+ + "\n"
+--- 1639,1648 ----
+ + ","
+ + ((transaction->type()==MyMoneyTransaction::Credit) ?
+ QString::number(transaction->amount().amount()) :
+! (QString)"")
+ + ","
+ + ((transaction->type()==MyMoneyTransaction::Credit) ?
+! (QString)"" :
+ QString::number(transaction->amount().amount()))
+ + ","
+ + "\n"
diff --git a/deskutils/kmymoney2/pkg-comment b/deskutils/kmymoney2/pkg-comment
new file mode 100644
index 000000000000..e64f953a68a7
--- /dev/null
+++ b/deskutils/kmymoney2/pkg-comment
@@ -0,0 +1 @@
+KMyMoney2 - The Personal Finances Manager for KDE
diff --git a/deskutils/kmymoney2/pkg-descr b/deskutils/kmymoney2/pkg-descr
new file mode 100644
index 000000000000..c20ca27fc4bd
--- /dev/null
+++ b/deskutils/kmymoney2/pkg-descr
@@ -0,0 +1,15 @@
+KMyMoney2 - The Personal Finances Manager for KDE
+
+ KMyMoney2 is specifically aimed at the typical home user at present.
+ The current version provides the basis for manipulating accounts that contain
+transactions. Each account belongs to an institution and can be reconciled to
+balance your transactions.
+ QIF import and export is supported within accounts so KMyMoney2 can read
+files exported from other programs and when downloaded from online banking
+institutions.
+ A search dialog is also provided to let the user find transactions that
+match specific criteria such as the amount.
+Support for Categories and Payees are also provided allowing the user to
+input meaningful information when entering their transactions and providing
+a means for a future incarnation of KMyMoney2 to provide reporting and
+budgeting features.
diff --git a/deskutils/kmymoney2/pkg-plist b/deskutils/kmymoney2/pkg-plist
new file mode 100644
index 000000000000..0047210a272b
--- /dev/null
+++ b/deskutils/kmymoney2/pkg-plist
@@ -0,0 +1,48 @@
+@cwd /usr/local
+bin/kmymoney2
+share/doc/HTML/en/kmymoney2/common
+share/doc/HTML/en/kmymoney2/index.docbook
+share/doc/HTML/en/kmymoney2/blank_icon.png
+share/doc/HTML/en/kmymoney2/mainwindow.png
+share/doc/HTML/en/kmymoney2/newaccount.png
+share/doc/HTML/en/kmymoney2/newaccount_icon.png
+share/doc/HTML/en/kmymoney2/newbank.png
+share/doc/HTML/en/kmymoney2/newbank_icon.png
+share/doc/HTML/en/kmymoney2/startdialog.png
+share/doc/HTML/en/kmymoney2/transwindow.png
+share/applnk/Applications/kmymoney2.desktop
+share/apps/kmymoney2/toolbar/kmymoney_newacc.xpm
+share/apps/kmymoney2/toolbar/kmymoney_up.xpm
+share/apps/kmymoney2/pics/account-folder.xpm
+share/apps/kmymoney2/pics/bank-folder.xpm
+share/apps/kmymoney2/pics/startlogo.png
+share/apps/kmymoney2/pics/setting_list.png
+share/apps/kmymoney2/icons/hicolor/22x22/actions/pay_edit.png
+share/apps/kmymoney2/icons/hicolor/22x22/actions/bank.png
+share/apps/kmymoney2/icons/hicolor/22x22/actions/categories.png
+share/apps/kmymoney2/icons/hicolor/22x22/actions/transaction_find.png
+share/apps/kmymoney2/icons/hicolor/22x22/actions/reconcile.png
+share/apps/kmymoney2/icons/hicolor/16x16/actions/bank.png
+share/apps/kmymoney2/icons/hicolor/16x16/actions/categories.png
+share/apps/kmymoney2/icons/hicolor/16x16/actions/pay_edit.png
+share/apps/kmymoney2/icons/hicolor/16x16/actions/transaction_export.png
+share/apps/kmymoney2/icons/hicolor/16x16/actions/transaction_find.png
+share/apps/kmymoney2/icons/hicolor/16x16/actions/transaction_import.png
+share/apps/kmymoney2/icons/hicolor/16x16/actions/reconcile.png
+share/apps/kmymoney2/kmymoney2ui.rc
+share/apps/kmymoney2/default_categories.dat
+share/icons/locolor/16x16/apps/kmymoney2.png
+share/icons/locolor/32x32/apps/kmymoney2.png
+share/icons/hicolor/16x16/mimetypes/kmy.png
+share/icons/hicolor/32x32/mimetypes/kmy.png
+share/icons/hicolor/48x48/mimetypes/kmy.png
+@dirrm share/doc/HTML/en/kmymoney2
+@dirrm share/apps/kmymoney2/toolbar
+@dirrm share/apps/kmymoney2/pics
+@dirrm share/apps/kmymoney2/icons/hicolor/16x16/actions
+@dirrm share/apps/kmymoney2/icons/hicolor/16x16
+@dirrm share/apps/kmymoney2/icons/hicolor/22x22/actions
+@dirrm share/apps/kmymoney2/icons/hicolor/22x22
+@dirrm share/apps/kmymoney2/icons/hicolor
+@dirrm share/apps/kmymoney2/icons
+@dirrm share/apps/kmymoney2