aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-26 17:45:24 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-26 17:45:24 +0000
commitcf57632844549b9c46acc64c2e60bd4a272bd748 (patch)
tree35efd56dc2cd8ec32ed362f55c9d2370ad84ecd7 /deskutils
parent7baa3768c103f72e343fcafb111e9423beab9534 (diff)
downloadports-cf57632844549b9c46acc64c2e60bd4a272bd748.tar.gz
ports-cf57632844549b9c46acc64c2e60bd4a272bd748.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/p5-ZConf-Runner/Makefile25
-rw-r--r--deskutils/p5-ZConf-Runner/distinfo3
-rw-r--r--deskutils/p5-ZConf-Runner/pkg-descr5
-rw-r--r--deskutils/p5-ZConf-Runner/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index c24a0f278804..d664b569108d 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -190,6 +190,7 @@
SUBDIR += org-mode.el6
SUBDIR += p5-Data-ICal
SUBDIR += p5-Goo
+ SUBDIR += p5-ZConf-Runner
SUBDIR += pal
SUBDIR += phpgroupware
SUBDIR += phpicalendar
diff --git a/deskutils/p5-ZConf-Runner/Makefile b/deskutils/p5-ZConf-Runner/Makefile
new file mode 100644
index 000000000000..48a2be9bc328
--- /dev/null
+++ b/deskutils/p5-ZConf-Runner/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-ZConf-Runner
+# Date created: 2009-01-14
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ZConf-Runner
+PORTVERSION= 0.0.0
+CATEGORIES= deskutils perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/V/VV/VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Run a file using a choosen methode, desktop entry or mimetype
+
+RUN_DEPENDS= ${SITE_PERL}/ZConf.pm:${PORTSDIR}/net/p5-ZConf \
+ ${SITE_PERL}/File/MimeInfo/Applications.pm:${PORTSDIR}/devel/p5-File-MimeInfo
+
+PERL_CONFIGURE= yes
+
+MAN3= ZConf::Runner.3
+
+.include <bsd.port.mk>
diff --git a/deskutils/p5-ZConf-Runner/distinfo b/deskutils/p5-ZConf-Runner/distinfo
new file mode 100644
index 000000000000..5f3292c1fbc4
--- /dev/null
+++ b/deskutils/p5-ZConf-Runner/distinfo
@@ -0,0 +1,3 @@
+MD5 (ZConf-Runner-0.0.0.tar.gz) = e82881c51fb617453d3dd271d6a82289
+SHA256 (ZConf-Runner-0.0.0.tar.gz) = bc0bcff049db0f749c41d401c252d138d5b56aeb796a3776d18cc110e93d2d4b
+SIZE (ZConf-Runner-0.0.0.tar.gz) = 12233
diff --git a/deskutils/p5-ZConf-Runner/pkg-descr b/deskutils/p5-ZConf-Runner/pkg-descr
new file mode 100644
index 000000000000..e067613187be
--- /dev/null
+++ b/deskutils/p5-ZConf-Runner/pkg-descr
@@ -0,0 +1,5 @@
+A configuration system allowing for either file or LDAP backed storage. A
+utility is included as well, 'zcrunner'. It can be used to configure
+actions and run files using them.
+
+WWW: http://search.cpan.org/dist/ZConf-Runner
diff --git a/deskutils/p5-ZConf-Runner/pkg-plist b/deskutils/p5-ZConf-Runner/pkg-plist
new file mode 100644
index 000000000000..40ee834ef1e0
--- /dev/null
+++ b/deskutils/p5-ZConf-Runner/pkg-plist
@@ -0,0 +1,7 @@
+bin/zcrunner
+%%SITE_PERL%%/ZConf/Runner.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf/Runner/.packlist
+@dirrm %%SITE_PERL%%/ZConf/Runner
+@dirrmtry %%SITE_PERL%%/ZConf
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf/Runner
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf