aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-01-05 02:29:15 +0000
committerWill Andrews <will@FreeBSD.org>2002-01-05 02:29:15 +0000
commit06517618a812d2a1631079a20caf7f3450155bad (patch)
tree78d48542d953726af080bfe301c2607b5d780984 /deskutils
parent84a76d28958c9ce909d0e88281e6b8f2384ab39e (diff)
downloadports-06517618a812d2a1631079a20caf7f3450155bad.tar.gz
ports-06517618a812d2a1631079a20caf7f3450155bad.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/kcharselect/Makefile11
-rw-r--r--deskutils/kdepim/Makefile12
-rw-r--r--deskutils/kdepim3/Makefile12
-rw-r--r--deskutils/kdepim4/Makefile12
-rw-r--r--deskutils/kdepim44/Makefile12
5 files changed, 40 insertions, 19 deletions
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
index 508f22d74d90..80195deac0fa 100644
--- a/deskutils/kcharselect/Makefile
+++ b/deskutils/kcharselect/Makefile
@@ -15,14 +15,19 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-objprelink
+CONFIGURE_ARGS?=
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/deskutils/kdepim/Makefile b/deskutils/kdepim/Makefile
index 226f3fbdb51a..df618f1d2dd2 100644
--- a/deskutils/kdepim/Makefile
+++ b/deskutils/kdepim/Makefile
@@ -15,8 +15,10 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= pisock.4:${PORTSDIR}/palm/pilot-link
USE_KDELIBS_VER=2
@@ -24,9 +26,11 @@ USE_BISON= yes
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-objprelink \
- --with-extra-includes=${LOCALBASE}/pilot/include \
+CONFIGURE_ARGS= --with-extra-includes=${LOCALBASE}/pilot/include \
--with-extra-libs=${LOCALBASE}/pilot/lib
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/deskutils/kdepim3/Makefile b/deskutils/kdepim3/Makefile
index 226f3fbdb51a..df618f1d2dd2 100644
--- a/deskutils/kdepim3/Makefile
+++ b/deskutils/kdepim3/Makefile
@@ -15,8 +15,10 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= pisock.4:${PORTSDIR}/palm/pilot-link
USE_KDELIBS_VER=2
@@ -24,9 +26,11 @@ USE_BISON= yes
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-objprelink \
- --with-extra-includes=${LOCALBASE}/pilot/include \
+CONFIGURE_ARGS= --with-extra-includes=${LOCALBASE}/pilot/include \
--with-extra-libs=${LOCALBASE}/pilot/lib
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index 226f3fbdb51a..df618f1d2dd2 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -15,8 +15,10 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= pisock.4:${PORTSDIR}/palm/pilot-link
USE_KDELIBS_VER=2
@@ -24,9 +26,11 @@ USE_BISON= yes
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-objprelink \
- --with-extra-includes=${LOCALBASE}/pilot/include \
+CONFIGURE_ARGS= --with-extra-includes=${LOCALBASE}/pilot/include \
--with-extra-libs=${LOCALBASE}/pilot/lib
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif
diff --git a/deskutils/kdepim44/Makefile b/deskutils/kdepim44/Makefile
index 226f3fbdb51a..df618f1d2dd2 100644
--- a/deskutils/kdepim44/Makefile
+++ b/deskutils/kdepim44/Makefile
@@ -15,8 +15,10 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14 \
- objprelink:${PORTSDIR}/devel/objprelink
+ automake14:${PORTSDIR}/devel/automake14
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
+.endif
LIB_DEPENDS= pisock.4:${PORTSDIR}/palm/pilot-link
USE_KDELIBS_VER=2
@@ -24,9 +26,11 @@ USE_BISON= yes
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-objprelink \
- --with-extra-includes=${LOCALBASE}/pilot/include \
+CONFIGURE_ARGS= --with-extra-includes=${LOCALBASE}/pilot/include \
--with-extra-libs=${LOCALBASE}/pilot/lib
+.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
+CONFIGURE_ARGS+=--enable-objprelink
+.endif
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
CONFIGURE_ARGS+=--enable-final
.endif