aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-10-02 03:18:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-10-02 03:18:55 +0000
commit70d2d90c7354ea7794817fe8e6a354f0ea1787fb (patch)
tree60375bbce00c26f44e5df62ea90eecb86de84d8f /deskutils
parent7ac4ebcbc2be99480a358d2d17a42753daeb2cbb (diff)
downloadports-70d2d90c7354ea7794817fe8e6a354f0ea1787fb.tar.gz
ports-70d2d90c7354ea7794817fe8e6a354f0ea1787fb.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/gcalcli/Makefile33
-rw-r--r--deskutils/gcalcli/distinfo3
-rw-r--r--deskutils/gcalcli/pkg-descr6
4 files changed, 43 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 6999d471754a..ec73d504ee17 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -58,6 +58,7 @@
SUBDIR += gaddr
SUBDIR += ganttproject
SUBDIR += gcal
+ SUBDIR += gcalcli
SUBDIR += gdeskcal
SUBDIR += gdeskcal-skins
SUBDIR += gdesklets
diff --git a/deskutils/gcalcli/Makefile b/deskutils/gcalcli/Makefile
new file mode 100644
index 000000000000..bb908a327e94
--- /dev/null
+++ b/deskutils/gcalcli/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: gcalcli
+# Date created: Oct 2, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gcalcli
+PORTVERSION= 1.2
+CATEGORIES= deskutils
+MASTER_SITES= http://gcalcli.googlecode.com/files/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Google Calendar Command Line Interface
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gdata/__init__.py:${PORTSDIR}/devel/py-gdata \
+ ${PYTHON_SITELIBDIR}/dateutil/__init__.py:${PORTSDIR}/devel/py-dateutil
+
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/gcalcli
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/bin/python,${SETENV} python," ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/deskutils/gcalcli/distinfo b/deskutils/gcalcli/distinfo
new file mode 100644
index 000000000000..b41fc3e3953d
--- /dev/null
+++ b/deskutils/gcalcli/distinfo
@@ -0,0 +1,3 @@
+MD5 (gcalcli-1.2.tgz) = f93c551dcd20814c27f7aaa4d7812780
+SHA256 (gcalcli-1.2.tgz) = e52cc20487c352de7df40afc19057b2aca24dcd79f908ed0cb707040f1ed4a86
+SIZE (gcalcli-1.2.tgz) = 5831
diff --git a/deskutils/gcalcli/pkg-descr b/deskutils/gcalcli/pkg-descr
new file mode 100644
index 000000000000..faf4547a3ce4
--- /dev/null
+++ b/deskutils/gcalcli/pkg-descr
@@ -0,0 +1,6 @@
+gcalcli is a Python application that allows you to access you Google Calendar
+from a command line. It's easy to get your agenda, search for events, and
+quickly add new events. Additionally gcalcli can be used as a reminder service
+to execute any application you want.
+
+WWW: http://code.google.com/p/gcalcli/