aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-06-03 16:20:47 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-06-03 16:20:47 +0000
commit86f6ecc83f64e36d42f934fee5cfcdaecbc69927 (patch)
treeea2032cf7a668a0dc55ad89d96d1f56c098e197b /deskutils
parenta76cd22bf118d097391c1901563b54ba4344f55e (diff)
downloadports-86f6ecc83f64e36d42f934fee5cfcdaecbc69927.tar.gz
ports-86f6ecc83f64e36d42f934fee5cfcdaecbc69927.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/plasma-applet-daisy/Makefile1
-rw-r--r--deskutils/plasma-applet-panelspacer/Makefile3
-rw-r--r--deskutils/plasma-applet-playwolf/Makefile6
-rw-r--r--deskutils/plasma-applet-serverstatuswidget/Makefile12
-rw-r--r--deskutils/plasma-applet-teacooker/Makefile5
-rw-r--r--deskutils/plasma-applet-yawp/Makefile4
6 files changed, 13 insertions, 18 deletions
diff --git a/deskutils/plasma-applet-daisy/Makefile b/deskutils/plasma-applet-daisy/Makefile
index 2c04c5313708..5037f99aba9a 100644
--- a/deskutils/plasma-applet-daisy/Makefile
+++ b/deskutils/plasma-applet-daisy/Makefile
@@ -17,5 +17,4 @@ USES= cmake gettext
USE_KDE4= automoc4 kdeprefix kdelibs workspace
USE_QT4= qmake_build moc_build rcc_build uic_build
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/deskutils/plasma-applet-panelspacer/Makefile b/deskutils/plasma-applet-panelspacer/Makefile
index c2888937d6e9..80a2731c2cc2 100644
--- a/deskutils/plasma-applet-panelspacer/Makefile
+++ b/deskutils/plasma-applet-panelspacer/Makefile
@@ -11,6 +11,8 @@ DISTNAME= ${PORTNAME}-plasmoid-${PORTVERSION}
MAINTAINER= jhale@FreeBSD.org
COMMENT= Panel spacer plasma applet for KDE4
+LICENSE= GPLv2
+
USES= cmake
USE_KDE4= automoc4 kdeprefix workspace
USE_QT4= gui dbus network opengl svg webkit xml \
@@ -21,5 +23,4 @@ WRKSRC= ${WRKDIR}/Panelspacer_from_svn_pour_kdelook-tmp
PLIST_FILES= lib/kde4/plasma_applet_panelspacer.so \
share/kde4/services/plasma-applet-panelspacer.desktop
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/deskutils/plasma-applet-playwolf/Makefile b/deskutils/plasma-applet-playwolf/Makefile
index fe5da9c4a488..5bd23ead8120 100644
--- a/deskutils/plasma-applet-playwolf/Makefile
+++ b/deskutils/plasma-applet-playwolf/Makefile
@@ -10,8 +10,9 @@ PKGNAMEPREFIX= plasma-applet-
MAINTAINER= jhale@FreeBSD.org
COMMENT= Amarok 2.x plasma applet for KDE4
-USE_BZIP2= yes
-USES= cmake
+LICENSE= GPLv2
+
+USES= cmake tar:bzip2
USE_KDE4= automoc4 kdeprefix kdelibs
USE_QT4= gui dbus network opengl phonon svg webkit xml xmlpatterns \
qmake_build moc_build rcc_build uic_build
@@ -29,7 +30,6 @@ ADD_NEWLINE_TO= flowlayout.cpp \
wolfbuttons.cpp \
wolflabel.h
-NO_STAGE= yes
post-patch:
.for i in ${ADD_NEWLINE_TO}
${ECHO_CMD} >> ${WRKSRC}/${i}
diff --git a/deskutils/plasma-applet-serverstatuswidget/Makefile b/deskutils/plasma-applet-serverstatuswidget/Makefile
index 67bfbc16cbb8..400bb4f3ce5d 100644
--- a/deskutils/plasma-applet-serverstatuswidget/Makefile
+++ b/deskutils/plasma-applet-serverstatuswidget/Makefile
@@ -9,21 +9,17 @@ PKGNAMEPREFIX= plasma-applet-
DISTNAME= 101336-${PORTNAME}-${PORTVERSION}
MAINTAINER= jhale@FreeBSD.org
-COMMENT= Server monitoring plasma applet for KDE4
+COMMENT= KDE4 server monitoring plasma applet
-USE_BZIP2= yes
-USES= cmake gettext
+LICENSE= GPLv2
+
+USES= cmake gettext tar:bzip2
USE_KDE4= automoc4 kdeprefix workspace
USE_QT4= qmake_build moc_build rcc_build uic_build
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-NO_STAGE= yes
post-patch:
-
${ECHO_CMD} >> ${WRKSRC}/src/serverstatus.h
.include <bsd.port.mk>
diff --git a/deskutils/plasma-applet-teacooker/Makefile b/deskutils/plasma-applet-teacooker/Makefile
index dfb397a8fb6a..25a8ddbadba8 100644
--- a/deskutils/plasma-applet-teacooker/Makefile
+++ b/deskutils/plasma-applet-teacooker/Makefile
@@ -9,7 +9,9 @@ PKGNAMEPREFIX= plasma-applet-
DISTNAME= 85564-TeaCooker
MAINTAINER= jhale@FreeBSD.org
-COMMENT= Tea cooker plasma applet for KDE4
+COMMENT= KDE4 tea cooker plasma applet
+
+LICENSE= GPLv3
USES= cmake
USE_KDE4= automoc4 kdeprefix kdelibs
@@ -18,5 +20,4 @@ USE_QT4= gui dbus network opengl svg webkit xml \
WRKSRC= ${WRKDIR}/TeaCooker
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/deskutils/plasma-applet-yawp/Makefile b/deskutils/plasma-applet-yawp/Makefile
index 395e6813516e..fad8dbf51102 100644
--- a/deskutils/plasma-applet-yawp/Makefile
+++ b/deskutils/plasma-applet-yawp/Makefile
@@ -12,10 +12,8 @@ COMMENT= KDE4 weather plasma applet
LICENSE= GPLv2
-USE_BZIP2= yes
-USES= cmake gettext
+USES= cmake gettext tar:bzip2
USE_KDE4= automoc4 kdeprefix workspace
USE_QT4= qmake_build moc_build rcc_build uic_build
-NO_STAGE= yes
.include <bsd.port.mk>