aboutsummaryrefslogtreecommitdiff
path: root/devel/9base
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-03-04 19:48:57 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-03-04 19:48:57 +0000
commitc28918bc35f6c602ffff4a72944c88859697e5cd (patch)
tree83f12ad2c2c8f2f3d51547c119863b79a5b071e4 /devel/9base
parent222105d2f879f97c6cc1e105e287760153ee989f (diff)
downloadports-c28918bc35f6c602ffff4a72944c88859697e5cd.tar.gz
ports-c28918bc35f6c602ffff4a72944c88859697e5cd.zip
Notes
Diffstat (limited to 'devel/9base')
-rw-r--r--devel/9base/Makefile36
-rw-r--r--devel/9base/distinfo3
-rw-r--r--devel/9base/pkg-descr8
-rw-r--r--devel/9base/pkg-message8
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/9base/Makefile b/devel/9base/Makefile
new file mode 100644
index 000000000000..0fc9121294ad
--- /dev/null
+++ b/devel/9base/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: 9base
+# Date created: 4 March 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= 9base
+DISTVERSION= b20060209
+CATEGORIES= devel
+MASTER_SITES= CSME
+#http://www.suckless.org/cgi-bin/hgwebdir.cgi/9base/
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Port of various original plan9 tools
+
+USE_BZIP2= yes
+CFLAGS+= -I. -c
+LDFLAGS+= -L.
+MANPREFIX= ${PREFIX}/9
+MAKE_ARGS= PREFIX="${PREFIX}/9" CC="${CC}" MANPREFIX="${MANPREFIX}/man" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+APPS= awk basename bc cat cleanname date dc echo grep ls mk rc read sed seq\
+ sleep sort tee test touch tr uniq yacc
+#MAN1= ${APPS:S|$|.1|}
+PLIST_FILES= ${APPS:S|^|9/bin/|} ${APPS:S|^|9/man/man1/|:S|$|.1|} 9/man/man7/regexp.7 9/etc/rcmain
+PLIST_DIRS= 9/bin 9/etc 9/man/man1 9/man/man7 9/man 9
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|PREFIX|"${PREFIX}/9"|' ${WRKSRC}/rc/plan9ish.c
+ @${REINPLACE_CMD} -e '/OBJTYPE!=/s|!=.*|=${ARCH:S,i386,386,:S,amd64,x86_64,:S,sparc64,sun4u,}|' ${WRKSRC}/lib9/Makefile
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/devel/9base/distinfo b/devel/9base/distinfo
new file mode 100644
index 000000000000..f875c8f45e41
--- /dev/null
+++ b/devel/9base/distinfo
@@ -0,0 +1,3 @@
+MD5 (9base-b20060209.tar.bz2) = 104599556fc8e2920b75d62058681047
+SHA256 (9base-b20060209.tar.bz2) = 23a939c76c2313d4eb8a1022f5adae99f0625569683da998a5bcdad436ca31ce
+SIZE (9base-b20060209.tar.bz2) = 245770
diff --git a/devel/9base/pkg-descr b/devel/9base/pkg-descr
new file mode 100644
index 000000000000..e38be9b6d2ef
--- /dev/null
+++ b/devel/9base/pkg-descr
@@ -0,0 +1,8 @@
+This is a port of various original plan9 tools to Unix based on
+plan9ports [1], mk-with-libs.tgz [2] and wmii [3].
+
+[1] http://www.swtch.com/plan9port/
+[2] http://swtch.com/plan9port/unix/
+[3] http://www.suckless.org/wiki/wmii
+
+WWW: http://www.suckless.org/wiki/wmii/download
diff --git a/devel/9base/pkg-message b/devel/9base/pkg-message
new file mode 100644
index 000000000000..fe788013769d
--- /dev/null
+++ b/devel/9base/pkg-message
@@ -0,0 +1,8 @@
+======================================================
+
+Some of 9base tools require fdescfs to be mounted.
+Place "fdescfs /dev/fd fdescfs rw 0 0" into your
+fstab(5) file and run "mount /dev/fd". See fdescfs(5)
+for more.
+
+======================================================