aboutsummaryrefslogtreecommitdiff
path: root/devel/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-05-08 14:25:19 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-05-08 14:25:19 +0000
commit03ad0df1b9d0404f3d7c5019655f39ebc56cd477 (patch)
treebae51b0b89e08bf873eb6a8f35f21c64a361cfc9 /devel/Makefile
parentcfc05be2e09de8ceb1b73a16d34f398b6012825f (diff)
- New port devel/py-rbtree
An RBTree is a fast, balanced efficient data structure with the following properties: get O(log n) set O(log n) delete O(log n) min O(log n) max O(log n) contains O(log n) Because the worst case timing is minimal across the range of standard dict and ordered data operations it makes sense to use this when you have volatile/dynamic sorted data. In common usage its nearly as fast as the Python dict impl but has a slightly more expensive usage of the compare function as the keys are ordered and not hashed. WWW: http://www.python.org/pypi/RBTree/
Notes
Notes: svn path=/head/; revision=161722
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e065ccb26c8a..0ff5b2fb1309 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1498,6 +1498,7 @@
SUBDIR += py-px
SUBDIR += py-pydasm
SUBDIR += py-pytz
+ SUBDIR += py-rbtree
SUBDIR += py-repl
SUBDIR += py-resourcepackage
SUBDIR += py-reverse