aboutsummaryrefslogtreecommitdiff
path: root/devel/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-06-05 03:48:42 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-06-05 03:48:42 +0000
commit258dab36c2f4dfa7f4468a9096e90c80732cc23a (patch)
treec4f7a5c2b6dbdce07120319bd96e6d11c0e73beb /devel/Makefile
parent3eb9ee55c5d1aeff2cb2939c8a64389d2516c1f9 (diff)
The Lemon program is an LALR(1) parser generator. It takes a context
free grammar and converts it into a subroutine that will parse a file using that grammar. Lemon is similar to the much more famous programs "YACC" and "BISON". But lemon is not compatible with either yacc or bison. There are several important differences: . Lemon using a different grammar syntax which is less prone to programming errors. . Lemon generates a parser that is faster than Yacc or Bison parsers (according to the author). . The parser generated by Lemon is both re-entrant and thread-safe. . Lemon includes the concept of a non-terminal destructor, which makes it much easier to write a parser that does not leak memory. WWW: http://www.hwaci.com/sw/lemon/
Notes
Notes: svn path=/head/; revision=43506
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 83014ca648b6..0e999beb2174 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -179,6 +179,7 @@
SUBDIR += kpp
SUBDIR += ktranslator
SUBDIR += lclint
+ SUBDIR += lemon
SUBDIR += libPropList
SUBDIR += libU77
SUBDIR += libcache