aboutsummaryrefslogtreecommitdiff
path: root/devel/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-30 18:14:55 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-30 18:14:55 +0000
commit9a7e733057bcd6b7409efb36e0dbc5b2cbf6146f (patch)
treef793cd4da0e2e4f057f316c190d6448651daf25a /devel/Makefile
parent8e7a2b625b6cbdb6fc04110cf03eaad465997f40 (diff)
Add port devel/p5-Class-Std:
Most programmers who use Perl's object-oriented features construct their objects by blessing a hash. But, in doing so, they undermine the robustness of the OO approach. Hash-based objects are unencapsulated: their entries are open for the world to access and modify. Objects without effective encapsulation are vulnerable. Instead of politely respecting their public interface, some clever client coder inevitably will realize that it's marginally faster to interact directly with the underlying implementation, pulling out attribute values directly from the hash of an object. WWW: http://search.cpan.org/dist/Class-Std/ Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=163991
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 188253f33e35..5f7a23c8ae45 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -807,6 +807,7 @@
SUBDIR += p5-Class-Singleton
SUBDIR += p5-Class-Spiffy
SUBDIR += p5-Class-StateMachine
+ SUBDIR += p5-Class-Std
SUBDIR += p5-Class-Tangram
SUBDIR += p5-Class-Throwable
SUBDIR += p5-Class-Tom