aboutsummaryrefslogtreecommitdiff
path: root/devel/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-11-28 10:35:30 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-11-28 10:35:30 +0000
commitf02f4db8d053d83df9aa123403c92d0281f5aa68 (patch)
tree47f93f3563416dcff4c619c32d16719d33aee77b /devel/Makefile
parent02c627a3caebdd963a2c8f49725527c9e4964e25 (diff)
Add two new ports: bbfreeze and bbfreeze-loader (helper script).
bbfreeze creates standalone executables from Python scripts. It's similar in purpose to the well known py2exe for Windows, py2app for OS X, PyInstaller and cx_Freeze (in fact ancient versions were based on cx_Freeze. And it uses the modulegraph package, which is also used by py2app). It has the following features: - ZIP/Egg file import tracking - Binary dependency tracking (e.g. shared libraries) - Multiple script freezing support - Python interpreter included (named 'py') - Automatic pathname rewriting (pathnames in tracebacks are relative) - New distutils command: bdist_bbfreeze WWW: https://pypi.python.org/pypi/bbfreeze/
Notes
Notes: svn path=/head/; revision=373541
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6427ee468e1d..09e975004248 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -117,6 +117,8 @@
SUBDIR += avro-cpp
SUBDIR += awscli
SUBDIR += bam
+ SUBDIR += bbfreeze
+ SUBDIR += bbfreeze-loader
SUBDIR += bcc
SUBDIR += bcpp
SUBDIR += beautifyphp