aboutsummaryrefslogtreecommitdiff
path: root/devel/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-01-18 06:20:07 +0000
committerWen Heping <wen@FreeBSD.org>2011-01-18 06:20:07 +0000
commit12ed8df0b3954af5d00f68219a1e360f9af1dff6 (patch)
tree01e7b503440ddaa5795623dce37702d4f3eba4e7 /devel/Makefile
parent720bb6ff50150947f325b88e1526f1efada02c09 (diff)
This module provides an object type which efficiently represents an array of
booleans. Bitarrays are sequence types and behave very much like usual lists. Eight bits are represented by one byte in contiguous block of memory. The user can select between two representations; little-endian and big-endian. Most of the functionality is implemented in C. Methods for accessing the machine representation are provided. This can be useful when bit level access to binary files is required, such as portable bitmap image files (.pbm). Also, when dealing with compressed data which uses variable bit length encoding, you may find this module useful. WWW: http://pypi.python.org/pypi/bitarray PR: ports/153914 Submitted by: Sofian Brabez <sbrabez@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=267938
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 75c23eb7b6ac..4b853efdc32c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2734,6 +2734,7 @@
SUBDIR += py-astng
SUBDIR += py-babel
SUBDIR += py-bison
+ SUBDIR += py-bitarray
SUBDIR += py-bitstring
SUBDIR += py-boto
SUBDIR += py-cclib