aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-Rcpp
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2013-05-06 06:06:11 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2013-05-06 06:06:11 +0000
commit787a40232e72f88712791f3346138c176bb4e128 (patch)
tree4a630f0b224e04d9fb1b89999e9552a79919526f /devel/R-cran-Rcpp
parentd9829e63a682c03afb25f203cd92ea34eeb0c670 (diff)
downloadports-787a40232e72f88712791f3346138c176bb4e128.tar.gz
ports-787a40232e72f88712791f3346138c176bb4e128.zip
Notes
Diffstat (limited to 'devel/R-cran-Rcpp')
-rw-r--r--devel/R-cran-Rcpp/Makefile18
-rw-r--r--devel/R-cran-Rcpp/distinfo2
-rw-r--r--devel/R-cran-Rcpp/pkg-descr15
3 files changed, 35 insertions, 0 deletions
diff --git a/devel/R-cran-Rcpp/Makefile b/devel/R-cran-Rcpp/Makefile
new file mode 100644
index 000000000000..db74124b6e96
--- /dev/null
+++ b/devel/R-cran-Rcpp/Makefile
@@ -0,0 +1,18 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Rcpp
+PORTVERSION= 0.10.3
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Seamless R and C++ Integration
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-Rcpp/distinfo b/devel/R-cran-Rcpp/distinfo
new file mode 100644
index 000000000000..c3241d53ac3f
--- /dev/null
+++ b/devel/R-cran-Rcpp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Rcpp_0.10.3.tar.gz) = 14aaca011810510a9ddff262a97e009240865ea7a12050f84b92d41c966535e0
+SIZE (Rcpp_0.10.3.tar.gz) = 2395986
diff --git a/devel/R-cran-Rcpp/pkg-descr b/devel/R-cran-Rcpp/pkg-descr
new file mode 100644
index 000000000000..02b15d6a7dc3
--- /dev/null
+++ b/devel/R-cran-Rcpp/pkg-descr
@@ -0,0 +1,15 @@
+The Rcpp package provides C++ classes that greatly facilitate
+interfacing C or C++ code in R packages using the .Call() interface
+provided by R.
+
+Rcpp provides matching C++ classes for a large number of basic R
+data types. Hence, a package author can keep his data in normal R
+data structures without having to worry about translation or
+transfering to C++. At the same time, the data structures can be
+accessed as easily at the C++ level, and used in the normal manner.
+
+The mapping of data types works in both directions. It is as
+straightforward to pass data from R to C++, as it is it return data
+from C++ to R.
+
+WWW: http://cran.r-project.org/web/packages/Rcpp/