aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-foreach
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-09-04 06:17:22 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-09-04 06:17:22 +0000
commite086c16d174def8abedb890da8bdfa0ac9bdb60e (patch)
treec3ab5b186a2b418c9fb806f865a15f1a91a0c1b5 /devel/R-cran-foreach
parent1ea6d1b0c41095c87b84e6e78444d89cd41cccaf (diff)
downloadports-e086c16d174def8abedb890da8bdfa0ac9bdb60e.tar.gz
ports-e086c16d174def8abedb890da8bdfa0ac9bdb60e.zip
Notes
Diffstat (limited to 'devel/R-cran-foreach')
-rw-r--r--devel/R-cran-foreach/Makefile24
-rw-r--r--devel/R-cran-foreach/distinfo2
-rw-r--r--devel/R-cran-foreach/pkg-descr9
3 files changed, 35 insertions, 0 deletions
diff --git a/devel/R-cran-foreach/Makefile b/devel/R-cran-foreach/Makefile
new file mode 100644
index 000000000000..1c360329cadc
--- /dev/null
+++ b/devel/R-cran-foreach/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: R-cran-foreach
+# Date created: 2011-09-04
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= foreach
+PORTVERSION= 1.3.2
+CATEGORIES= devel
+PKGNAMEPREFIX= R-cran-
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Foreach looping construct for R
+
+LICENSE= ASL
+
+RUN_DEPENDS= R-cran-iterators>=1.0.0:${PORTSDIR}/devel/R-cran-iterators
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-foreach/distinfo b/devel/R-cran-foreach/distinfo
new file mode 100644
index 000000000000..d7a108bb5b82
--- /dev/null
+++ b/devel/R-cran-foreach/distinfo
@@ -0,0 +1,2 @@
+SHA256 (foreach_1.3.2.tar.gz) = 337e497b1550df1ef2595c9284f86fc03a6a8c992947fe53be917456f32439b1
+SIZE (foreach_1.3.2.tar.gz) = 340437
diff --git a/devel/R-cran-foreach/pkg-descr b/devel/R-cran-foreach/pkg-descr
new file mode 100644
index 000000000000..82a9c664418b
--- /dev/null
+++ b/devel/R-cran-foreach/pkg-descr
@@ -0,0 +1,9 @@
+Support for the foreach looping construct. Foreach is an idiom that
+allows for iterating over elements in a collection, without the use
+of an explicit loop counter. This package in particular is intended
+to be used for its return value, rather than for its side effects.
+In that sense, it is similar to the standard lapply function, but
+doesn't require the evaluation of a function. Using foreach without
+side effects also facilitates executing the loop in parallel.
+
+WWW: http://cran.r-project.org/web/packages/foreach/