aboutsummaryrefslogtreecommitdiff
path: root/devel/SWIG
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-06-11 09:51:15 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-06-11 09:51:15 +0000
commitd31cf3da2bee1cc48caf719997412b2ad8873e23 (patch)
treea54bfb300653035965cc8387db813bcb114c838e /devel/SWIG
parent278f54e00aff610ac3bbea595ee7830f572a3fba (diff)
downloadports-d31cf3da2bee1cc48caf719997412b2ad8873e23.tar.gz
ports-d31cf3da2bee1cc48caf719997412b2ad8873e23.zip
Notes
Diffstat (limited to 'devel/SWIG')
-rw-r--r--devel/SWIG/Makefile3
-rw-r--r--devel/SWIG/files/patch-ah8
2 files changed, 6 insertions, 5 deletions
diff --git a/devel/SWIG/Makefile b/devel/SWIG/Makefile
index e211c85645de..6882b7411f0c 100644
--- a/devel/SWIG/Makefile
+++ b/devel/SWIG/Makefile
@@ -24,9 +24,10 @@ VER= 1.1
USE_PERL5= yes
USE_PYTHON= yes
+PYTHON_NO_DEPENDS= yes
INSTALLS_SHLIB= yes
-WRKSRC= ${WRKDIR}/SWIG${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME:U}${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
CONFIGURE_ARGS= --with-tclincl=${LOCALBASE}/include/tcl8.3/ \
diff --git a/devel/SWIG/files/patch-ah b/devel/SWIG/files/patch-ah
index 139e4541fb7b..d460a34586f9 100644
--- a/devel/SWIG/files/patch-ah
+++ b/devel/SWIG/files/patch-ah
@@ -3,12 +3,12 @@
@@ -2445,3 +2445,3 @@
-dirs="$PYINCLUDE $PYINCLUDE/python1.5 $PYINCLUDE/python1.4 $PYINCLUDE/Py $prefix/include/python1.5 $prefix/include/python1.4 /usr/local/include/python1.5 /usr/include/python1.5 /usr/local/include/python1.4 /usr/include/python1.4 $prefix/include/Py /usr/local/include/Py /usr/include/Py"
-+dirs="$PYINCLUDE $PYINCLUDE/python2.0 $PYINCLUDE/python1.5 $PYINCLUDE/Py $prefix/include/python2.0 $prefix/include/python1.5 /usr/local/include/python2.0 /usr/include/python2.0 /usr/local/include/python1.5 /usr/include/python1.5 $prefix/include/Py /usr/local/include/Py /usr/include/Py"
++dirs="$PYINCLUDE $PYINCLUDE/python2.1 $PYINCLUDE/python1.5 $PYINCLUDE/Py $prefix/include/python2.1 $prefix/include/python1.5 /usr/local/include/python2.1 /usr/include/python2.1 /usr/local/include/python1.5 /usr/include/python1.5 $prefix/include/Py /usr/local/include/Py /usr/include/Py"
for i in $dirs ; do
@@ -2460,3 +2460,3 @@
echo "configure:2461: checking for Python library" >&5
-dirs="$PYLIB $PYLIB/config $PYLIB/lib $PYLIB/python1.5/config $PYLIB/python1.4/config $PYLIB/python/lib $prefix/lib/python1.5/config $prefix/lib/python1.4/config /usr/local/lib/python1.5/config /usr/lib/python1.5 /usr/local/lib/python1.4/config /usr/lib/python1.4 $prefix/lib/python/lib /usr/local/lib/python/lib /usr/lib/python/lib /home/sci/local/lib/python"
-+dirs="$PYLIB $PYLIB/config $PYLIB/lib $PYLIB/python2.0/config $PYLIB/python1.5/config $PYLIB/python/lib $prefix/lib/python2.0/config $prefix/lib/python1.5/config /usr/local/lib/python2.0/config /usr/lib/python2.0 /usr/local/lib/python1.5/config /usr/lib/python1.5 $prefix/lib/python/lib /usr/local/lib/python/lib /usr/lib/python/lib /home/sci/local/lib/python"
++dirs="$PYLIB $PYLIB/config $PYLIB/lib $PYLIB/python2.1/config $PYLIB/python1.5/config $PYLIB/python/lib $prefix/lib/python2.1/config $prefix/lib/python1.5/config /usr/local/lib/python2.1/config /usr/lib/python2.1 /usr/local/lib/python1.5/config /usr/lib/python1.5 $prefix/lib/python/lib /usr/local/lib/python/lib /usr/lib/python/lib /home/sci/local/lib/python"
@@ -2467,6 +2467,6 @@
PYINCLUDE="$PYINCLUDE -I$i"
@@ -17,9 +17,9 @@
break
fi
- if test -r $i/libPython.a; then
-+ if test -r $i/libpython2.0.a; then
++ if test -r $i/libpython2.1.a; then
echo "$ac_t""$i" 1>&6
@@ -2474,2 +2474,3 @@
PYINCLUDE="$PYINCLUDE -I$i"
-+ PYLINK="-lpython2.0"
++ PYLINK="-lpython2.1"
break