aboutsummaryrefslogtreecommitdiff
path: root/devel/SWIG
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-04-02 19:04:13 +0000
committerAde Lovett <ade@FreeBSD.org>2001-04-02 19:04:13 +0000
commit7bd499c7372920d237d04bcd4c0a6a35bb8ae4da (patch)
treebe55a5fb33cbddd6f82bf8dece25dabe6accfe58 /devel/SWIG
parent3d5e86b63a1b501399174c662439a3301a2f575d (diff)
downloadports-7bd499c7372920d237d04bcd4c0a6a35bb8ae4da.tar.gz
ports-7bd499c7372920d237d04bcd4c0a6a35bb8ae4da.zip
Notes
Diffstat (limited to 'devel/SWIG')
-rw-r--r--devel/SWIG/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/SWIG/Makefile b/devel/SWIG/Makefile
index 67a5b8857609..430f333df7d6 100644
--- a/devel/SWIG/Makefile
+++ b/devel/SWIG/Makefile
@@ -7,8 +7,8 @@
PORTNAME= swig
PORTVERSION= ${VER}p5
-PORTREVISION= 4
-CATEGORIES= devel perl5 python tcl82
+PORTREVISION= 5
+CATEGORIES= devel perl5 python tcl83
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/${VER}/ \
ftp://ftp.mcc.ac.uk/pub/mvc/swig/
@@ -18,20 +18,20 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= ${PYTHON_CMD}:${PYTHON_PORTSDIR} \
- ${LOCALBASE}/bin/tclsh8.2:${PORTSDIR}/lang/tcl82
+ ${LOCALBASE}/bin/tclsh8.3:${PORTSDIR}/lang/tcl83
VER= 1.1
USE_PERL5= yes
-PYTHON_VERSION?= python1.5
+PYTHON_VERSION?= python2.0
PYTHON_NO_DEPENDS?= yes
INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/SWIG${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
-CONFIGURE_ARGS= --with-tclincl=${PREFIX}/include/tcl8.2/ \
- --with-tcllib=${PREFIX}/lib/tcl8.2/
+CONFIGURE_ARGS= --with-tclincl=${LOCALBASE}/include/tcl8.3/ \
+ --with-tcllib=${LOCALBASE}/lib/tcl8.3/
ALL_TARGET= all runtime
MAN1= swig.1