aboutsummaryrefslogtreecommitdiff
path: root/devel/aap
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-02 16:53:33 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-02 16:53:33 +0000
commit688bff28616b76aa1a8b340d6f3b59e7568a5eb9 (patch)
tree9c4b31c3a5e4fd7dcf46653249fd9cb3235eaedd /devel/aap
parentaabb31e67a79a7c77ef0b5e43bca4505f1606976 (diff)
downloadports-688bff28616b76aa1a8b340d6f3b59e7568a5eb9.tar.gz
ports-688bff28616b76aa1a8b340d6f3b59e7568a5eb9.zip
Notes
Diffstat (limited to 'devel/aap')
-rw-r--r--devel/aap/Makefile36
-rw-r--r--devel/aap/files/pkg-install.in15
-rw-r--r--devel/aap/pkg-plist136
3 files changed, 106 insertions, 81 deletions
diff --git a/devel/aap/Makefile b/devel/aap/Makefile
index 14188152db9b..f2ac3a7fdcdd 100644
--- a/devel/aap/Makefile
+++ b/devel/aap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aap
PORTVERSION= 0.900
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= a-a-p
@@ -16,41 +17,38 @@ COMMENT= A build tool alternative to make with internet access and CVS support
MAN1= aap.1
+NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_ZIP= yes
USE_PYTHON= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-# This port does not need to build anything here
-do-build:
- @${TRUE}
-
# The files are installed in lib/aap/Exec-${PORTVERSION} and below. Create
# a symbolic link for bin/aap so that it's found in $PATH and still knows
# where to find the Python modules.
# Also create a link for share/doc/aap, so that more people can find the docs
# without clobbering share/doc.
-AAPEXECDIR= lib/aap/Exec-${PORTVERSION}
-INSTALLDIR= ${PREFIX}/${AAPEXECDIR}
+INSTALLDIR= ${PREFIX}/lib/aap/Exec-${PORTVERSION}
do-install:
cd ${WRKSRC} && \
- ${MKDIR} -m 755 ${INSTALLDIR}/doc ${INSTALLDIR}/tools && \
+ ${MKDIR} -m 755 ${INSTALLDIR}/tools && \
${INSTALL_SCRIPT} *.py aap ${INSTALLDIR} && \
- ${INSTALL_SCRIPT} tools/*.py ${INSTALLDIR}/tools && \
- ${INSTALL_DATA} -m 644 COPYING README.txt filetype.txt default.aap ${INSTALLDIR} && \
- ${INSTALL_DATA} doc/*.html doc/exec.pdf ${INSTALLDIR}/doc && \
- ${INSTALL_DATA} aap.1 ${PREFIX}/man/man1 && \
${LN} -fhs ${INSTALLDIR}/aap ${PREFIX}/bin/aap && \
+ ${INSTALL_SCRIPT} tools/*.py ${INSTALLDIR}/tools && \
+ ${INSTALL_DATA} -m 644 COPYING README.txt default.aap ${INSTALLDIR} && \
+ ${INSTALL_DATA} aap.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && \
+ ${MKDIR} -m 755 ${INSTALLDIR}/doc ${INSTALLDIR}/doc/html && \
+ ${INSTALL_DATA} filetype.txt doc/exec.pdf ${INSTALLDIR}/doc && \
+ ${INSTALL_DATA} doc/*.html ${INSTALLDIR}/doc/html && \
${LN} -fhs ${INSTALLDIR}/doc ${PREFIX}/share/doc/aap
+.endif
+ cd ${INSTALLDIR} && \
+ ${PYTHON_CMD} -c "import compileall; compileall.compile_dir('.', 1)"
-post-install:
- @${SED} -e 's,@PYTHON_CMD@,${PYTHON_CMD},g ; \
- s,@AAPEXECDIR@,${AAPEXECDIR},g' \
- < ${FILESDIR}/pkg-install.in > ${WRKSRC}/pkg-install
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${WRKSRC}/pkg-install ${PKGNAME} POST-INSTALL
-
-test:
- cd ${WRKSRC}; ./aap
+test: install
+ cd ${WRKSRC}; ${PREFIX}/bin/aap
.include <bsd.port.mk>
diff --git a/devel/aap/files/pkg-install.in b/devel/aap/files/pkg-install.in
deleted file mode 100644
index 54b292f48963..000000000000
--- a/devel/aap/files/pkg-install.in
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-
-if [ "$2" != "POST-INSTALL" ]; then
- exit 0
-fi
-
-PYTHON_CMD=@PYTHON_CMD@
-INSTALLDIR=${PKG_PREFIX}/@AAPEXECDIR@
-
-echo 'Compiling files...'
-(cd ${INSTALLDIR} && \
- ${PYTHON_CMD} -c "import compileall; compileall.compile_dir('.', 1)" && \
- ${PYTHON_CMD} -O -c "import compileall; compileall.compile_dir('.', 1)" \
- ) || exit 1
diff --git a/devel/aap/pkg-plist b/devel/aap/pkg-plist
index 4c848221b5f2..4b9e48905957 100644
--- a/devel/aap/pkg-plist
+++ b/devel/aap/pkg-plist
@@ -1,98 +1,140 @@
bin/aap
lib/aap/Exec-%%PORTVERSION%%/Action.py
+lib/aap/Exec-%%PORTVERSION%%/Action.pyc
lib/aap/Exec-%%PORTVERSION%%/Args.py
+lib/aap/Exec-%%PORTVERSION%%/Args.pyc
lib/aap/Exec-%%PORTVERSION%%/COPYING
lib/aap/Exec-%%PORTVERSION%%/Cache.py
+lib/aap/Exec-%%PORTVERSION%%/Cache.pyc
lib/aap/Exec-%%PORTVERSION%%/Commands.py
+lib/aap/Exec-%%PORTVERSION%%/Commands.pyc
lib/aap/Exec-%%PORTVERSION%%/CopyMove.py
+lib/aap/Exec-%%PORTVERSION%%/CopyMove.pyc
lib/aap/Exec-%%PORTVERSION%%/Depend.py
+lib/aap/Exec-%%PORTVERSION%%/Depend.pyc
lib/aap/Exec-%%PORTVERSION%%/Dictlist.py
+lib/aap/Exec-%%PORTVERSION%%/Dictlist.pyc
lib/aap/Exec-%%PORTVERSION%%/DoAddDef.py
+lib/aap/Exec-%%PORTVERSION%%/DoAddDef.pyc
lib/aap/Exec-%%PORTVERSION%%/DoArgs.py
+lib/aap/Exec-%%PORTVERSION%%/DoArgs.pyc
lib/aap/Exec-%%PORTVERSION%%/DoBuild.py
+lib/aap/Exec-%%PORTVERSION%%/DoBuild.pyc
lib/aap/Exec-%%PORTVERSION%%/DoInstall.py
+lib/aap/Exec-%%PORTVERSION%%/DoInstall.pyc
lib/aap/Exec-%%PORTVERSION%%/DoRead.py
+lib/aap/Exec-%%PORTVERSION%%/DoRead.pyc
lib/aap/Exec-%%PORTVERSION%%/Error.py
+lib/aap/Exec-%%PORTVERSION%%/Error.pyc
lib/aap/Exec-%%PORTVERSION%%/Filetype.py
+lib/aap/Exec-%%PORTVERSION%%/Filetype.pyc
lib/aap/Exec-%%PORTVERSION%%/Global.py
+lib/aap/Exec-%%PORTVERSION%%/Global.pyc
lib/aap/Exec-%%PORTVERSION%%/Main.py
+lib/aap/Exec-%%PORTVERSION%%/Main.pyc
lib/aap/Exec-%%PORTVERSION%%/Message.py
+lib/aap/Exec-%%PORTVERSION%%/Message.pyc
lib/aap/Exec-%%PORTVERSION%%/Node.py
+lib/aap/Exec-%%PORTVERSION%%/Node.pyc
lib/aap/Exec-%%PORTVERSION%%/ParsePos.py
+lib/aap/Exec-%%PORTVERSION%%/ParsePos.pyc
lib/aap/Exec-%%PORTVERSION%%/PkgInstall.py
+lib/aap/Exec-%%PORTVERSION%%/PkgInstall.pyc
lib/aap/Exec-%%PORTVERSION%%/Port.py
+lib/aap/Exec-%%PORTVERSION%%/Port.pyc
lib/aap/Exec-%%PORTVERSION%%/PrintProfile.py
+lib/aap/Exec-%%PORTVERSION%%/PrintProfile.pyc
lib/aap/Exec-%%PORTVERSION%%/Process.py
+lib/aap/Exec-%%PORTVERSION%%/Process.pyc
lib/aap/Exec-%%PORTVERSION%%/README.txt
lib/aap/Exec-%%PORTVERSION%%/RecPos.py
+lib/aap/Exec-%%PORTVERSION%%/RecPos.pyc
lib/aap/Exec-%%PORTVERSION%%/RecPython.py
+lib/aap/Exec-%%PORTVERSION%%/RecPython.pyc
lib/aap/Exec-%%PORTVERSION%%/Remote.py
+lib/aap/Exec-%%PORTVERSION%%/Remote.pyc
lib/aap/Exec-%%PORTVERSION%%/RootShell.py
+lib/aap/Exec-%%PORTVERSION%%/RootShell.pyc
lib/aap/Exec-%%PORTVERSION%%/Rule.py
+lib/aap/Exec-%%PORTVERSION%%/Rule.pyc
lib/aap/Exec-%%PORTVERSION%%/Scope.py
+lib/aap/Exec-%%PORTVERSION%%/Scope.pyc
lib/aap/Exec-%%PORTVERSION%%/Sign.py
+lib/aap/Exec-%%PORTVERSION%%/Sign.pyc
lib/aap/Exec-%%PORTVERSION%%/Util.py
+lib/aap/Exec-%%PORTVERSION%%/Util.pyc
lib/aap/Exec-%%PORTVERSION%%/VersCont.py
+lib/aap/Exec-%%PORTVERSION%%/VersCont.pyc
lib/aap/Exec-%%PORTVERSION%%/VersContCvs.py
+lib/aap/Exec-%%PORTVERSION%%/VersContCvs.pyc
lib/aap/Exec-%%PORTVERSION%%/Version.py
+lib/aap/Exec-%%PORTVERSION%%/Version.pyc
lib/aap/Exec-%%PORTVERSION%%/Work.py
+lib/aap/Exec-%%PORTVERSION%%/Work.pyc
lib/aap/Exec-%%PORTVERSION%%/__init__.py
+lib/aap/Exec-%%PORTVERSION%%/__init__.pyc
lib/aap/Exec-%%PORTVERSION%%/aap
lib/aap/Exec-%%PORTVERSION%%/aap.py
+lib/aap/Exec-%%PORTVERSION%%/aap.pyc
lib/aap/Exec-%%PORTVERSION%%/aapnetrc.py
+lib/aap/Exec-%%PORTVERSION%%/aapnetrc.pyc
lib/aap/Exec-%%PORTVERSION%%/default.aap
-lib/aap/Exec-%%PORTVERSION%%/doc/exec.html
-lib/aap/Exec-%%PORTVERSION%%/doc/exec.pdf
-lib/aap/Exec-%%PORTVERSION%%/doc/index.html
-lib/aap/Exec-%%PORTVERSION%%/doc/license.html
-lib/aap/Exec-%%PORTVERSION%%/doc/ln12.html
-lib/aap/Exec-%%PORTVERSION%%/doc/p1714.html
-lib/aap/Exec-%%PORTVERSION%%/doc/p2794.html
-lib/aap/Exec-%%PORTVERSION%%/doc/p30.html
-lib/aap/Exec-%%PORTVERSION%%/doc/p794.html
-lib/aap/Exec-%%PORTVERSION%%/doc/ref-arguments.html
-lib/aap/Exec-%%PORTVERSION%%/doc/ref-attributes.html
-lib/aap/Exec-%%PORTVERSION%%/doc/ref-commands.html
-lib/aap/Exec-%%PORTVERSION%%/doc/ref-syntax.html
-lib/aap/Exec-%%PORTVERSION%%/doc/ref-variables.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-actions.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-compile.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-cvs.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-distribute.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-include.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-pipe.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-port.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-python.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-start.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-variant.html
-lib/aap/Exec-%%PORTVERSION%%/doc/tutor-website.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-autodep.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-basics.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-cvs.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-debug.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-depend.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-fetch.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-filetype.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-install.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-issue.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-makedif.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-package.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-porting.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-publish.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-python.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-tools.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-variant.html
-lib/aap/Exec-%%PORTVERSION%%/doc/user-version.html
-lib/aap/Exec-%%PORTVERSION%%/filetype.txt
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/exec.pdf
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/filetype.txt
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/exec.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/index.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/license.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/ln12.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/p1714.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/p2794.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/p30.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/p794.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/ref-arguments.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/ref-attributes.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/ref-commands.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/ref-syntax.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/ref-variables.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-actions.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-compile.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-cvs.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-distribute.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-include.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-pipe.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-port.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-python.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-start.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-variant.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/tutor-website.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-autodep.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-basics.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-cvs.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-debug.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-depend.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-fetch.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-filetype.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-install.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-issue.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-makedif.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-package.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-porting.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-publish.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-python.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-tools.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-variant.html
+%%PORTDOCS%%lib/aap/Exec-%%PORTVERSION%%/doc/html/user-version.html
lib/aap/Exec-%%PORTVERSION%%/tools/__init__.py
+lib/aap/Exec-%%PORTVERSION%%/tools/__init__.pyc
lib/aap/Exec-%%PORTVERSION%%/tools/gcc.py
+lib/aap/Exec-%%PORTVERSION%%/tools/gcc.pyc
lib/aap/Exec-%%PORTVERSION%%/tools/icc.py
+lib/aap/Exec-%%PORTVERSION%%/tools/icc.pyc
lib/aap/Exec-%%PORTVERSION%%/tools/mingw.py
+lib/aap/Exec-%%PORTVERSION%%/tools/mingw.pyc
lib/aap/Exec-%%PORTVERSION%%/tools/msvc.py
-share/doc/aap
-@unexec rm -f %D/lib/aap/Exec-%%PORTVERSION%%/tools/*.py[co]
-@unexec rm -f %D/lib/aap/Exec-%%PORTVERSION%%/*.py[co]
-@dirrm lib/aap/Exec-%%PORTVERSION%%/doc
+lib/aap/Exec-%%PORTVERSION%%/tools/msvc.pyc
+%%PORTDOCS%%share/doc/aap
@dirrm lib/aap/Exec-%%PORTVERSION%%/tools
+%%PORTDOCS%%@dirrm lib/aap/Exec-%%PORTVERSION%%/doc/html
+%%PORTDOCS%%@dirrm lib/aap/Exec-%%PORTVERSION%%/doc
@dirrm lib/aap/Exec-%%PORTVERSION%%
@dirrm lib/aap