aboutsummaryrefslogtreecommitdiff
path: root/devel/abi-compliance-checker
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-09-17 13:07:41 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-09-17 13:07:41 +0000
commit6dcdf0fd4c08f41aa54431f311faab6975649a3b (patch)
tree0cda0ac4b089e3ff3cf6a142d2e80242f5ce157f /devel/abi-compliance-checker
parent844cb1d5b2ac09ea312abb1eb79b300b1d2d28b1 (diff)
downloadports-6dcdf0fd4c08f41aa54431f311faab6975649a3b.tar.gz
ports-6dcdf0fd4c08f41aa54431f311faab6975649a3b.zip
Notes
Diffstat (limited to 'devel/abi-compliance-checker')
-rw-r--r--devel/abi-compliance-checker/Makefile29
-rw-r--r--devel/abi-compliance-checker/distinfo4
2 files changed, 21 insertions, 12 deletions
diff --git a/devel/abi-compliance-checker/Makefile b/devel/abi-compliance-checker/Makefile
index 4c88c1182888..8d6a16c889a6 100644
--- a/devel/abi-compliance-checker/Makefile
+++ b/devel/abi-compliance-checker/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= abi-compliance-checker
-PORTVERSION= 1.93.7
+PORTVERSION= 1.94
CATEGORIES= devel perl5
MASTER_SITES= http://linuxtesting.org/downloads/ \
LOCAL/bf
@@ -37,6 +37,12 @@ PICFLAG?= -fPIC
PICFLAG?= -fpic
.endif
+.for w in DATA DOCS
+.ifndef(NOPORT${w})
+PORT${w}= *
+.endif
+.endfor
+
post-patch:
@${REINPLACE_CMD} \
-e "\|get_CmdPath(\"ar\")|s|\"ar\"|\"${AR}\"|" \
@@ -44,11 +50,22 @@ post-patch:
-e "\|get_CmdPath(\"gcc\")|s|\"gcc\"|\"${CC}\"|" \
-e "\|get_CmdPath(\"objdump\")|s|\"objdump\"|\"${OBJDUMP}\"|" \
-e "\|get_CmdPath(\"readelf\")|s|\"readelf\"|\"${READELF}\"|" \
- -e "s| -shared|& ${PICFLAG}|g" \
+ -e "s|ACC_MODULES_INSTALL_PATH|${DATADIR}|" \
${WRKSRC}/${PORTNAME}.pl
+ @${SED} -i "" -e "\|BuildCmd|s|GCC_PATH.\"|& ${PICFLAG}|" \
+ ${WRKSRC}/modules/Internals/RegTests.pm
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+.ifndef(NOPORTDATA)
+ @${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} \
+ "modules/Internals modules/*.xml modules/Targets/unix" ${DATADIR})
+.endif
.ifdef(MAINTAINER_MODE)
check regression-test test: build
@@ -56,12 +73,4 @@ check regression-test test: build
.endif
-.ifndef(NOPORTDOCS)
-PORTDOCS= *
-
-post-install:
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
-
-.endif
.include <bsd.port.post.mk>
diff --git a/devel/abi-compliance-checker/distinfo b/devel/abi-compliance-checker/distinfo
index 821e8f54a021..08c81f29c0b0 100644
--- a/devel/abi-compliance-checker/distinfo
+++ b/devel/abi-compliance-checker/distinfo
@@ -1,2 +1,2 @@
-SHA256 (abi-compliance-checker-1.93.7.tar.gz) = dfe53a7cc1a21b221d5072027a503abb6fcf2941fe7a080257614edfdea7334c
-SIZE (abi-compliance-checker-1.93.7.tar.gz) = 176187
+SHA256 (abi-compliance-checker-1.94.tar.gz) = 4a935534b6ceef1ab96594c83d8d63fe794d8b45f10fe8c080378e1541d1939a
+SIZE (abi-compliance-checker-1.94.tar.gz) = 179920