aboutsummaryrefslogtreecommitdiff
path: root/devel/ace
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2015-10-01 21:45:33 +0000
committerPawel Pekala <pawel@FreeBSD.org>2015-10-01 21:45:33 +0000
commit6d06bfe3202939fe1acc14f10e05c6ffaa8f9449 (patch)
tree2c6731c2756e72a9bdd891ec00335bac21ee2620 /devel/ace
parent24a9ca09c2b30e63bbfc08bf305d379d8a454b9d (diff)
downloadports-6d06bfe3202939fe1acc14f10e05c6ffaa8f9449.tar.gz
ports-6d06bfe3202939fe1acc14f10e05c6ffaa8f9449.zip
Notes
Diffstat (limited to 'devel/ace')
-rw-r--r--devel/ace/Makefile2
-rw-r--r--devel/ace/distinfo4
-rw-r--r--devel/ace/files/patch-ace-os_include-os_pthread.h6
-rw-r--r--devel/ace/files/patch-ace__OS_NS_Thread.h10
-rw-r--r--devel/ace/files/patch-ace__OS_NS_netdb.inl18
-rw-r--r--devel/ace/files/patch-ace__OS_NS_signal.h6
-rw-r--r--devel/ace/files/patch-ace__SSL__SSL_Context.cpp22
-rw-r--r--devel/ace/pkg-plist4
8 files changed, 29 insertions, 43 deletions
diff --git a/devel/ace/Makefile b/devel/ace/Makefile
index 6eeb8016a420..edf6dbc0c0be 100644
--- a/devel/ace/Makefile
+++ b/devel/ace/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ace
-PORTVERSION= 6.3.1
+PORTVERSION= 6.3.3
CATEGORIES= devel
MASTER_SITES= ftp://download.dre.vanderbilt.edu/previous_versions/ \
http://download.dre.vanderbilt.edu/previous_versions/
diff --git a/devel/ace/distinfo b/devel/ace/distinfo
index 86aecf3e33bb..4d2a833bb42f 100644
--- a/devel/ace/distinfo
+++ b/devel/ace/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ACE-6.3.1.tar.bz2) = 7a453ed93a5c1d0c07e2200c6c4ea47b99b218dc2fc5b543ed4c99f498824dad
-SIZE (ACE-6.3.1.tar.bz2) = 8719870
+SHA256 (ACE-6.3.3.tar.bz2) = f362e45f624db3343db529654b601d5df69b5f56fa4597cf453da35d80989888
+SIZE (ACE-6.3.3.tar.bz2) = 8753296
diff --git a/devel/ace/files/patch-ace-os_include-os_pthread.h b/devel/ace/files/patch-ace-os_include-os_pthread.h
index 108067151e46..b2051ef82b2d 100644
--- a/devel/ace/files/patch-ace-os_include-os_pthread.h
+++ b/devel/ace/files/patch-ace-os_include-os_pthread.h
@@ -1,6 +1,6 @@
---- ace/os_include/os_pthread.h.orig 2010-11-27 02:39:33.000000000 +0900
-+++ ace/os_include/os_pthread.h 2011-11-27 05:58:00.000000000 +0900
-@@ -283,7 +283,11 @@
+--- ace/os_include/os_pthread.h.orig 2015-09-17 06:55:18 UTC
++++ ace/os_include/os_pthread.h
+@@ -277,7 +277,11 @@
# undef THR_DAEMON
# define THR_BOUND 0x00000001
diff --git a/devel/ace/files/patch-ace__OS_NS_Thread.h b/devel/ace/files/patch-ace__OS_NS_Thread.h
index 3d7801505413..e8e888971a82 100644
--- a/devel/ace/files/patch-ace__OS_NS_Thread.h
+++ b/devel/ace/files/patch-ace__OS_NS_Thread.h
@@ -1,8 +1,8 @@
---- ace/OS_NS_Thread.h.orig 2011-04-07 20:48:50.000000000 +0900
-+++ ace/OS_NS_Thread.h 2011-11-27 05:38:21.000000000 +0900
-@@ -38,6 +38,12 @@
- # include "ace/ACE_export.h"
- # include "ace/Object_Manager_Base.h"
+--- ace/OS_NS_Thread.h.orig 2015-09-17 06:55:18 UTC
++++ ace/OS_NS_Thread.h
+@@ -42,6 +42,12 @@
+ # endif /* VxWorks and ! SMP */
+ #endif
+# include <sys/param.h>
+#if (defined(__FreeBSD__) && ((__FreeBSD_version >= 700110 && __FreeBSD_version < 800000) || __FreeBSD_version >= 800024))
diff --git a/devel/ace/files/patch-ace__OS_NS_netdb.inl b/devel/ace/files/patch-ace__OS_NS_netdb.inl
index c3fad947196a..4a689fbf0172 100644
--- a/devel/ace/files/patch-ace__OS_NS_netdb.inl
+++ b/devel/ace/files/patch-ace__OS_NS_netdb.inl
@@ -1,15 +1,15 @@
---- ace/OS_NS_netdb.inl.orig 2011-03-21 21:54:52.000000000 +0900
-+++ ace/OS_NS_netdb.inl 2011-11-27 07:46:06.000000000 +0900
-@@ -6,6 +6,8 @@
+--- ace/OS_NS_netdb.inl.orig 2015-09-17 06:55:18 UTC
++++ ace/OS_NS_netdb.inl
+@@ -3,6 +3,8 @@
#include "ace/OS_NS_string.h"
#include "ace/OS_NS_errno.h"
+#include <sys/param.h>
+
#if defined (ACE_LACKS_NETDB_REENTRANT_FUNCTIONS)
- # if defined (ACE_MT_SAFE) && (ACE_MT_SAFE != 0)
+ # if defined (ACE_MT_SAFE) && (ACE_MT_SAFE != 0) && !defined (HPUX_11)
# define ACE_NETDBCALL_RETURN(OP,TYPE,FAILVALUE,TARGET,SIZE) \
-@@ -119,7 +121,7 @@
+@@ -116,7 +118,7 @@ ACE_OS::gethostbyaddr_r (const char *add
*h_errnop = h_errno;
return (struct hostent *) 0;
}
@@ -18,7 +18,7 @@
// GNU C library has a different signature
ACE_OS::memset (buffer, 0, sizeof (ACE_HOSTENT_DATA));
-@@ -304,7 +306,7 @@
+@@ -301,7 +303,7 @@ ACE_OS::gethostbyname_r (const char *nam
*h_errnop = h_errno;
return (struct hostent *) 0;
}
@@ -27,7 +27,7 @@
// GNU C library has a different signature
ACE_OS::memset (buffer, 0, sizeof (ACE_HOSTENT_DATA));
-@@ -517,7 +519,7 @@
+@@ -514,7 +516,7 @@ ACE_OS::getprotobyname_r (const char *na
else
return 0;
//FUZZ: enable check_for_lack_ACE_OS
@@ -36,7 +36,7 @@
// GNU C library has a different signature
//FUZZ: disable check_for_lack_ACE_OS
if (::getprotobyname_r (name,
-@@ -598,7 +600,7 @@
+@@ -595,7 +597,7 @@ ACE_OS::getprotobynumber_r (int proto,
//FUZZ: enable check_for_lack_ACE_OS
else
return 0;
@@ -45,7 +45,7 @@
// GNU C library has a different signature
//FUZZ: disable check_for_lack_ACE_OS
if (::getprotobynumber_r (proto,
-@@ -684,7 +686,7 @@
+@@ -681,7 +683,7 @@ ACE_OS::getservbyname_r (const char *svc
//FUZZ: enable check_for_lack_ACE_OS
else
return (struct servent *) 0;
diff --git a/devel/ace/files/patch-ace__OS_NS_signal.h b/devel/ace/files/patch-ace__OS_NS_signal.h
index 8cb903bce94b..15976763deb7 100644
--- a/devel/ace/files/patch-ace__OS_NS_signal.h
+++ b/devel/ace/files/patch-ace__OS_NS_signal.h
@@ -1,6 +1,6 @@
---- ace/OS_NS_signal.h.orig 2011-03-04 23:59:09.000000000 +0900
-+++ ace/OS_NS_signal.h 2011-11-27 07:50:01.000000000 +0900
-@@ -33,10 +33,10 @@
+--- ace/OS_NS_signal.h.orig 2015-09-17 06:55:18 UTC
++++ ace/OS_NS_signal.h
+@@ -31,10 +31,10 @@
#endif
#define ACE_EXPORT_MACRO ACE_Export
diff --git a/devel/ace/files/patch-ace__SSL__SSL_Context.cpp b/devel/ace/files/patch-ace__SSL__SSL_Context.cpp
index b2524df5450b..51c339d91bb3 100644
--- a/devel/ace/files/patch-ace__SSL__SSL_Context.cpp
+++ b/devel/ace/files/patch-ace__SSL__SSL_Context.cpp
@@ -1,24 +1,6 @@
---- ace/SSL/SSL_Context.cpp.orig 2014-12-29 10:41:20 UTC
+--- ace/SSL/SSL_Context.cpp.orig 2015-09-17 06:55:18 UTC
+++ ace/SSL/SSL_Context.cpp
-@@ -274,7 +274,7 @@ ACE_SSL_Context::set_mode (int mode)
- case ACE_SSL_Context::TLSv1:
- method = ::TLSv1_method ();
- break;
--#ifdef TLS1_1_VERSION
-+#if defined(TLS1_1_VERSION) && (TLS_MAX_VERSION >= TLS1_1_VERSION)
- case ACE_SSL_Context::TLSv1_1_client:
- method = ::TLSv1_1_client_method ();
- break;
-@@ -285,7 +285,7 @@ ACE_SSL_Context::set_mode (int mode)
- method = ::TLSv1_1_method ();
- break;
- #endif
--#ifdef TLS1_2_VERSION
-+#if defined(TLS1_2_VERSION) && (TLS_MAX_VERSION >= TLS1_2_VERSION)
- case ACE_SSL_Context::TLSv1_2_client:
- method = ::TLSv1_2_client_method ();
- break;
-@@ -556,7 +556,7 @@ ACE_SSL_Context::random_seed (const char
+@@ -683,7 +683,7 @@ ACE_SSL_Context::random_seed (const char
int
ACE_SSL_Context::egd_file (const char * socket_file)
{
diff --git a/devel/ace/pkg-plist b/devel/ace/pkg-plist
index bbdde19ff116..8212ff6024a9 100644
--- a/devel/ace/pkg-plist
+++ b/devel/ace/pkg-plist
@@ -1098,6 +1098,7 @@ include/ace/config-kfreebsd.h
include/ace/config-linux.h
include/ace/config-lite.h
include/ace/config-lynxos.h
+include/ace/config-macosx-elcapitan.h
include/ace/config-macosx-iOS-hardware.h
include/ace/config-macosx-iOS-simulator.h
include/ace/config-macosx-leopard.h
@@ -1135,6 +1136,7 @@ include/ace/config-vxworks6.6.h
include/ace/config-vxworks6.7.h
include/ace/config-vxworks6.8.h
include/ace/config-vxworks6.9.h
+include/ace/config-vxworks7.0.h
include/ace/config-win32-borland.h
include/ace/config-win32-cegcc.h
include/ace/config-win32-common.h
@@ -1509,6 +1511,7 @@ libdata/pkgconfig/Kokyu.pc
%%DATADIR%%/include/makeinclude/platform_lynxos.GNU
%%DATADIR%%/include/makeinclude/platform_macosx.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_common.GNU
+%%DATADIR%%/include/makeinclude/platform_macosx_elcapitan.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_iOS.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_icc.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_leopard.GNU
@@ -1539,6 +1542,7 @@ libdata/pkgconfig/Kokyu.pc
%%DATADIR%%/include/makeinclude/platform_vxworks6.7.GNU
%%DATADIR%%/include/makeinclude/platform_vxworks6.8.GNU
%%DATADIR%%/include/makeinclude/platform_vxworks6.9.GNU
+%%DATADIR%%/include/makeinclude/platform_vxworks7.0.GNU
%%DATADIR%%/include/makeinclude/platform_win32_dmc.GNU
%%DATADIR%%/include/makeinclude/platform_win32_icc.GNU
%%DATADIR%%/include/makeinclude/platform_win32_interix.GNU