aboutsummaryrefslogtreecommitdiff
path: root/devel/acpicatools
diff options
context:
space:
mode:
authorMitsuru IWASAKI <iwasaki@FreeBSD.org>2003-06-12 15:45:04 +0000
committerMitsuru IWASAKI <iwasaki@FreeBSD.org>2003-06-12 15:45:04 +0000
commit4a31628a76ee22e545c8cdb22c6227557e607909 (patch)
tree04d0f4368c3b7d6eddfba6a70b3a33c4b1338f97 /devel/acpicatools
parentdcfd42987ea44dbea88178675510971cff31700e (diff)
downloadports-4a31628a76ee22e545c8cdb22c6227557e607909.tar.gz
ports-4a31628a76ee22e545c8cdb22c6227557e607909.zip
Notes
Diffstat (limited to 'devel/acpicatools')
-rw-r--r--devel/acpicatools/Makefile4
-rw-r--r--devel/acpicatools/distinfo4
-rw-r--r--devel/acpicatools/files/patch-compiler::aslutils.c4
-rw-r--r--devel/acpicatools/files/patch-include::platform::acfreebsd.h43
-rw-r--r--devel/acpicatools/files/patch-osunixxf.c6
5 files changed, 47 insertions, 14 deletions
diff --git a/devel/acpicatools/Makefile b/devel/acpicatools/Makefile
index 4a6369579d4f..2ed98a1bf58a 100644
--- a/devel/acpicatools/Makefile
+++ b/devel/acpicatools/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= acpicatools
-PORTVERSION= 20021118.0
+PORTVERSION= 20030523.0
CATEGORIES= devel
MASTER_SITES= http://people.FreeBSD.org/~iwasaki/acpi/ \
http://developer.intel.com/technology/iapc/acpi/downloads/ \
${MASTER_SITE_PORTS_JP}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- acpica-unix-20021118.tar.gz
+ acpica-unix-20030523.tar.gz
NO_WRKSUBDIR= yes
MAINTAINER= iwasaki@FreeBSD.org
diff --git a/devel/acpicatools/distinfo b/devel/acpicatools/distinfo
index afea8edac46c..8108fe466622 100644
--- a/devel/acpicatools/distinfo
+++ b/devel/acpicatools/distinfo
@@ -1,2 +1,2 @@
-MD5 (acpica-unix-20021118.tar.gz) = 72944a201290b31c34573f634c6ffccb
-MD5 (acpicatools-20021118.0.tar.gz) = 3f40704138b95a5b4be854deec53c361
+MD5 (acpica-unix-20030523.tar.gz) = dd54fb88c4ca1a8dac41cd33ac242930
+MD5 (acpicatools-20030523.0.tar.gz) = c57f3d0c473032da46ea1eb882e074a0
diff --git a/devel/acpicatools/files/patch-compiler::aslutils.c b/devel/acpicatools/files/patch-compiler::aslutils.c
index 18819d19b192..e2f0696256d9 100644
--- a/devel/acpicatools/files/patch-compiler::aslutils.c
+++ b/devel/acpicatools/files/patch-compiler::aslutils.c
@@ -1,5 +1,5 @@
---- compiler/aslutils.c.orig Fri Aug 16 09:25:16 2002
-+++ compiler/aslutils.c Thu Aug 22 17:41:16 2002
+--- acpica-unix-20030523/compiler/aslutils.c.orig Thu Jun 12 15:48:25 2003
++++ acpica-unix-20030523/compiler/aslutils.c Thu Jun 12 15:48:34 2003
@@ -126,7 +126,7 @@
#ifdef _USE_BERKELEY_YACC
diff --git a/devel/acpicatools/files/patch-include::platform::acfreebsd.h b/devel/acpicatools/files/patch-include::platform::acfreebsd.h
index 2270e2e2ba44..d932d1318b1d 100644
--- a/devel/acpicatools/files/patch-include::platform::acfreebsd.h
+++ b/devel/acpicatools/files/patch-include::platform::acfreebsd.h
@@ -1,16 +1,49 @@
---- include/platform/acfreebsd.h.orig Sat Jul 27 03:19:45 2002
-+++ include/platform/acfreebsd.h Fri Aug 9 20:53:32 2002
-@@ -126,7 +126,9 @@
+--- acpica-unix-20030523/include/platform/acfreebsd.h.orig Sat May 24 09:10:56 2003
++++ acpica-unix-20030523/include/platform/acfreebsd.h Fri Jun 13 00:17:53 2003
+@@ -126,7 +126,25 @@
/* FreeBSD uses GCC */
#include "acgcc.h"
+#if 0
#include <machine/acpica_machdep.h>
+#endif
++
++#ifdef _KERNEL
++#include "opt_acpi.h"
++#endif
++
++#ifdef ACPI_DEBUG
++#define ACPI_DEBUG_OUTPUT /* for backward compatibility */
++#endif
++
++#ifdef _KERNEL
++#include "opt_acpi.h"
++#endif
++
++#ifdef ACPI_DEBUG
++#define ACPI_DEBUG_OUTPUT /* for backward compatibility */
++#endif
#ifdef _KERNEL
#include <sys/ctype.h>
-@@ -157,6 +159,7 @@
+@@ -135,15 +153,11 @@
+ #include <sys/libkern.h>
+ #include <machine/stdarg.h>
+
+-#define asm __asm
+-#define __cli() disable_intr()
+-#define __sti() enable_intr()
+-
+-#ifdef ACPI_DEBUG_OUTPUT
+ #ifdef DEBUGGER_THREADING
+ #undef DEBUGGER_THREADING
+ #endif /* DEBUGGER_THREADING */
+ #define DEBUGGER_THREADING 0 /* integrated with DDB */
++#ifdef ACPI_DEBUG_OUTPUT
+ #include "opt_ddb.h"
+ #ifdef DDB
+ #define ACPI_DEBUGGER
+@@ -157,6 +171,7 @@
#define __cli()
#define __sti()
@@ -18,7 +51,7 @@
#endif /* _KERNEL */
-@@ -196,5 +199,16 @@
+@@ -196,5 +211,16 @@
return ((char *)s);
}
#endif /* _KERNEL */
diff --git a/devel/acpicatools/files/patch-osunixxf.c b/devel/acpicatools/files/patch-osunixxf.c
index eb77fc184132..5dae056fe40c 100644
--- a/devel/acpicatools/files/patch-osunixxf.c
+++ b/devel/acpicatools/files/patch-osunixxf.c
@@ -1,6 +1,6 @@
---- osunixxf.c.orig Mon May 20 23:27:31 2002
-+++ osunixxf.c Fri Jun 7 22:23:11 2002
-@@ -728,7 +728,7 @@
+--- acpica-unix-20030523/osunixxf.c.orig Sat May 24 09:11:02 2003
++++ acpica-unix-20030523/osunixxf.c Thu Jun 12 17:03:26 2003
+@@ -815,7 +815,7 @@
UINT32 milliseconds)
{