aboutsummaryrefslogtreecommitdiff
path: root/devel/adabindx/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 07:32:24 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 07:32:24 +0000
commit99af2876ad0e7e435b5d20d9649f50dfebd601f7 (patch)
tree264a974d70fce76e54442afade24da71f36af8eb /devel/adabindx/Makefile
parent0365ab67fdec4cb55d23c45c9f05c47327d8294f (diff)
Notes
Diffstat (limited to 'devel/adabindx/Makefile')
-rw-r--r--devel/adabindx/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/adabindx/Makefile b/devel/adabindx/Makefile
new file mode 100644
index 000000000000..b31823358489
--- /dev/null
+++ b/devel/adabindx/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: adabindx
+# Date created: 23 December 2002
+# Whom: David Holm <david@realityrift.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= adabindx
+PORTVERSION= 0.7.2
+CATEGORIES= devel
+MASTER_SITES= http://home.arcor.de/hfvogt/
+
+MAINTAINER= david@realityrift.com
+COMMENT= An Ada-binding to the X Window System and *tif
+
+BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat
+
+USE_MOTIF= yes
+PREFIX= ${X11BASE}
+
+post-patch:
+# @mv ${WRKSRC}/lib ${WRKSRC}/src
+
+#do-install:
+# @${MKDIR} ${X11BASE}/lib/adabindx
+# @(for i in `cat pkg-plist|grep "lib/adabindx"|grep -v dirrm|sed "s/lib\/adabindx\///"`; do \
+# ${INSTALL_DATA} ${WRKSRC}/lib/$${i} ${PREFIX}/lib/adabindx; \
+# done)
+#
+# @${MKDIR} ${X11BASE}/share/adabindx
+# @(for i in `cat pkg-plist|grep "share/adabindx"|grep -v dirrm|sed "s/share\/adabindx\///"`; do \
+# ${INSTALL_DATA} ${WRKSRC}/$${i} ${PREFIX}/share/adabindx; \
+# done)
+
+.include <bsd.port.mk>