aboutsummaryrefslogtreecommitdiff
path: root/devel/agenda-libs/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-06-30 11:50:36 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-06-30 11:50:36 +0000
commite1d07602a03d0c78dc2da757c04a3c80e3238111 (patch)
treea83737c7915eb513067466a8bd5e2ce2839dcae0 /devel/agenda-libs/Makefile
parent6206c2bedd4ab4f43729a963128552bbc6994569 (diff)
Notes
Diffstat (limited to 'devel/agenda-libs/Makefile')
-rw-r--r--devel/agenda-libs/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/agenda-libs/Makefile b/devel/agenda-libs/Makefile
new file mode 100644
index 000000000000..fabe8d0b408f
--- /dev/null
+++ b/devel/agenda-libs/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: agenda-libs
+# Date created: 14 June 2001
+# Whom: Lev Serebryakov <lev@serebryakov.spb.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= agenda-libs
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= http://lev.serebryakov.spb.ru/download/agenda/
+
+MAINTAINER= lev@serebryakov.spb.ru
+
+RUN_DEPENDS= ${LOCALBASE}/${TARGET_PLATFORM}/include/stdio.h:${PORTSDIR}/devel/agenda-headers
+
+TARGET_PLATFORM=mipsel-linux
+USE_BZIP2= yes
+NO_FILTER_SHLIBS= yes
+
+LIBC_SUB= PREFIX=${PREFIX} TARGET_PLATFORM=${TARGET_PLATFORM}
+
+do-build:
+ @${SED} ${LIBC_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} < ${WRKSRC}/lib/libc.so > ${WRKSRC}/lib/libc.so.new
+ @${MV} ${WRKSRC}/lib/libc.so.new ${WRKSRC}/lib/libc.so
+
+do-install:
+ (cd ${WRKSRC} && tar --exclude '*.orig' -cf - *) \
+ | (cd ${PREFIX}/${TARGET_PLATFORM} && tar xf -)
+.include <bsd.port.mk>