aboutsummaryrefslogtreecommitdiff
path: root/devel/allegro-devel/files
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-03-30 03:04:33 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-03-30 03:04:33 +0000
commitf89a6b459429792c4da8df43a2448f7a1313ea0f (patch)
tree51e5a0614c19b70096a9ce5bb833ee73b3c736e3 /devel/allegro-devel/files
parent9fdbea032b7fb62be43204e588d8001509e9def9 (diff)
downloadports-f89a6b459429792c4da8df43a2448f7a1313ea0f.tar.gz
ports-f89a6b459429792c4da8df43a2448f7a1313ea0f.zip
Notes
Diffstat (limited to 'devel/allegro-devel/files')
-rw-r--r--devel/allegro-devel/files/patch-configure.in18
-rw-r--r--devel/allegro-devel/files/patch-makefile.in56
-rw-r--r--devel/allegro-devel/files/patch-misc::allegro-config.in11
-rw-r--r--devel/allegro-devel/files/patch-misc::deplib.sh8
4 files changed, 63 insertions, 30 deletions
diff --git a/devel/allegro-devel/files/patch-configure.in b/devel/allegro-devel/files/patch-configure.in
index 3504cae06a03..46f3f0e2aaff 100644
--- a/devel/allegro-devel/files/patch-configure.in
+++ b/devel/allegro-devel/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig Thu Jul 4 05:17:59 2002
-+++ configure.in Wed Nov 6 02:19:16 2002
-@@ -169,12 +169,12 @@
+--- configure.in.orig Wed Oct 23 08:08:26 2002
++++ configure.in Sun Nov 10 00:24:54 2002
+@@ -183,12 +183,12 @@
TARGET_ARCH=
fi
if test "X$allegro_cv_support_fomit_frame_pointer" = "Xyes"; then
@@ -13,10 +13,10 @@
ALLEGRO_DEBUG_CFLAGS="-g $WFLAGS -DDEBUGMODE"
- ALLEGRO_PROFILE_CFLAGS="-pg $TARGET_ARCH -O2 -funroll-loops -ffast-math $WFLAGS"
+ ALLEGRO_PROFILE_CFLAGS="-pg $TARGET_ARCH $CFLAGS -funroll-loops -ffast-math $WFLAGS"
- if test "$allegro_cv_support_asm" != i386; then
- CFLAGS="$CFLAGS -DALLEGRO_USE_C"
- ALLEGRO_DEBUG_CFLAGS="$ALLEGRO_DEBUG_CFLAGS -DALLEGRO_USE_C"
-@@ -226,8 +226,8 @@
+ if test "X$allegro_cv_can_use_pipe" = "Xyes"; then
+ CFLAGS="-pipe $CFLAGS"
+ ALLEGRO_DEBUG_CFLAGS="-pipe $ALLEGRO_DEBUG_CFLAGS"
+@@ -245,8 +245,8 @@
LINK_WITH_STATIC_LIBS=yes
allegro_static_libraries=yes
else
@@ -27,7 +27,7 @@
LINK_WITH_STATIC_LIBS=no
allegro_shared_libraries=yes
fi
-@@ -254,13 +254,13 @@
+@@ -273,13 +273,13 @@
fi
if test "X$allegro_shared_libraries" = "Xyes"; then
if test "X$allegro_build_normal_library" = "Xyes"; then
@@ -44,7 +44,7 @@
fi
fi
AC_SUBST(ALLEGRO_LIB_TARGETS)
-@@ -504,7 +504,7 @@
+@@ -550,7 +550,7 @@
${MAKE-make} depend
else
AC_MSG_WARN([Non-GNU make detected, trying gmake to build dependencies.])
diff --git a/devel/allegro-devel/files/patch-makefile.in b/devel/allegro-devel/files/patch-makefile.in
index e4a8c951e1c4..67f7668497eb 100644
--- a/devel/allegro-devel/files/patch-makefile.in
+++ b/devel/allegro-devel/files/patch-makefile.in
@@ -1,8 +1,17 @@
---- makefile.in.orig Thu Jul 4 05:20:02 2002
-+++ makefile.in Wed Nov 6 02:02:31 2002
-@@ -28,10 +28,10 @@
- LIBDIR = lib/unix
+--- makefile.in.orig Wed Oct 23 08:08:26 2002
++++ makefile.in Sun Nov 10 23:37:39 2002
+@@ -20,7 +20,7 @@
+ mandir = @mandir@
+ libdir = @libdir@
+ modulebasedir = @libdir@/allegro
+-moduledir = $(modulebasedir)/$(shared_major_minor)
++moduledir = $(modulebasedir)/$(shared_version)
+
+ EXE =
+ OBJ = .o
+@@ -29,13 +29,14 @@
INFO_DIR = $(infodir)/dir
+ DESTDIR =
-ACLOCAL = aclocal
+ACLOCAL = true
@@ -14,7 +23,11 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -249,6 +249,11 @@
++INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_INFO = @INSTALL_INFO@
+
+@@ -262,6 +263,11 @@
all: lib modules programs docs
lib: $(ALLEGRO_LIB_TARGETS)
@@ -26,24 +39,33 @@
modules: $(ALLEGRO_MODULE_TARGETS)
-@@ -332,9 +337,9 @@
+@@ -349,35 +355,37 @@
fi; \
done
@for l in alleg alld allp; do \
- if test -f $(LIBDIR)/lib$${l}-$(shared_version).so; then \
-- echo Installing $(LIBDIR)/lib$${l}-$(shared_version).so to $(libdir); \
-- $(INSTALL_DATA) $(LIBDIR)/lib$${l}-$(shared_version).so $(libdir)/; \
+- echo Installing $(LIBDIR)/lib$${l}-$(shared_version).so to $(DESTDIR)$(libdir); \
+- $(INSTALL_DATA) $(LIBDIR)/lib$${l}-$(shared_version).so $(DESTDIR)$(libdir)/; \
+ if test -f $(LIBDIR)/lib$${l}.so.$(shared_version); then \
+ echo Installing $(LIBDIR)/lib$${l}.so.$(shared_version) to $(libdir); \
-+ $(INSTALL_DATA) $(LIBDIR)/lib$${l}.so.$(shared_version) $(libdir)/; \
- $(INSTALL_DATA) $(LIBDIR)/lib$${l}_unsharable.a $(libdir)/; \
++ $(INSTALL_PROGRAM) $(LIBDIR)/lib$${l}.so.$(shared_version) $(libdir)/; \
+ $(INSTALL_DATA) $(LIBDIR)/lib$${l}_unsharable.a $(DESTDIR)$(libdir)/; \
fi; \
done
-@@ -347,20 +352,20 @@
+ @if test -n "$(ALLEGRO_MODULE_TARGETS)"; then \
+ $(mkinstalldirs) $(DESTDIR)$(moduledir); \
+- for m in $(ALLEGRO_MODULE_TARGETS) modules.lst; do \
++ for m in $(ALLEGRO_MODULE_TARGETS); do \
+ echo Installing $$m to $(DESTDIR)$(moduledir); \
+- $(INSTALL_DATA) $$m $(DESTDIR)$(moduledir)/; \
++ $(INSTALL_PROGRAM) $$m $(DESTDIR)$(moduledir)/; \
+ done; \
++ echo Installing modules.lst to $(DESTDIR)$(moduledir); \
++ $(INSTALL_DATA) modules.lst $(DESTDIR)$(moduledir)/; \
fi
- $(mkinstalldirs) $(bindir)
- @echo Installing allegro-config to $(bindir)
-- @$(INSTALL_PROGRAM) allegro-config $(bindir)
+ $(mkinstalldirs) $(DESTDIR)$(bindir)
+ @echo Installing allegro-config to $(DESTDIR)$(bindir)
+- @$(INSTALL_PROGRAM) allegro-config $(DESTDIR)$(bindir)
- @if test -n "$(LIBDIR)/liball*-$(shared_version).so"; then \
- (cat /etc/ld.so.conf | grep $(libdir) >/dev/null || \
- test $(libdir) = /lib || test $(libdir) = /usr/lib) \
@@ -54,7 +76,7 @@
- echo "$(libdir) each time you want to run an Allegro program." ; \
- ) ; \
- fi
-+ @$(INSTALL) allegro-config $(bindir)
++ @$(INSTALL_SCRIPT) allegro-config $(DESTDIR)$(bindir)
+# @if test -n "$(LIBDIR)/liball*-$(shared_version).so"; then \
+# (cat /etc/ld.so.conf | grep $(libdir) >/dev/null || \
+# test $(libdir) = /lib || test $(libdir) = /usr/lib) \
@@ -66,8 +88,8 @@
+# ) ; \
+# fi
@for l in alleg alld allp; do \
-- if test -f $(libdir)/lib$${l}-$(shared_version).so -a \! -L $(libdir)/lib$${l}.so.${shared_major_minor}; then \
-- (cd $(libdir); ln -s lib$${l}-$(shared_version).so lib$${l}.so.${shared_major_minor}); \
+- if test -f $(DESTDIR)$(libdir)/lib$${l}-$(shared_version).so -a \! -h $(DESTDIR)$(libdir)/lib$${l}.so.${shared_major_minor}; then \
+- (cd $(DESTDIR)$(libdir); ln -s lib$${l}-$(shared_version).so lib$${l}.so.${shared_major_minor}); \
+ if test -f $(libdir)/lib$${l}.so.$(shared_version) -a \! -L $(libdir)/lib$${l}.so; then \
+ (cd $(libdir); ln -s lib$${l}.so.$(shared_version) lib$${l}.so); \
fi; \
diff --git a/devel/allegro-devel/files/patch-misc::allegro-config.in b/devel/allegro-devel/files/patch-misc::allegro-config.in
new file mode 100644
index 000000000000..d060f8fd3641
--- /dev/null
+++ b/devel/allegro-devel/files/patch-misc::allegro-config.in
@@ -0,0 +1,11 @@
+--- misc/allegro-config.in.orig Wed Oct 23 08:10:01 2002
++++ misc/allegro-config.in Mon Nov 11 18:41:09 2002
+@@ -167,7 +167,7 @@
+ if test "$static_libs" = "yes"; then
+ echo $libdirs $allegro_ldflags -l${lib_type} $allegro_libs
+ else
+- echo $libdirs $allegro_ldflags -l${lib_type}-${version} -l${lib_type}_unsharable
++ echo $libdirs $allegro_ldflags -l${lib_type} -l${lib_type}_unsharable
+ fi
+ fi
+
diff --git a/devel/allegro-devel/files/patch-misc::deplib.sh b/devel/allegro-devel/files/patch-misc::deplib.sh
index 499f6d447aa0..3c3a1f7b4078 100644
--- a/devel/allegro-devel/files/patch-misc::deplib.sh
+++ b/devel/allegro-devel/files/patch-misc::deplib.sh
@@ -1,5 +1,5 @@
---- misc/deplib.sh.orig Thu Jul 4 05:18:01 2002
-+++ misc/deplib.sh Tue Nov 5 22:56:54 2002
+--- misc/deplib.sh.orig Wed Oct 23 08:08:27 2002
++++ misc/deplib.sh Sun Nov 10 00:40:21 2002
@@ -10,7 +10,7 @@
staticlib="lib${1}.a"
staticobj="\$(${2}_OBJECTS)"
@@ -13,8 +13,8 @@
echo " rm -f \$@"
# gf: This bit is obviously gcc-specific
# eb: Yes, but the GNU C Compiler doesn't always spell 'gcc'
-- echo " \$(CC) -shared -o \$@ ${shareobj} \$(LDFLAGS) -Wl,-soname,lib${1}.so.\$(shared_major_minor) \$(LIBS)"
-+ echo " \$(CC) -shared -o \$@ ${shareobj} \$(LDFLAGS) -Wl,-soname,lib${1}.so.\$(shared_version) \$(LIBS)"
+- echo " \$(CC) -shared -o \$@ ${shareobj} \$(LDFLAGS) -Wl,-h,lib${1}.so.\$(shared_major_minor) \$(LIBS)"
++ echo " \$(CC) -shared -o \$@ ${shareobj} \$(LDFLAGS) -Wl,-h,lib${1}.so.\$(shared_version) \$(LIBS)"
echo ""
echo "\$(LIBDIR)/${unsharelib}: ${unshareobj}"
echo " rm -f \$@"