aboutsummaryrefslogtreecommitdiff
path: root/devel/allegro
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-07-24 13:54:46 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-07-24 13:54:46 +0000
commit14c83eb7eeb622d1b0e6b5a8106231ab21e0e4b7 (patch)
tree3d2f136f4fd759414a1a007c350140427fdc0f91 /devel/allegro
parent8eaacd4074286e2f40052fe1f15dacb0a46c5e6c (diff)
downloadports-14c83eb7eeb622d1b0e6b5a8106231ab21e0e4b7.tar.gz
ports-14c83eb7eeb622d1b0e6b5a8106231ab21e0e4b7.zip
Notes
Diffstat (limited to 'devel/allegro')
-rw-r--r--devel/allegro/Makefile3
-rw-r--r--devel/allegro/Makefile.man18
-rw-r--r--devel/allegro/distinfo6
-rw-r--r--devel/allegro/files/patch-makefile.in14
-rw-r--r--devel/allegro/pkg-plist1
5 files changed, 20 insertions, 22 deletions
diff --git a/devel/allegro/Makefile b/devel/allegro/Makefile
index edcacb269338..42be54b8909b 100644
--- a/devel/allegro/Makefile
+++ b/devel/allegro/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= allegro
-DISTVERSION= 4.2.1
-PORTREVISION= 1
+DISTVERSION= 4.2.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= alleg
diff --git a/devel/allegro/Makefile.man b/devel/allegro/Makefile.man
index d1b5cab1b31f..cf3e66e24c6f 100644
--- a/devel/allegro/Makefile.man
+++ b/devel/allegro/Makefile.man
@@ -82,7 +82,7 @@ MAN3= ALLEGRO_DATE.3 ALLEGRO_DATE_STR.3 ALLEGRO_SUB_VERSION.3 \
fixtorad_r.3 fixup_datafile.3 fli_bitmap.3 fli_bmp_dirty_from.3 \
fli_bmp_dirty_to.3 fli_frame.3 fli_pal_dirty_from.3 \
fli_pal_dirty_to.3 fli_palette.3 fli_timer.3 floodfill.3 \
- flush_config_file.3 font.3 for_each_file_ex.3 \
+ flush_config_file.3 font.3 font_has_alpha.3 for_each_file_ex.3 \
free_audio_stream_buffer.3 free_config_entries.3 \
free_lzss_pack_data.3 free_lzss_unpack_data.3 \
freeze_mouse_flag.3 ftofix.3 generate_332_palette.3 \
@@ -135,7 +135,7 @@ MAN3= ALLEGRO_DATE.3 ALLEGRO_DATE_STR.3 ALLEGRO_SUB_VERSION.3 \
is_color_font.3 is_compatible_font.3 is_inside_bitmap.3 \
is_linear_bitmap.3 is_memory_bitmap.3 is_mono_font.3 \
is_planar_bitmap.3 is_relative_filename.3 is_same_bitmap.3 \
- is_screen_bitmap.3 is_sub_bitmap.3 is_system_bitmap.3 \
+ is_screen_bitmap.3 is_sub_bitmap.3 is_system_bitmap.3 is_trans_font.3 \
is_video_bitmap.3 is_windowed_mode.3 itofix.3 joy.3 key.3 \
key_led_flag.3 key_shifts.3 keyboard_callback.3 \
keyboard_lowlevel_callback.3 keyboard_needs_poll.3 \
@@ -158,7 +158,7 @@ MAN3= ALLEGRO_DATE.3 ALLEGRO_DATE_STR.3 ALLEGRO_SUB_VERSION.3 \
matrix_to_quat.3 merge_fonts.3 midi_loop_end.3 midi_loop_start.3 \
midi_meta_callback.3 midi_msg_callback.3 midi_out.3 midi_pause.3 \
midi_pos.3 midi_recorder.3 midi_resume.3 midi_seek.3 \
- midi_sysex_callback.3 midi_time.3 mouse_b.3 mouse_callback.3 \
+ midi_sysex_callback.3 midi_time.3 mouse_b.3 mouse_w.3 mouse_callback.3 \
mouse_needs_poll.3 mouse_pos.3 mouse_sprite.3 mouse_x.3 \
mouse_x_focus.3 mouse_y.3 mouse_y_focus.3 mouse_z.3 \
need_uconvert.3 next_fli_frame.3 normalize_vector.3 \
@@ -170,17 +170,17 @@ MAN3= ALLEGRO_DATE.3 ALLEGRO_DATE_STR.3 ALLEGRO_SUB_VERSION.3 \
pack_fopen_chunk.3 pack_fopen_vtable.3 pack_fputs.3 pack_fread.3 \
pack_fseek.3 pack_fwrite.3 pack_getc.3 pack_igetl.3 pack_igetw.3 \
pack_iputl.3 pack_iputw.3 pack_mgetl.3 pack_mgetw.3 pack_mputl.3 \
- pack_mputw.3 pack_putc.3 packfile_password.3 palette_color.3 \
- persp_project.3 persp_project_f.3 pivot_scaled_sprite.3 \
- pivot_scaled_sprite_v_flip.3 pivot_sprite.3 \
+ pack_mputw.3 pack_putc.3 pack_ungetc.3 packfile_password.3 \
+ palette_color.3 persp_project.3 persp_project_f.3 \
+ pivot_scaled_sprite.3 pivot_scaled_sprite_v_flip.3 pivot_sprite.3 \
pivot_sprite_v_flip.3 play_audio_stream.3 play_fli.3 \
play_looped_midi.3 play_memory_fli.3 play_midi.3 play_sample.3 \
poll_joystick.3 poll_keyboard.3 poll_mouse.3 poll_scroll.3 \
polygon.3 polygon3d.3 polygon3d_f.3 polygon_z_normal.3 \
polygon_z_normal_f.3 pop_config_state.3 popup_dialog.3 \
- position_dialog.3 position_mouse.3 position_mouse_z.3 \
- push_config_state.3 put_backslash.3 putpixel.3 qnx_get_window.3 \
- qscale_matrix.3 qscale_matrix_f.3 qtranslate_matrix.3 \
+ position_dialog.3 position_mouse.3 position_mouse_w.3 \
+ position_mouse_z.3 push_config_state.3 put_backslash.3 putpixel.3 \
+ qnx_get_window.3 qscale_matrix.3 qscale_matrix_f.3 qtranslate_matrix.3 \
qtranslate_matrix_f.3 quad3d.3 quad3d_f.3 quat_interpolate.3 \
quat_mul.3 quat_slerp.3 quat_to_matrix.3 radtofix_r.3 \
read_sound_input.3 readkey.3 reallocate_voice.3 rect.3 \
diff --git a/devel/allegro/distinfo b/devel/allegro/distinfo
index a3a13dc1e7d2..6a256069f820 100644
--- a/devel/allegro/distinfo
+++ b/devel/allegro/distinfo
@@ -1,3 +1,3 @@
-MD5 (allegro-4.2.1.tar.gz) = 0a09d0144ee8652fb8fa00f6cbb324fe
-SHA256 (allegro-4.2.1.tar.gz) = a800a4c61db448e327c13b898fa9bdc00bea43319266a27ad37435f68c5d414b
-SIZE (allegro-4.2.1.tar.gz) = 3107022
+MD5 (allegro-4.2.2.tar.gz) = a2311287c8c94d275871a063f52d2048
+SHA256 (allegro-4.2.2.tar.gz) = 9b25a2fcc48d2d44843687b24a8f60c1b3c107fc39dee7ebfc675c2008a73e42
+SIZE (allegro-4.2.2.tar.gz) = 3164413
diff --git a/devel/allegro/files/patch-makefile.in b/devel/allegro/files/patch-makefile.in
index ece0309c3a0e..89e7e2189e73 100644
--- a/devel/allegro/files/patch-makefile.in
+++ b/devel/allegro/files/patch-makefile.in
@@ -1,15 +1,13 @@
---- makefile.in.orig Sat Apr 8 14:07:28 2006
-+++ makefile.in Mon Dec 18 12:35:59 2006
-@@ -29,12 +29,13 @@
+--- makefile.in.orig Fri Jun 15 22:52:28 2007
++++ makefile.in Fri Jul 13 14:52:12 2007
+@@ -29,11 +29,12 @@
INFO_DIR = $(infodir)/dir
DESTDIR =
-ACLOCAL = aclocal
-AUTOCONF = autoconf
--AUTOHEADER = autoheader
+ACLOCAL = true
+AUTOCONF = true
-+AUTOHEADER = true
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -17,7 +15,7 @@
INSTALL_DATA = @INSTALL_DATA@
INSTALL_INFO = @INSTALL_INFO@
-@@ -354,6 +355,11 @@
+@@ -352,6 +353,11 @@
endif
lib: $(ALLEGRO_LIB_TARGETS)
@@ -29,7 +27,7 @@
modules: $(ALLEGRO_MODULE_TARGETS)
-@@ -465,9 +471,9 @@
+@@ -463,9 +469,9 @@
fi; \
done
@for l in alleg alld allp; do \
@@ -42,7 +40,7 @@
$(INSTALL_DATA) $(LIBDIR)/lib$${l}_unsharable.a $(DESTDIR)$(libdir)/; \
fi; \
done
-@@ -481,20 +487,10 @@
+@@ -479,20 +485,10 @@
fi
$(mkinstalldirs) $(DESTDIR)$(bindir)
@echo Installing allegro-config to $(DESTDIR)$(bindir)
diff --git a/devel/allegro/pkg-plist b/devel/allegro/pkg-plist
index 683321abbc22..2c0c66ddc7a5 100644
--- a/devel/allegro/pkg-plist
+++ b/devel/allegro/pkg-plist
@@ -68,6 +68,7 @@ include/allegro/platform/albcc32.h
include/allegro/platform/albecfg.h
include/allegro/platform/albeos.h
include/allegro/platform/aldjgpp.h
+include/allegro/platform/aldmc.h
include/allegro/platform/aldos.h
include/allegro/platform/almac.h
include/allegro/platform/almaccfg.h