aboutsummaryrefslogtreecommitdiff
path: root/devel/android-tools-fastboot-devel/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-06-18 22:45:34 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-06-18 22:45:34 +0000
commit17b8d562a75297ff880862f094d2c8b893616334 (patch)
tree003f8714585df32697d9b6439421ce4e46848009 /devel/android-tools-fastboot-devel/Makefile
parentf536135538dc07ad71ce2dd09c3b339bf2176550 (diff)
Notes
Diffstat (limited to 'devel/android-tools-fastboot-devel/Makefile')
-rw-r--r--devel/android-tools-fastboot-devel/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/devel/android-tools-fastboot-devel/Makefile b/devel/android-tools-fastboot-devel/Makefile
new file mode 100644
index 000000000000..a029081b3841
--- /dev/null
+++ b/devel/android-tools-fastboot-devel/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+DISTVERSION= m-preview-122
+DISTVERSIONSUFFIX= -g53d504f
+PORTREVISION= 0
+PKGNAMESUFFIX= -devel
+
+GH_TAGNAME= m-preview-36-gb9408ad:extras \
+ m-preview-1-g06d4551:libselinux
+
+CONFLICTS_INSTALL= ${PORTNAME}-[0-9]*
+
+MASTERDIR= ${.CURDIR}/../android-tools-fastboot
+DISTINFO_FILE= ${.CURDIR}/distinfo
+MAKEFILE= ${.CURDIR}/files/Makefile
+EXTRA_PATCHES+= ${.CURDIR}/files/patch-*
+
+USES= compiler:c++11-lib
+CFLAGS+= -DFASTBOOT_REVISION='\"${DISTVERSIONFULL}\"'
+
+.include "${MASTERDIR}/Makefile"