aboutsummaryrefslogtreecommitdiff
path: root/devel/android-tools-simpleperf
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-09-26 20:25:34 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-09-26 20:25:34 +0000
commit137926f29177accf5136523ad2145b7f00d7d60e (patch)
tree7bf5ab5d8c6921de2392650e7d9eb336cb94978f /devel/android-tools-simpleperf
parent08140ceea2b8b6b73a1c2d366633a21d1beb8c4d (diff)
downloadports-137926f29177accf5136523ad2145b7f00d7d60e.tar.gz
ports-137926f29177accf5136523ad2145b7f00d7d60e.zip
Notes
Diffstat (limited to 'devel/android-tools-simpleperf')
-rw-r--r--devel/android-tools-simpleperf/Makefile8
-rw-r--r--devel/android-tools-simpleperf/distinfo12
-rw-r--r--devel/android-tools-simpleperf/files/Makefile7
3 files changed, 15 insertions, 12 deletions
diff --git a/devel/android-tools-simpleperf/Makefile b/devel/android-tools-simpleperf/Makefile
index 17f6623bc29d..e7c2ac421f31 100644
--- a/devel/android-tools-simpleperf/Makefile
+++ b/devel/android-tools-simpleperf/Makefile
@@ -2,8 +2,8 @@
PORTNAME= android-tools-simpleperf
DISTVERSIONPREFIX= android-
-DISTVERSION= m-preview-136
-DISTVERSIONSUFFIX= -g89a2254
+DISTVERSION= m-preview-219
+DISTVERSIONSUFFIX= -gaf995fe
CATEGORIES= devel
MAINTAINER= jbeich@FreeBSD.org
@@ -17,8 +17,8 @@ USE_GITHUB= yes
GH_ACCOUNT= android:bionic,core jbeich
GH_PROJECT= platform_bionic:bionic platform_system_core:core \
platform_system_extras
-GH_TAGNAME= ${DISTVERSIONFULL:C/-[0-9].*//}-232-gb4f2112:bionic \
- ${DISTVERSIONFULL:C/-[0-9].*//}-868-gb81c410:core
+GH_TAGNAME= ${DISTVERSIONFULL:C/-[0-9].*//}-357-g55f87a0:bionic \
+ ${DISTVERSIONFULL:C/-[0-9].*//}-1254-gfca4821:core
USES= compiler:c++11-lib uidfix
BUILD_WRKSRC= ${WRKSRC}/simpleperf
diff --git a/devel/android-tools-simpleperf/distinfo b/devel/android-tools-simpleperf/distinfo
index cfdd3a2e4b0e..0507c81879be 100644
--- a/devel/android-tools-simpleperf/distinfo
+++ b/devel/android-tools-simpleperf/distinfo
@@ -1,6 +1,6 @@
-SHA256 (jbeich-platform_system_extras-android-m-preview-136-g89a2254_GH0.tar.gz) = 33813515ba14743085b8e95a4a74025ac4cefd7d308d5870cc8e279ef5380d4a
-SIZE (jbeich-platform_system_extras-android-m-preview-136-g89a2254_GH0.tar.gz) = 665360
-SHA256 (android-platform_bionic-android-m-preview-232-gb4f2112_GH0.tar.gz) = 88767af6ed1b4377c03aee44e61c175f69decc9169eea2b39661c940186eec5e
-SIZE (android-platform_bionic-android-m-preview-232-gb4f2112_GH0.tar.gz) = 3438328
-SHA256 (android-platform_system_core-android-m-preview-868-gb81c410_GH0.tar.gz) = e013cf5538e25d8123bb7e423ab4269826f74d0af3d44e3e316942c2b1b5a362
-SIZE (android-platform_system_core-android-m-preview-868-gb81c410_GH0.tar.gz) = 1335909
+SHA256 (jbeich-platform_system_extras-android-m-preview-219-gaf995fe_GH0.tar.gz) = e8d797e8764c693ba3f5b312368815747c9c331e7d5d2c71068ab99fedff6e29
+SIZE (jbeich-platform_system_extras-android-m-preview-219-gaf995fe_GH0.tar.gz) = 76449581
+SHA256 (android-platform_bionic-android-m-preview-357-g55f87a0_GH0.tar.gz) = bb0a72a7d84c2b18d5076581f97ac1c239329ee64f5150082f740f911be64a03
+SIZE (android-platform_bionic-android-m-preview-357-g55f87a0_GH0.tar.gz) = 3462941
+SHA256 (android-platform_system_core-android-m-preview-1254-gfca4821_GH0.tar.gz) = 0368607e5bc8e777746658f37be59d9f6c356d1265b24c0c128054c8d1b958eb
+SIZE (android-platform_system_core-android-m-preview-1254-gfca4821_GH0.tar.gz) = 1361953
diff --git a/devel/android-tools-simpleperf/files/Makefile b/devel/android-tools-simpleperf/files/Makefile
index 9e9f030e5ad9..a8300e15e100 100644
--- a/devel/android-tools-simpleperf/files/Makefile
+++ b/devel/android-tools-simpleperf/files/Makefile
@@ -10,7 +10,6 @@ SRCS+= cmd_help.cpp
SRCS+= cmd_report.cpp
SRCS+= command.cpp
SRCS+= dso.cpp
-SRCS+= environment_fake.cpp
SRCS+= event_attr.cpp
SRCS+= event_type.cpp
SRCS+= main.cpp
@@ -26,6 +25,9 @@ TEST_SRCS+= command_test.cpp
TEST_SRCS+= record_test.cpp
TEST_SRCS+= sample_tree_test.cpp
+.PATH: ${.CURDIR}/darwin_support
+SRCS+= darwin_support.cpp
+
# required by simpleperf
.PATH: ${.CURDIR}/../base
SRCS+= file.cpp
@@ -51,7 +53,8 @@ SRCS+= threads.c
CFLAGS+=-D_WITH_GETLINE
CFLAGS+=-DUSE_BIONIC_UAPI_HEADERS
-CFLAGS+=-I${.CURDIR}/darwin_support
+CFLAGS+=-I${.CURDIR}
+CFLAGS+=-I${.CURDIR}/darwin_support/include
CFLAGS+=-I${.CURDIR}/../include
CFLAGS+=-I${.CURDIR}/../base/include
CFLAGS+=-I${.CURDIR}/../bionic/libc/kernel