aboutsummaryrefslogtreecommitdiff
path: root/devel/anjuta-extras
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /devel/anjuta-extras
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
downloadports-d129587b5d568b0ff5300386f1e1b706c349f38e.tar.gz
ports-d129587b5d568b0ff5300386f1e1b706c349f38e.zip
Notes
Diffstat (limited to 'devel/anjuta-extras')
-rw-r--r--devel/anjuta-extras/Makefile3
-rw-r--r--devel/anjuta-extras/files/patch-plugins_scintilla_aneditor.cxx22
-rw-r--r--devel/anjuta-extras/files/patch-plugins_scintilla_properties_styles.properties25
3 files changed, 49 insertions, 1 deletions
diff --git a/devel/anjuta-extras/Makefile b/devel/anjuta-extras/Makefile
index a9d4aedf85f1..f9dec3f00e03 100644
--- a/devel/anjuta-extras/Makefile
+++ b/devel/anjuta-extras/Makefile
@@ -16,8 +16,9 @@ USES= gettext gmake libtool pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= gtk30 intltool libxml2
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.gnome.anjuta.plugins.scintilla.gschema.xml \
org.gnome.anjuta.plugins.scratchbox.gschema.xml
diff --git a/devel/anjuta-extras/files/patch-plugins_scintilla_aneditor.cxx b/devel/anjuta-extras/files/patch-plugins_scintilla_aneditor.cxx
new file mode 100644
index 000000000000..846195939a5e
--- /dev/null
+++ b/devel/anjuta-extras/files/patch-plugins_scintilla_aneditor.cxx
@@ -0,0 +1,22 @@
+From 959807c25e3547b019448b0877bae54dd6c04a9d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=A9bastien=20Granjoux?= <seb.sfo@free.fr>
+Date: Mon, 11 Nov 2013 10:51:05 +0100
+Subject: bgo #711771 - The edge-column variable is not taken into account by
+ anjuta for scintilla editor
+
+
+diff --git a/plugins/scintilla/aneditor.cxx b/plugins/scintilla/aneditor.cxx
+index 0fa9acc..d61e4e1 100644
+--- plugins/scintilla/aneditor.cxx
++++ plugins/scintilla/aneditor.cxx
+@@ -2656,7 +2656,6 @@ void AnEditor::ReadProperties(const char *fileForExt, char **typedef_hl) {
+ int visibleLines = props->GetInt("visible.policy.lines");
+ SendEditor(SCI_SETVISIBLEPOLICY, visibleStrict | visibleSlop, visibleLines);
+
+- SendEditor(SCI_SETEDGECOLUMN, props->GetInt("edge.column", 0));
+ SendEditor(SCI_SETEDGEMODE, props->GetInt("edge.mode", EDGE_NONE));
+ SendEditor(SCI_SETEDGECOLOUR,
+ ColourOfProperty(props, "edge.colour", ColourDesired(0xff, 0xda, 0xda)));
+--
+cgit v0.10.1
+
diff --git a/devel/anjuta-extras/files/patch-plugins_scintilla_properties_styles.properties b/devel/anjuta-extras/files/patch-plugins_scintilla_properties_styles.properties
new file mode 100644
index 000000000000..6820dbfaf5ca
--- /dev/null
+++ b/devel/anjuta-extras/files/patch-plugins_scintilla_properties_styles.properties
@@ -0,0 +1,25 @@
+From 088d3da478e876836efb386bfafd0b23c0de8d82 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=A9bastien=20Granjoux?= <seb.sfo@free.fr>
+Date: Sat, 9 Nov 2013 22:34:18 +0100
+Subject: cintilla: bgo #690373 - The syntax-highlighting for Gtk types does
+ not work from version 3.x
+
+
+diff --git a/plugins/scintilla/properties/styles.properties b/plugins/scintilla/properties/styles.properties
+index 6d6e455..3e5331f 100644
+--- plugins/scintilla/properties/styles.properties
++++ plugins/scintilla/properties/styles.properties
+@@ -8222,8 +8222,8 @@ keywords.$(file.patterns.yaml)=true false yes no
+ style.cpp.17=$(style.anjuta.comment)
+ # Comment keyword error
+ style.cpp.18=$(style.anjuta.comment)
+-# Libraries symbols
+-#style.cpp.19=$(style.anjuta.syskeyword)
++# Libraries symbols (needed to highlight library functions by example GTK+)
++ style.cpp.19=$(style.anjuta.syskeyword)
+ # Raw strings for C++0x
+ style.cpp.20=$(style.anjuta.string)
+ # Triple-quoted strings for Vala
+--
+cgit v0.10.1
+