aboutsummaryrefslogtreecommitdiff
path: root/devel/anjuta-extras
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /devel/anjuta-extras
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Notes
Diffstat (limited to 'devel/anjuta-extras')
-rw-r--r--devel/anjuta-extras/Makefile33
-rw-r--r--devel/anjuta-extras/distinfo3
-rw-r--r--devel/anjuta-extras/pkg-descr3
-rw-r--r--devel/anjuta-extras/pkg-plist108
4 files changed, 147 insertions, 0 deletions
diff --git a/devel/anjuta-extras/Makefile b/devel/anjuta-extras/Makefile
new file mode 100644
index 000000000000..17be5db63d92
--- /dev/null
+++ b/devel/anjuta-extras/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: anjuta-extras
+# Date created: 8 May 2009
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/devel/anjuta-extras/Makefile,v 1.3 2009/09/22 10:27:21 kwm Exp $
+#
+
+PORTNAME= anjuta-extras
+PORTVERSION= 2.28.0
+CATEGORIES= devel
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Extra anjuta plugins.
+
+BUILD_DEPENDS= neato:${PORTSDIR}/graphics/graphviz
+LIB_DEPENDS= anjuta.0:${PORTSDIR}/devel/anjuta
+RUN_DEPENDS= neato:${PORTSDIR}/graphics/graphviz
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= intltool
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include " \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=--disable-plugin-valgrind \
+ --localedir=${PREFIX}/share
+
+GCONF_SCHEMAS= anjuta-editor-scintilla.schemas
+
+.include <bsd.port.mk>
diff --git a/devel/anjuta-extras/distinfo b/devel/anjuta-extras/distinfo
new file mode 100644
index 000000000000..79a77a4979d1
--- /dev/null
+++ b/devel/anjuta-extras/distinfo
@@ -0,0 +1,3 @@
+MD5 (anjuta-extras-2.28.0.tar.bz2) = c67db4abb5a873fdbe8f4fed59b2a9da
+SHA256 (anjuta-extras-2.28.0.tar.bz2) = 7b7aa28ca598e17024a41fb29582e6cf2efcc1a273b00e84994f21900e288b49
+SIZE (anjuta-extras-2.28.0.tar.bz2) = 2939244
diff --git a/devel/anjuta-extras/pkg-descr b/devel/anjuta-extras/pkg-descr
new file mode 100644
index 000000000000..5c0d44664cdd
--- /dev/null
+++ b/devel/anjuta-extras/pkg-descr
@@ -0,0 +1,3 @@
+Extra plugins for the Anjuta IDE.
+
+WWW: http://anjuta.org/
diff --git a/devel/anjuta-extras/pkg-plist b/devel/anjuta-extras/pkg-plist
new file mode 100644
index 000000000000..660a35dda8d4
--- /dev/null
+++ b/devel/anjuta-extras/pkg-plist
@@ -0,0 +1,108 @@
+lib/anjuta/anjuta-class-inheritance.plugin
+lib/anjuta/anjuta-editor.plugin
+lib/anjuta/anjuta-sample.plugin
+lib/anjuta/anjuta-scratchbox.plugin
+lib/anjuta/libanjuta-class-inheritance.a
+lib/anjuta/libanjuta-class-inheritance.la
+lib/anjuta/libanjuta-class-inheritance.so
+lib/anjuta/libanjuta-class-inheritance.so.0
+lib/anjuta/libanjuta-editor.a
+lib/anjuta/libanjuta-editor.la
+lib/anjuta/libanjuta-editor.so
+lib/anjuta/libanjuta-editor.so.0
+lib/anjuta/libanjuta-profiler.a
+lib/anjuta/libanjuta-profiler.la
+lib/anjuta/libanjuta-profiler.so
+lib/anjuta/libanjuta-profiler.so.0
+lib/anjuta/libanjuta-sample.a
+lib/anjuta/libanjuta-sample.la
+lib/anjuta/libanjuta-sample.so
+lib/anjuta/libanjuta-sample.so.0
+lib/anjuta/libanjuta-scratchbox.a
+lib/anjuta/libanjuta-scratchbox.la
+lib/anjuta/libanjuta-scratchbox.so
+lib/anjuta/libanjuta-scratchbox.so.0
+lib/anjuta/profiler.plugin
+share/anjuta/glade/anjuta-editor-scintilla.ui
+share/anjuta/glade/anjuta-scratchbox-panel.png
+share/anjuta/glade/anjuta-scratchbox.ui
+share/anjuta/glade/profiler-call-graph.ui
+share/anjuta/glade/profiler-flat-profile.ui
+share/anjuta/glade/profiler-function-call-tree.ui
+share/anjuta/glade/profiler.ui
+share/anjuta/properties/anjuta.properties
+share/anjuta/properties/styles.properties
+share/anjuta/properties/user.properties
+share/anjuta/ui/anjuta-sample.ui
+share/anjuta/ui/profiler.xml
+share/locale/ar/LC_MESSAGES/anjuta-extras.mo
+share/locale/az/LC_MESSAGES/anjuta-extras.mo
+share/locale/be/LC_MESSAGES/anjuta-extras.mo
+share/locale/be@latin/LC_MESSAGES/anjuta-extras.mo
+share/locale/bg/LC_MESSAGES/anjuta-extras.mo
+share/locale/ca/LC_MESSAGES/anjuta-extras.mo
+share/locale/cs/LC_MESSAGES/anjuta-extras.mo
+share/locale/da/LC_MESSAGES/anjuta-extras.mo
+share/locale/de/LC_MESSAGES/anjuta-extras.mo
+share/locale/dz/LC_MESSAGES/anjuta-extras.mo
+share/locale/el/LC_MESSAGES/anjuta-extras.mo
+share/locale/en_CA/LC_MESSAGES/anjuta-extras.mo
+share/locale/en_GB/LC_MESSAGES/anjuta-extras.mo
+share/locale/es/LC_MESSAGES/anjuta-extras.mo
+share/locale/eu/LC_MESSAGES/anjuta-extras.mo
+share/locale/fi/LC_MESSAGES/anjuta-extras.mo
+share/locale/fr/LC_MESSAGES/anjuta-extras.mo
+share/locale/ga/LC_MESSAGES/anjuta-extras.mo
+share/locale/gl/LC_MESSAGES/anjuta-extras.mo
+share/locale/gu/LC_MESSAGES/anjuta-extras.mo
+share/locale/he/LC_MESSAGES/anjuta-extras.mo
+share/locale/hi/LC_MESSAGES/anjuta-extras.mo
+share/locale/hr/LC_MESSAGES/anjuta-extras.mo
+share/locale/hu/LC_MESSAGES/anjuta-extras.mo
+share/locale/id/LC_MESSAGES/anjuta-extras.mo
+share/locale/it/LC_MESSAGES/anjuta-extras.mo
+share/locale/ja/LC_MESSAGES/anjuta-extras.mo
+share/locale/kn/LC_MESSAGES/anjuta-extras.mo
+share/locale/ko/LC_MESSAGES/anjuta-extras.mo
+share/locale/lt/LC_MESSAGES/anjuta-extras.mo
+share/locale/lv/LC_MESSAGES/anjuta-extras.mo
+share/locale/mk/LC_MESSAGES/anjuta-extras.mo
+share/locale/ml/LC_MESSAGES/anjuta-extras.mo
+share/locale/mr/LC_MESSAGES/anjuta-extras.mo
+share/locale/ms/LC_MESSAGES/anjuta-extras.mo
+share/locale/nb/LC_MESSAGES/anjuta-extras.mo
+share/locale/ne/LC_MESSAGES/anjuta-extras.mo
+share/locale/nl/LC_MESSAGES/anjuta-extras.mo
+share/locale/oc/LC_MESSAGES/anjuta-extras.mo
+share/locale/or/LC_MESSAGES/anjuta-extras.mo
+share/locale/pa/LC_MESSAGES/anjuta-extras.mo
+share/locale/pl/LC_MESSAGES/anjuta-extras.mo
+share/locale/pt/LC_MESSAGES/anjuta-extras.mo
+share/locale/pt_BR/LC_MESSAGES/anjuta-extras.mo
+share/locale/ru/LC_MESSAGES/anjuta-extras.mo
+share/locale/rw/LC_MESSAGES/anjuta-extras.mo
+share/locale/si/LC_MESSAGES/anjuta-extras.mo
+share/locale/sk/LC_MESSAGES/anjuta-extras.mo
+share/locale/sl/LC_MESSAGES/anjuta-extras.mo
+share/locale/sq/LC_MESSAGES/anjuta-extras.mo
+share/locale/sr/LC_MESSAGES/anjuta-extras.mo
+share/locale/sr@latin/LC_MESSAGES/anjuta-extras.mo
+share/locale/sv/LC_MESSAGES/anjuta-extras.mo
+share/locale/te/LC_MESSAGES/anjuta-extras.mo
+share/locale/th/LC_MESSAGES/anjuta-extras.mo
+share/locale/tr/LC_MESSAGES/anjuta-extras.mo
+share/locale/uk/LC_MESSAGES/anjuta-extras.mo
+share/locale/vi/LC_MESSAGES/anjuta-extras.mo
+share/locale/zh_CN/LC_MESSAGES/anjuta-extras.mo
+share/locale/zh_HK/LC_MESSAGES/anjuta-extras.mo
+share/locale/zh_TW/LC_MESSAGES/anjuta-extras.mo
+share/pixmaps/anjuta/anjuta-class-inheritance-plugin-48.png
+share/pixmaps/anjuta/anjuta-class-inheritance-plugin.svg
+share/pixmaps/anjuta/anjuta-editor-scintilla-plugin-48.png
+share/pixmaps/anjuta/anjuta-editor-scintilla-plugin.svg
+share/pixmaps/anjuta/anjuta-profiler-plugin-48.png
+share/pixmaps/anjuta/anjuta-profiler-plugin.svg
+share/pixmaps/anjuta/anjuta-sample-plugin-48.png
+share/pixmaps/anjuta/anjuta-sample-plugin.svg
+share/pixmaps/anjuta/anjuta-scratchbox-48.png
+@dirrm share/anjuta/properties