aboutsummaryrefslogtreecommitdiff
path: root/devel/anjuta
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-29 15:23:10 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-29 15:23:10 +0000
commit9495fdc6a0985ab197cb74dbe403fee63bccf01c (patch)
tree2c79a8165412bab3b0a1150e12efcdf45ab9fd2a /devel/anjuta
parentb80fd5665d588504807089e1a6f49f6a959f8d71 (diff)
downloadports-9495fdc6a0985ab197cb74dbe403fee63bccf01c.tar.gz
ports-9495fdc6a0985ab197cb74dbe403fee63bccf01c.zip
Notes
Diffstat (limited to 'devel/anjuta')
-rw-r--r--devel/anjuta/Makefile3
-rw-r--r--devel/anjuta/distinfo6
-rw-r--r--devel/anjuta/files/patch-plugins_glade_pluginc.c35
3 files changed, 15 insertions, 29 deletions
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index 28b5271df949..87d663eeeba8 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= anjuta
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.2.2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= anjuta
diff --git a/devel/anjuta/distinfo b/devel/anjuta/distinfo
index 42efaca6c958..9269e1fe4160 100644
--- a/devel/anjuta/distinfo
+++ b/devel/anjuta/distinfo
@@ -1,3 +1,3 @@
-MD5 (anjuta-2.2.1.tar.bz2) = 7569935b1b498bd64ff05e38087e7189
-SHA256 (anjuta-2.2.1.tar.bz2) = e569dd0089bdbc333a2fd0342ead82154f44ad4d456165c801cde485756499aa
-SIZE (anjuta-2.2.1.tar.bz2) = 5533408
+MD5 (anjuta-2.2.2.tar.bz2) = ed2e54fdd498db70e5b0bf3d0fed13cd
+SHA256 (anjuta-2.2.2.tar.bz2) = ee7e8c5d9f2b062a28680cdf67e61614073578656688eb0891d9202179e56cf6
+SIZE (anjuta-2.2.2.tar.bz2) = 5542975
diff --git a/devel/anjuta/files/patch-plugins_glade_pluginc.c b/devel/anjuta/files/patch-plugins_glade_pluginc.c
index 569bafe71633..c2bd9847c4cd 100644
--- a/devel/anjuta/files/patch-plugins_glade_pluginc.c
+++ b/devel/anjuta/files/patch-plugins_glade_pluginc.c
@@ -1,5 +1,5 @@
---- plugins/glade/plugin.c 2007/06/20 02:18:37 3013
-+++ plugins/glade/plugin.c 2007/07/07 13:25:08 3048
+--- plugins/glade/plugin.c.orig 2007-10-23 04:24:26.000000000 -0400
++++ plugins/glade/plugin.c 2007-10-29 11:05:01.000000000 -0400
@@ -20,7 +20,7 @@
#include <config.h>
@@ -9,7 +9,7 @@
# include <glade.h>
#else
# if (GLADEUI_VERSION <= 314)
-@@ -54,7 +54,7 @@
+@@ -54,7 +54,7 @@ struct _GladePluginPriv
GtkActionGroup *action_group;
GladeApp *gpw;
GtkWidget *inspector;
@@ -18,7 +18,7 @@
GtkWidget *design_notebook;
#endif
GtkWidget *view_box;
-@@ -428,7 +428,7 @@
+@@ -428,7 +428,7 @@ on_api_help (GladeEditor* editor,
static void
glade_do_close (GladePlugin *plugin, GladeProject *project)
{
@@ -27,20 +27,7 @@
GtkWidget *design_view;
design_view = g_object_get_data (G_OBJECT (project), "design_view");
-@@ -459,7 +459,11 @@
- }
-
- #if (GLADEUI_VERSION >= 330)
-- if (glade_project_get_has_unsaved_changes (project))
-+# if (GLADEUI_VERSION > 331)
-+ if (glade_project_get_modified (project))
-+# else
-+ if (glade_project_get_has_unsaved_changes (project))
-+# endif
- #else
- if (project->changed)
- #endif
-@@ -502,14 +506,14 @@
+@@ -506,14 +506,14 @@ on_glade_project_changed (GtkComboBox *c
{
GladeProject *project;
@@ -57,7 +44,7 @@
design_view = g_object_get_data (G_OBJECT (project), "design_view");
design_pagenum = gtk_notebook_page_num (GTK_NOTEBOOK (plugin->priv->design_notebook),
design_view);
-@@ -713,7 +717,7 @@
+@@ -717,7 +717,7 @@ on_shell_destroy (AnjutaShell *shell, Gl
gtk_container_remove (GTK_CONTAINER (parent), wid);
}
@@ -66,7 +53,7 @@
static void
glade_plugin_add_project (GladePlugin *glade_plugin, GladeProject *project)
{
-@@ -796,7 +800,7 @@
+@@ -800,7 +800,7 @@ activate_plugin (AnjutaPlugin *plugin)
g_object_unref (G_OBJECT (store));
gtk_box_pack_start (GTK_BOX (priv->view_box), priv->projects_combo,
FALSE, FALSE, 0);
@@ -75,7 +62,7 @@
# if (GLADEUI_VERSION >= 330)
priv->inspector = glade_inspector_new ();
-@@ -825,7 +829,7 @@
+@@ -829,7 +829,7 @@ activate_plugin (AnjutaPlugin *plugin)
gtk_notebook_popup_enable (GTK_NOTEBOOK (glade_app_get_editor ()->notebook));
@@ -84,7 +71,7 @@
/* Create design_notebook */
priv->design_notebook = gtk_notebook_new ();
gtk_notebook_set_show_tabs (GTK_NOTEBOOK (priv->design_notebook), FALSE);
-@@ -862,7 +866,7 @@
+@@ -866,7 +866,7 @@ activate_plugin (AnjutaPlugin *plugin)
g_object_ref (glade_app_get_palette ());
g_object_ref (glade_app_get_editor ());
g_object_ref (priv->view_box);
@@ -93,7 +80,7 @@
g_object_ref (priv->design_notebook);
#endif
gtk_widget_show (GTK_WIDGET (glade_app_get_palette ()));
-@@ -884,7 +888,7 @@
+@@ -888,7 +888,7 @@ activate_plugin (AnjutaPlugin *plugin)
"AnjutaGladeEditor", _("Properties"),
"glade-plugin-icon",
ANJUTA_SHELL_PLACEMENT_CENTER, NULL);
@@ -102,7 +89,7 @@
anjuta_shell_add_widget (ANJUTA_PLUGIN (plugin)->shell,
GTK_WIDGET (priv->design_notebook),
"AnjutaGladeDesigner", _("Designer"),
-@@ -935,7 +939,7 @@
+@@ -939,7 +939,7 @@ deactivate_plugin (AnjutaPlugin *plugin)
anjuta_shell_remove_widget (plugin->shell,
GTK_WIDGET (priv->view_box),
NULL);