aboutsummaryrefslogtreecommitdiff
path: root/devel/apache-ant
diff options
context:
space:
mode:
authorErnst de Haan <znerd@FreeBSD.org>2004-01-06 07:16:46 +0000
committerErnst de Haan <znerd@FreeBSD.org>2004-01-06 07:16:46 +0000
commitcf79061ad0f85fd7faaf373749d1dc716ac53cc0 (patch)
tree54b0859f50a0f0382958465dbe868b530a1b5fac /devel/apache-ant
parente7d05a7642ef3299fd2a7f182be1ae50e4bf6120 (diff)
downloadports-cf79061ad0f85fd7faaf373749d1dc716ac53cc0.tar.gz
ports-cf79061ad0f85fd7faaf373749d1dc716ac53cc0.zip
Notes
Diffstat (limited to 'devel/apache-ant')
-rw-r--r--devel/apache-ant/Makefile1
-rw-r--r--devel/apache-ant/files/ant29
-rw-r--r--devel/apache-ant/files/ant.sh.in29
3 files changed, 35 insertions, 24 deletions
diff --git a/devel/apache-ant/Makefile b/devel/apache-ant/Makefile
index dd3d69cb9a3e..971369c32b92 100644
--- a/devel/apache-ant/Makefile
+++ b/devel/apache-ant/Makefile
@@ -7,6 +7,7 @@
PORTNAME= apache-ant
PORTVERSION= 1.6.0
+PORTREVISION= 1
CATEGORIES= devel java
MASTER_SITES= http://apache.mirror.trueserver.nl/dist/ant/binaries/:bin \
http://apache.proserve.nl/dist/ant/binaries/:bin \
diff --git a/devel/apache-ant/files/ant b/devel/apache-ant/files/ant
index 4927ef8832a4..2e3f332951bf 100644
--- a/devel/apache-ant/files/ant
+++ b/devel/apache-ant/files/ant
@@ -1,8 +1,11 @@
#!/bin/sh
#
-# FreeBSD-specific startup script for Jakarta Ant.
+#-*- mode: Fundamental; tab-width: 4; -*-
+# ex:ts=4
#
-# See: http://jakarta.apache.org/ant/
+# FreeBSD-specific startup script for Apache Ant.
+#
+# See: http://ant.apache.org/
#
# $FreeBSD$
#
@@ -81,17 +84,19 @@ for JAR_FILE in "${ANT_LIB}"/*.jar; do
done
# FreeBSD-specific: Add the .jar files from ${PREFIX}/share/java/classes
-for JAR_FILE in "%%PREFIX%%/share/java/classes"/*.jar; do
-
- # If the directory is empty, then the input string is returned
- if [ -f "${JAR_FILE}" ]; then
- if [ -z "${LOCALCLASSPATH}" ]; then
- LOCALCLASSPATH="${JAR_FILE}"
- else
- LOCALCLASSPATH="${JAR_FILE}":"${LOCALCLASSPATH}"
+if [ "${ANT_INCLUDE_SHARED_JARS}" = "YES" ]; then
+ for JAR_FILE in "%%PREFIX%%/share/java/classes"/*.jar; do
+
+ # If the directory is empty, then the input string is returned
+ if [ -f "${JAR_FILE}" ]; then
+ if [ -z "${LOCALCLASSPATH}" ]; then
+ LOCALCLASSPATH="${JAR_FILE}"
+ else
+ LOCALCLASSPATH="${JAR_FILE}":"${LOCALCLASSPATH}"
+ fi
fi
- fi
-done
+ done
+fi
# Add the JDK tools.jar or classes.zip file to the CLASSPATH
if [ -n "${JAVA_HOME}" ]; then
diff --git a/devel/apache-ant/files/ant.sh.in b/devel/apache-ant/files/ant.sh.in
index 4927ef8832a4..2e3f332951bf 100644
--- a/devel/apache-ant/files/ant.sh.in
+++ b/devel/apache-ant/files/ant.sh.in
@@ -1,8 +1,11 @@
#!/bin/sh
#
-# FreeBSD-specific startup script for Jakarta Ant.
+#-*- mode: Fundamental; tab-width: 4; -*-
+# ex:ts=4
#
-# See: http://jakarta.apache.org/ant/
+# FreeBSD-specific startup script for Apache Ant.
+#
+# See: http://ant.apache.org/
#
# $FreeBSD$
#
@@ -81,17 +84,19 @@ for JAR_FILE in "${ANT_LIB}"/*.jar; do
done
# FreeBSD-specific: Add the .jar files from ${PREFIX}/share/java/classes
-for JAR_FILE in "%%PREFIX%%/share/java/classes"/*.jar; do
-
- # If the directory is empty, then the input string is returned
- if [ -f "${JAR_FILE}" ]; then
- if [ -z "${LOCALCLASSPATH}" ]; then
- LOCALCLASSPATH="${JAR_FILE}"
- else
- LOCALCLASSPATH="${JAR_FILE}":"${LOCALCLASSPATH}"
+if [ "${ANT_INCLUDE_SHARED_JARS}" = "YES" ]; then
+ for JAR_FILE in "%%PREFIX%%/share/java/classes"/*.jar; do
+
+ # If the directory is empty, then the input string is returned
+ if [ -f "${JAR_FILE}" ]; then
+ if [ -z "${LOCALCLASSPATH}" ]; then
+ LOCALCLASSPATH="${JAR_FILE}"
+ else
+ LOCALCLASSPATH="${JAR_FILE}":"${LOCALCLASSPATH}"
+ fi
fi
- fi
-done
+ done
+fi
# Add the JDK tools.jar or classes.zip file to the CLASSPATH
if [ -n "${JAVA_HOME}" ]; then