aboutsummaryrefslogtreecommitdiff
path: root/devel/api-sanity-autotest/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-10 02:23:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-10 02:23:59 +0000
commit20420eb9da9771d7c901e257f07777a78d380f29 (patch)
tree50cd7fcbf4416cc470761c89092a466693b377a5 /devel/api-sanity-autotest/Makefile
parent5b6f18bd0216d7123db99cb3d9853c3a26c3fd77 (diff)
downloadports-20420eb9da9771d7c901e257f07777a78d380f29.tar.gz
ports-20420eb9da9771d7c901e257f07777a78d380f29.zip
Notes
Diffstat (limited to 'devel/api-sanity-autotest/Makefile')
-rw-r--r--devel/api-sanity-autotest/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/devel/api-sanity-autotest/Makefile b/devel/api-sanity-autotest/Makefile
new file mode 100644
index 000000000000..77a50c9fba13
--- /dev/null
+++ b/devel/api-sanity-autotest/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: api-sanity-autotest
+# Date created: February 16, 2009
+# Whom: bf <bf1783@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= api-sanity-autotest
+PORTVERSION= 1.8
+CATEGORIES= devel perl5
+MASTER_SITES= http://ispras.linux-foundation.org/images/e/e8/
+DISTFILES= ${PORTNAME:S/^a/A/}-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= bf1783@gmail.com
+COMMENT= Quickly generate sanity tests for the API of a C/C++ shared library
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+PLIST_FILES= bin/${PORTNAME}.pl
+
+CPPFILT?= c++filt
+READELF?= readelf
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e "\%my% { \
+ s%\"c++filt\"%\"${CPPFILT}\"%g; \
+ s%\"readelf\"%\"${READELF}\"%g; \
+ s%\"g++\"%\"${CXX}\"%g; \
+ s%\"gcc\"%\"${CC}\"%g; }" \
+ -e "\%search_for% { \
+ s%\"g++\"%\"${CXX}\"%g; \
+ s%\"gcc\"%\"${CC}\"%g; }" \
+ -e "s% -shared%& -fPIC%g" \
+ ${WRKSRC}/${PORTNAME}.pl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin
+
+test: build
+ @(cd ${WRKSRC} && ./${PORTNAME}.pl -test )
+
+.include <bsd.port.mk>