aboutsummaryrefslogtreecommitdiff
path: root/devel/apiextractor/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2011-12-18 21:58:21 +0000
committerNicola Vitale <nivit@FreeBSD.org>2011-12-18 21:58:21 +0000
commit03d5abef50645c99d09ca6f8f48ddf096f6e87dd (patch)
treea80f3c3effe59ace7ca8fd95211edee2a825ccbd /devel/apiextractor/Makefile
parent29930ba0c5d3756d21c0d22bcf4e489cc2d5e59a (diff)
Notes
Diffstat (limited to 'devel/apiextractor/Makefile')
-rw-r--r--devel/apiextractor/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/apiextractor/Makefile b/devel/apiextractor/Makefile
new file mode 100644
index 000000000000..b0a4def08a18
--- /dev/null
+++ b/devel/apiextractor/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: apiextractor
+# Date created: 2011-03-21
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= apiextractor
+PORTVERSION= 0.10.9
+#PORTREVISION= 0
+CATEGORIES= devel
+MASTER_SITES= http://www.pyside.org/files/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= API Extractor library to build PySide
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xslt.2:${PORTSDIR}/textproc/libxslt
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
+QT_COMPONENTS= gui moc_build qmake_build qtestlib_build \
+ rcc_build uic_build xml xmlpatterns
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+USE_QT_VER= 4
+
+.include <bsd.port.mk>