aboutsummaryrefslogtreecommitdiff
path: root/devel/apiextractor/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-07-04 14:17:13 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-07-04 14:17:13 +0000
commitd736ad0e7f4440d7dd555f1579494c8347b03e47 (patch)
treef24c599cb0c6c7f7c0ddcc21d15ff5536b003c74 /devel/apiextractor/Makefile
parent01a7b2de3a64926cf167f8d86d45e7efb61bc932 (diff)
Notes
Diffstat (limited to 'devel/apiextractor/Makefile')
-rw-r--r--devel/apiextractor/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/devel/apiextractor/Makefile b/devel/apiextractor/Makefile
index adf384b3a228..b7df75ed60c4 100644
--- a/devel/apiextractor/Makefile
+++ b/devel/apiextractor/Makefile
@@ -5,27 +5,26 @@ PORTNAME= apiextractor
PORTVERSION= 0.10.10
PORTREVISION= 2
CATEGORIES= devel
-MASTER_SITES= http://www.pyside.org/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= wg@FreeBSD.org
COMMENT= API Extractor library to build PySide
LICENSE= GPLv2
-BROKEN= Unfetchable
-
BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
-USE_GNOME= libxml2 libxslt
-
-PLIST_SUB= PORTVERSION=${PORTVERSION}
+USE_GITHUB= yes
+GH_ACCOUNT= PySide
+GH_PROJECT= Apiextractor
+#GH_TAG= ${PORTVERSION}
+GH_COMMIT= 4889efc
+USES= cmake
+USE_GNOME= libxml2 libxslt
USE_QT4= gui moc_build qmake_build qtestlib_build \
rcc_build uic_build xml xmlpatterns
-
-USE_BZIP2= yes
-USES= cmake
USE_LDCONFIG= yes
-NO_STAGE= yes
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
.include <bsd.port.mk>