aboutsummaryrefslogtreecommitdiff
path: root/devel/appstream-glib
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /devel/appstream-glib
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'devel/appstream-glib')
-rw-r--r--devel/appstream-glib/Makefile47
-rw-r--r--devel/appstream-glib/distinfo2
-rw-r--r--devel/appstream-glib/pkg-descr4
-rw-r--r--devel/appstream-glib/pkg-plist71
4 files changed, 124 insertions, 0 deletions
diff --git a/devel/appstream-glib/Makefile b/devel/appstream-glib/Makefile
new file mode 100644
index 000000000000..62500eb64bf5
--- /dev/null
+++ b/devel/appstream-glib/Makefile
@@ -0,0 +1,47 @@
+# Created by: FreeBSD GNOME Team <gnome@freebsd.org>
+# $FreeBSD$
+# $MCom: ports/trunk/devel/appstream-glib/Makefile 20031 2014-11-02 21:47:55Z kwm $
+
+PORTNAME= appstream-glib
+PORTVERSION= 0.2.6
+CATEGORIES= devel
+DIST_SUBDIR= gnome3
+
+WRKSRC= ${WRKDIR}/hughsie-appstream-glib-${GH_COMMIT}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Library to help with AppStream metadata
+
+BUILD_DEPENDS= gtkdoc-check:${PORTSDIR}/textproc/gtk-doc
+LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup
+
+GH_ACCOUNT= hughsie
+GH_PROJECT= appstream-glib
+GH_COMMIT= f4f3230
+GH_TAGNAME= ${GH_COMMIT}
+
+USES= autoreconf:build gmake libtool pathfix pkgconfig
+USE_GNOME= gdkpixbuf2 glib20 gtk30 intlhack
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GITHUB= yes
+PATHFIX_MAKEFILEIN= Makefile.am
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 1000000
+LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
+.else
+CONFIGURE_ENV+= LIBARCHIVE_CFLAGS=" " \
+ LIBARCHIVE_LIBS="-larchive"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-Wtype-limits||g' \
+ ${WRKSRC}/configure.ac
+
+pre-configure:
+ cd ${WRKSRC} && ${SETENV} NOCONFIGURE=yes ${SH} ./autogen.sh
+
+.include <bsd.port.mk>
diff --git a/devel/appstream-glib/distinfo b/devel/appstream-glib/distinfo
new file mode 100644
index 000000000000..dfa5076d8a7f
--- /dev/null
+++ b/devel/appstream-glib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/appstream-glib-0.2.6.tar.gz) = 3a0b1827c8b2ba5f315cbe47a44a52c1a87879545fad6d6674b3de8d213579cb
+SIZE (gnome3/appstream-glib-0.2.6.tar.gz) = 1755005
diff --git a/devel/appstream-glib/pkg-descr b/devel/appstream-glib/pkg-descr
new file mode 100644
index 000000000000..b2416f5af589
--- /dev/null
+++ b/devel/appstream-glib/pkg-descr
@@ -0,0 +1,4 @@
+This library provides objects and helper methods to help
+reading and writing AppStream metadata.
+
+WWW: https://github.com/hughsie/appstream-glib/
diff --git a/devel/appstream-glib/pkg-plist b/devel/appstream-glib/pkg-plist
new file mode 100644
index 000000000000..9a9ffe90ab82
--- /dev/null
+++ b/devel/appstream-glib/pkg-plist
@@ -0,0 +1,71 @@
+bin/appstream-builder
+bin/appstream-util
+include/libappstream-builder/appstream-builder.h
+include/libappstream-builder/asb-app.h
+include/libappstream-glib/appstream-glib.h
+include/libappstream-glib/as-app.h
+include/libappstream-glib/as-enums.h
+include/libappstream-glib/as-image.h
+include/libappstream-glib/as-node.h
+include/libappstream-glib/as-problem.h
+include/libappstream-glib/as-provide.h
+include/libappstream-glib/as-release.h
+include/libappstream-glib/as-screenshot.h
+include/libappstream-glib/as-store.h
+include/libappstream-glib/as-tag.h
+include/libappstream-glib/as-utils.h
+include/libappstream-glib/as-version.h
+lib/asb-plugins/libasb_plugin_absorb.a
+lib/asb-plugins/libasb_plugin_absorb.so
+lib/asb-plugins/libasb_plugin_appdata.a
+lib/asb-plugins/libasb_plugin_appdata.so
+lib/asb-plugins/libasb_plugin_blacklist.a
+lib/asb-plugins/libasb_plugin_blacklist.so
+lib/asb-plugins/libasb_plugin_dbus.a
+lib/asb-plugins/libasb_plugin_dbus.so
+lib/asb-plugins/libasb_plugin_desktop.a
+lib/asb-plugins/libasb_plugin_desktop.so
+lib/asb-plugins/libasb_plugin_font.a
+lib/asb-plugins/libasb_plugin_font.so
+lib/asb-plugins/libasb_plugin_gettext.a
+lib/asb-plugins/libasb_plugin_gettext.so
+lib/asb-plugins/libasb_plugin_gir.a
+lib/asb-plugins/libasb_plugin_gir.so
+lib/asb-plugins/libasb_plugin_gresource.a
+lib/asb-plugins/libasb_plugin_gresource.so
+lib/asb-plugins/libasb_plugin_gstreamer.a
+lib/asb-plugins/libasb_plugin_gstreamer.so
+lib/asb-plugins/libasb_plugin_hardcoded.a
+lib/asb-plugins/libasb_plugin_hardcoded.so
+lib/asb-plugins/libasb_plugin_ibus_sql.a
+lib/asb-plugins/libasb_plugin_ibus_sql.so
+lib/asb-plugins/libasb_plugin_ibus_xml.a
+lib/asb-plugins/libasb_plugin_ibus_xml.so
+lib/asb-plugins/libasb_plugin_kde_notifyrc.a
+lib/asb-plugins/libasb_plugin_kde_notifyrc.so
+lib/asb-plugins/libasb_plugin_kde_services.a
+lib/asb-plugins/libasb_plugin_kde_services.so
+lib/asb-plugins/libasb_plugin_metainfo.a
+lib/asb-plugins/libasb_plugin_metainfo.so
+lib/asb-plugins/libasb_plugin_nm.a
+lib/asb-plugins/libasb_plugin_nm.so
+lib/girepository-1.0/AppStreamBuilder-1.0.typelib
+lib/girepository-1.0/AppStreamGlib-1.0.typelib
+lib/libappstream-builder.a
+lib/libappstream-builder.so
+lib/libappstream-builder.so.1
+lib/libappstream-builder.so.1.5.6
+lib/libappstream-glib.a
+lib/libappstream-glib.so
+lib/libappstream-glib.so.1
+lib/libappstream-glib.so.1.5.6
+lib/locale/ru/LC_MESSAGES/appstream-glib.mo
+libdata/pkgconfig/appstream-builder.pc
+libdata/pkgconfig/appstream-glib.pc
+share/aclocal/appstream-xml.m4
+share/bash-completion/completions/appstream-builder
+share/bash-completion/completions/appstream-util
+share/gir-1.0/AppStreamBuilder-1.0.gir
+share/gir-1.0/AppStreamGlib-1.0.gir
+share/installed-tests/appstream-glib/appdata-validate.test
+share/installed-tests/appstream-glib/destdir-check.test